Keyboard Fn defaults question in KDE

Manjaro 5.10. with KDE Plasma 5.23. Desktop with multi monitors. Where I live in Ecuador its very difficult to buy really nice peripherals…plus I am hard on keyboards. Recently got rid of the old Genius for a newer model (most of the key lettering was worn off and it looked really shabby). One buys what is available…So for $15 I got a Genius SlimStar 260, a generic 105 key PC keyboard. Nicer than the old one to type on. Function keys double as media keys. Default is Fn so to use the media keys one must first hold the Fn key. I have done some searching here plus online and I can find no keyboard specific way to change things where the default is media keys and to activate the function key --for example right now I hold F12 and get Yakuake terminal which I use…instead I want to change things where holding the Fn key + F12 I get Yakuake…

I have looked a number of places for a solution to this. Aside from traveling 2 1/2 hours to Quito to buy something better can anyone recommend a better solution? Thanks.

Try pressing Fn+Fn Lock. It will toggle between Enable and Disable. On my keyboard fn lock is on the Esc key. I am not sure if this will persist between boots though.

1 Like

This is a nice writeup that will help you out. Most likely your keyboard does not have a FnLock …

ishaanbhimwal & bogdncoviaciu
Thanks both of you for the kind and informative replies. I will post back with what works…
Regards and again thanks.

On your next boot hit F1 or ESC or whatever your bios uses to interrupt. Check in your bios settings. I was able to switch the default behavior of my laptop F-keys this way.

Every key is recognized by a scan code.

sudo showkey

Or use the global hotkeys in input section of the system settings panel.

My laptop as well. This was the first thing I checked when trying to make the change. Thanks for the suggestion.

ishaanbhimwal & bogdncoviaciu

Thanks both of you. I have been unable to make either solution work…

linux-aarhus–thanks for this suggestion. Will look at it during the weekend.

I also have an external keyboard with media functions available as Fn keys. They don’t work in Linux (I have both Pop!_OS et Manjaro installed on my laptop). I have tried showkey and other commands, and my keyboard’s Fn keys don’t register any scan code.

I think that for a keyboard Fn’s keys to be recognized, the keyboard itself must have a specific driver in the linux kernel. If the keyboard is only recognized as a generic keyboard, like my own Perixx Periboard 220, then I think there simply is no driver for it in Linux. Next time, I’m buying a Linux compatible keyboard. (I bought it years ago to use with Windows anyway.)

As a workaround, since my media keys are on the F1-F12 keys, I added keyboard shortcuts with the Meta/Super key. Instead of typing Fn+F6 to lower volume, I type Meta+F6.

Thanks for the helpful info. On this Genius keyboard, the media keys are recognized by holding the Fn key down and pressing the desired media keyboard. I too would like to have a linux recognized keyboard. Also thanks very much for the information on what you have done with shortcuts.


thanks, it works on my machine