Keyboard doesn't work with linux58 on Asus machine

This is my first thread on this forum, so please be gentle with me :relaxed:

I’m testing linux58 on my device, and my keyboard is unresponsive, as in everything seems to be working except the keyboard, as described here:
The user in the above mentioned thread seems to have found the culprit, but doesn’t know how to proceed - neither do I :upside_down_face:

  Kernel: 5.8.XX-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Xfce 4.14.2 Distro: Manjaro Linux
  Type: Laptop System: ASUSTeK product: X556UQK v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X556UQK v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X556UQK.313 date: 03/13/2018
  Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Amber Lake rev: 9 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 21607 
  Speed: 900 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 900 2: 901 
  3: 900 4: 900 
  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: ASUSTeK driver: nouveau 
  v: kernel bus ID: 01:00.0 
  Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-6:3 
  Display: x11 server: X.Org 1.20.8 driver: intel,nouveau 
  unloaded: modesetting resolution: 1920x1080 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.5 
  direct render: Yes

If you need more information, please let me know.

Then try another kernel, like 5.7

And: inxi -Fzxxxa returns the complete kernel version: 5.7.14.

I’m on 5.7 right now (my daily driver). The inxi is from when I was testing various 5.8 releases. Unfortunately none of them worked for me - and my keyboard…

Tested 5.8.2-1 from the unstable branch. Keyboard and mousepad still unresponsive. What’s weird, now it seems that the enter key is being pressed permanently. I wasn’t able to get a log in that kind of state.

Back to 5.7 it is…

Keyboard and mouse are recognized by Manjaro…
Probs with the Logitech nano-receiver ? —> install Solaar
(Aug 18 16:02:54 hostname upowerd[1308]: failed to coldplug unifying device:
Unable to read response from device: Die Ressource ist zur Zeit nicht verfügbar.
Da liegt der Hund begraben…
(Aug 18 16:02:55 hostname blueman-mechanism[1484]: Unable to init server:
Could not connect: Connection refused)
keyboard is PS/2 - I see; is this supported by manjaro?
So possibly devices are not paired ==> mouse / touchpad
Or bluetooth pairing problem (PIN) / i am not the expert in bluetooth…
Does the mouse work on an other machine…
What tells “systemctl --failed” / journalctl -p 3 -b / journalctl -p 2 -b

Remove the “quiet” in GRUB-menu (edit with key “E”) - sometimes the PC tells whats wrong.

Btw.: ```
15.995s NetworkManager-wait-online.service

that is extremely long time. My systemd-analyze blame tells: 6.543s NetworkManager-wait-online.service
(test: sudo systemctl enable systemd-resolved.service)

EDIT: The enter key issue was due to my not realizing that I locked enter in ‘onboard’ while trying to do stuff without the physical keyboard…

Touchpad not working:

try whether the touchpad is recogized:

grep -B 5 mouse /proc/bus/input/devices

cat /proc/bus/input/devices | grep -i pad

Install: x86-input-synaptics 1.9.1-2

Sometimes the touchpad can be de-activated in BIOS…
Or a switch if laptop…

1 Like

Installing x86-input-synaptics 1.9.1-2 did the trick for the touchpad!
As for the keyboard, it must have been recognized, since Fn key is partially working (Fn + brightness up/down). The rest of it still isn’t working.
We’re getting there - your help is greately appreciated :+1:

What keyboard is this, build_in_to laptop or extra device?
Have you looked inside BIOS for keyboard related “Possibilities”

It’s built-in, like this one: (this may not be the exact same model, but close)

I’ve checked UEFI, but unfortunately there’s nothing keyboard related.
The keyboard does work there though, even up until lightdm starts…

The keyboard does work there though, even up until lightdm starts…

Would you dare: gdm instead of lightdm???

Simple and not so risky: make an USB-Stick with Manjaro-Gnome (uses gdm)
and see whether the keyboard works…

1 Like

Sure. Downloading…

EDIT: Nope. No luck with gdm/gnome running linux58 - same unresponsiveness :confused:

EDIT2: Tested linux59 for the fun of it. Guess what…
No keyboard :thinking:

no further ideas… sorry

Thank you for your help!

Solution (workaround) in the link added in the first post (OP). Also partly solved by @GaVenga - big thank you!

uname -r

1 Like

So to choose the default keyboard on installation is wrong …

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.