Keyboard disconnects if pressing LEFT SHIFT and Steam is on

Hi there

I have this weird issue, evolved from a problem I had from the past with the same keyboard and it seemed to be fixed in recent updates. But now, if Steam app is on and I press LEFT SHIFT the keyboard will disconnect and I’ll have to unplug and plug it again. If (some) wine games are running it’ll trigger also.

I’ve tried different kernels (5.4-5.8-5.9) and disabling USB autosuspend through TLP and powertop.

Keyboard is a Cooler Master MK850, and it works flawlessly on the same system on other OS partitions (Ubuntu and Win).

Video proof

System:    Kernel: 5.9.11-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.2 
       wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: Z390 AORUS ULTRA v: N/A serial: <filter> 
       Mobo: Gigabyte model: Z390 AORUS ULTRA-CF v: x.x serial: <filter> UEFI: American Megatrends v: F9 date: 10/15/2019 
Battery:   ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 4.0/N/A model: Logitech G Pro Wireless Gaming Mouse 
       serial: <filter> status: Discharging 
CPU:       Info: 8-Core model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Kaby Lake rev: C L2 cache: 16.0 MiB 
       flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 115232 
       Speed: 3800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 3801 2: 3800 3: 3801 4: 3800 5: 3800 6: 3801 7: 3800 
       8: 3800 9: 3801 10: 3801 11: 3800 12: 3801 13: 3799 14: 3800 15: 3800 16: 3798 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e98 
       Device-2: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: ZOTAC driver: nvidia v: 455.45.01 bus ID: 01:00.0 
       chip ID: 10de:1e07 
       Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia resolution: 5120x1440~120Hz s-dpi: 109 
       OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
       chip ID: 8086:a348 
       Device-2: NVIDIA TU102 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
       chip ID: 10de:10f7 
       Device-3: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK Virtuoso 100 driver: snd_virtuoso v: kernel 
       bus ID: 05:04.0 chip ID: 13f6:8788 
       Sound Server: ALSA v: k5.9.11-2-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
       chip ID: 8086:a370 
       IF: wlo1 state: up mac: <filter> 
       Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel port: efa0 bus ID: 00:1f.6 
       chip ID: 8086:15bc 
       IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 6.77 TiB used: 4.56 TiB (67.4%) 
       ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP510 size: 894.25 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
       ID-2: /dev/nvme1n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
       ID-3: /dev/sda model: SSD PLUS 480GB size: 447.13 GiB speed: 6.0 Gb/s serial: <filter> 
       ID-4: /dev/sdb vendor: Toshiba model: DT01ACA300 size: 2.73 TiB speed: 6.0 Gb/s serial: <filter> 
       ID-5: /dev/sdc vendor: Western Digital model: WD20EARX-00PASB0 size: 1.82 TiB speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 878.92 GiB used: 616.72 GiB (70.2%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 29 C 
       Fan Speeds (RPM): fan-2: 1001 fan-3: 998 fan-4: 1007 gpu: nvidia fan: 35% 
Info:      Processes: 363 Uptime: 31m Memory: 31.22 GiB used: 4.91 GiB (15.7%) Init: systemd v: 246    Compilers: gcc: 10.2.0 
       Packages: 1456 pacman: 1442 flatpak: 6 snap: 8 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

Hello @pungentstentch :wink:

Since it disconnects, there must be a log entry about it. Please open a terminal and run:

journalctl -f

Then repeat it and post the output here, if anything is logged there.

Also this could help to figure out, if the keyboard works correctly (install evtest):

sudo evtest

choose the correct event and test the keys.


xinput list


sudo libinput list-devices

About steam, run (install gdb first):

DEBUGGER=gdb steam-native

and then type, if your in (gdb): run

Then try again pressing LEFT_SHIFT. Any useful log entries there?

Thanks :wink:

This is my journal -f

And the rest of commands , xinput don’t work, sorry I don’t know why.

I want to add I just tested logging out of steam beta, and the problem is gone there (persists in some wine games-apps). I f roll in beta again the problem is back. My fear is when the beta is live to get this problem persistent.

In that case i would suggest to start steam in debug mode, reproduce the problem and send the log in the terminal to steam devs.

Here you can do this:

Thanks for your time,

DEBUGGER=gdb steam-native
[carlos@Piratexjaro ~]$ DEBUGGER=gdb steam-native
bash: steam-native: command not found

or (as suggested in wiki)

[carlos@Piratexjaro ~]$ DEBUGGER=gdb steam
Running Steam on manjarolinux 20.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
gdb -x carlos.steam.gdb.SDXv --args /home/carlos/.local/share/Steam/ubuntu12_32/steam
gdb: /home/carlos/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs_64/ version `CURL_OPENSSL_4' not found (required by /usr/lib/
[carlos@Piratexjaro ~]$ 

EDIT: installed steam-native and

[carlos@Piratexjaro ~]$ DEBUGGER=gdb steam
Running Steam on manjarolinux 20.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
gdb -x carlos.steam.gdb.SDXv --args /home/carlos/.local/share/Steam/ubuntu12_32/steam
gdb: /home/carlos/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs_64/ version `CURL_OPENSSL_4' not found (required by /usr/lib/
[carlos@Piratexjaro ~]$

steam > steam-native :wink:

Hello there, this problem persists, I’m doing some digging and I think it has to do with the fact that the keyboard has Aimpad technology, meaning is recognized as a xbox controller by steam and the system.

Why it disconnects as soon as I press Left Shift (and only that key) is a mystery to me, in these months I’d been trying other distros, kernels, configurations, etc … But the problem is still there.

I’m open to suggestions or workarounds.

Well, more testing, it’s almost there, but I can’t figure it out since my linux-fu is nonexistent.

I did a full new Manjaro reinstall, still using KDE, everything working right finally. No more keyboard shutting down when pressing left shift.

Well, no more until I tried a new game with controller support. I had to click on game properties on steam, properties>controller> and change default settings to “disable steam input”. Xbox controller worked in game, all good, but when I launched another game and pressed left shift, NOOO, it happened again. Now, no matter after deleting steam folder and reinstalling games, reboot, and such, still same problem.

Before that I won’t have this 3 controllers listed on steam,

Something was triggered as system level configuration, I think in my ignorance possibly related to udev rules or something like that, and now the keyboard is also detected as 3 controllers as before I reinstalled Manjaro.

I have the idea that the solution could be blacklisting this 3 connections of my keyboard to even be available to be detected, but honestly I don’t know if that’s the solution or even how to pull that out on the terminal.

Thanks in advance for any help.

I managed to solve it.

Apparently it had to do with that pointed before.

Thanks all

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.