Keyboard bugs which may not caused by the keyboard itself

Has anyone experienced this situation before?

Since I began to use Manjaro a month ago, I noticed that sometimes when I just short press any key of the keyboard for a short time, it may act like I press the key for a long time until I press the next key. I say it may not caused by the keyboard because I never seen it in a tty.

  • I just press my Enter key hundreds of time with a low frequences in a tty, and the bug diddn’t occure.
  • But it occured when I use KDE plasma, it can happen in any desktop application, not only the Enter key, but also any other keys.
  • I just started a new install of manjaro, and just updated it to the newest version, and the bug occured too. And still, it didn’t occure in tty.

Information about my device: Dell G15 5510

Is Sticky Keys turned on? (System Settings → Accessibility → Modifier Keys)

If not, what do you have for Keyboard model in System Settings → Input Devices → Keyboard?


No - keyboard always work as intended - I am pretty sure it is a setting local to your system.

1 Like

The sticky keys set to ‘lock’, well my system language is not English so I don’t know what its name is in English system. The keyboard model now is Dell|Dell, and the bug also existed when it was set as Generic|104 keys by default. (well I don’t remember the number of keys clearly).

Thank you for your reply!
but it’s so hard to explain why after I executed a new installlatin in a new part of my disk, the bug still exist. Maybe it’s my keyboards’ bug? Then it’s kind of hard to explain why it didn’t occure in tty terminal, or maybe I just don’t have enough try.

There is nothing generically wrong with Linux and in that sentiment Manjaro. I suggest you may have chosen the wrong keyboard layout - or something along those lines.

1 Like

But are they Enabled or not?


If it’s not sticky keys and it happens with other keyboard models then I’m afraid I don’t know. I’d suspect a hardware problem but then it’s strange then that it doesn’t happen in a TTY too. :man_shrugging:

1 Like

not enabled. Thank you very much for your help!

Double-check the repeat-rate is not set too fast in System Settings:

Now: Delay=501 rate=50
I think it can’t be the problem.


Was just a though, try bringing the rate down, like mine is. Even if it is just to test.

1 Like

Thanks, I’ll try it. Though now to avoid something bad caused by the bug I change the when a key is held to do nothing, sometimes like the Ctrl key is held just like open the sticky key, and when I try to press other key the shotcut is executed.

If you have such a setting and don’t want it to do anything, well, the obvious solution would be to me sure that it’s disabled…

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.