Keyboard backlight fading on and off

Hello,

does anyone know how to disable the keyboard backlight from fading continuously on/off? I don’t see the option in the System Settings and I haven’t been able to find a command for that.

These are my settings:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.1.25-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × 12th Gen Intel® Core™ i5-12450H
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: ASUSTeK COMPUTER INC.
Product Name: ASUS TUF Dash F15 FX517ZE_FX517ZE
System Version: 1.0

Hi @bejuco,

We needz moar infos! Please help us help you and provide the output of:

inxi --admin --verbosity=7 --filter --no-host --width

Edit:

Considering:

I recommend having a look here:

https://wiki.archlinux.org/title/Asusctl

Which is in the AUR, so can be installed with:

pamac build asusctl

More info:

This may help:
https://wiki.archlinux.org/title/Keyboard_backlight


If the backlight behavior is more akin to customization effects, you may need a dedicated tool such as openrgb (if supported).

1 Like

how did you get the keyboard backlight to work in the first place?
i also have an asus tuf laptop.

Looks like AURA-support (BIOS) - my ASUS B550 can do - I donot like…

1 Like

Hi @Mirdarthos, thanks you for all the info.

I was looking to the asusctl package but I’m getting some build errors, seems like its necessary to install supergfxctl and for that I need to remove any distro provided methods of graphics switching (like prime).

This is the inxi print:

System:
  Kernel: 6.1.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=f67db6a4-f0e2-45a3-a794-ba5e4c535873 rw ibt=off quiet
    udev.log_priority=3 ibt=off
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX517ZE_FX517ZE
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX517ZE v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: FX517ZE.316 date: 12/09/2022
Battery:
  ID-1: BAT1 charge: 70.0 Wh (100.0%) condition: 70.0/75.8 Wh (92.2%)
    volts: 17.4 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: full
  Device-1: wacom_battery_0 model: Wacom Intuos BT M serial: N/A charge: 100%
    status: discharging
Memory:
  RAM: total: 15.25 GiB used: 2.36 GiB (15.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: 12th Gen Intel Core i5-12450H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x429
  Topology: cpus: 1x cores: 8 mt: 4 tpc: 2 st: 4 threads: 12 smt: enabled
    cache: L1: 704 KiB desc: d-4x32 KiB, 4x48 KiB; i-4x32 KiB, 4x64 KiB L2: 7 MiB
    desc: 4x1.2 MiB, 1x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2179 high: 2500 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 691 2: 2500 3: 2500
    4: 2500 5: 2500 6: 2500 7: 460 8: 2500 9: 2500 10: 2500 11: 2500 12: 2500
    bogomips: 59916
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid
    rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep smx
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes
    vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0 chip-ID: 8086:46a3
    class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: ASUSTeK
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
    chip-ID: 10de:25a0 class-ID: 0300
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-7:3 chip-ID: 322e:202c class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x153c built: 2021 res: 1920x1080
    hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 3-9:4
    alternate: snd_sof_pci_intel_tgl chip-ID: 0b05:6206 class-ID: 0300
    bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Device-3: ASUSTek C-Media Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  API: ALSA v: k6.1.25-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl
Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 0000:00:1f.6 chip-ID: 8086:1a1e class-ID: 0200
  IF: eno2 state: down mac: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
  Local Storage: total: 1.38 TiB used: 38.38 GiB (2.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 002C temp: 28.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:8 vendor: Western Digital
    model: WD BLACK SN750 SE 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 711250WD temp: 33.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 226.56 GiB size: 221.95 GiB (97.96%)
    used: 38.35 GiB (17.3%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
    label: N/A uuid: f67db6a4-f0e2-45a3-a794-ba5e4c535873
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 29.7 MiB (11.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM uuid: F6F2-D75A
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 226.57 GiB fs: ntfs
    label: Windows uuid: FA0EF4C90EF48045
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 723 MiB fs: ntfs label: N/A
    uuid: CC9A38E99A38D1A6
  ID-4: /dev/nvme0n1p6 maj-min: 259:6 size: 22 GiB fs: ntfs label: RESTORE
    uuid: 5870AAD970AABD5E
  ID-5: /dev/nvme0n1p7 maj-min: 259:7 size: 200 MiB fs: vfat label: MYASUS
    uuid: 98AB-216B
  ID-6: /dev/nvme1n1p1 maj-min: 259:9 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-7: /dev/nvme1n1p2 maj-min: 259:10 size: 931.5 GiB fs: ntfs
    label: Archivos uuid: 3EFE4A1BFE49CBB9
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Wacom CTL-6100WL [Intuos BT (M)] type: HID
    driver: usbhid,wacom interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 056a:0378 class-ID: 0300 serial: <filter>
  Device-2: 3-7:3 info: Sonix USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 322e:202c class-ID: 0e02
  Device-3: 3-9:4 info: ASUSTek C-Media Audio type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 0b05:6206 class-ID: 0300
  Device-4: 3-10:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 292 Uptime: 4m wakeups: 430 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1401 libs: 368 tools: pamac Shell: Bash v: 5.1.16
  running-in: dolphin inxi: 3.3.26
1 Like

Hi @maycne.sonahoz, thanks for the info. I tried with OpenRGB but my device is not listed. I guess is not supported. I also tried with brightnessctl and xset but none of them seem to have an option for animation/fading parameters.

Thank you, it was an AURA configuration in Windows. Not on the BIOS utility directly but in the desktop app.

Sorry everybody for opening a topic for such a silly error! Thank you and have a good day.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.