Keyboard and touchpad stop working randomly

I have a Minibook X from CHUWI, with:

  • ManjaroLinux 21.3.3 Ruah
  • Kernel 5.19.01

The mouse and keyboard sometimes stop working, its more frequently the trackpad. It appears to be random, sometimes it can go for hours and hours without any issue, other times, the trackpad stops on their tracks right after launch.

To revive one or both i run:
modprobe -r i2c_hid_acpi && modprobe i2c_hid_acpi

and all gets back to normal, working perfectly.

dmesg output pertaining to the events where they stop working (The trackpad in this case):

[ 1928.785322] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=116283 end=116284) time 9 us, min 2543, max 2559, scanline start 2560, end 2561
[ 1934.737306] audit: type=1131 audit(1659869398.335:100): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 2058.161450] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=124045 end=124046) time 7 us, min 2543, max 2559, scanline start 2560, end 2561
[ 2167.569465] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=130609 end=130610) time 9 us, min 2543, max 2559, scanline start 2560, end 2561
[ 2289.178355] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=137905 end=137906) time 14 us, min 2543, max 2559, scanline start 2560, end 2562
[ 2356.283258] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=141931 end=141932) time 9 us, min 2543, max 2559, scanline start 2560, end 2561
[ 2374.151230] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=143003 end=143004) time 8 us, min 2543, max 2559, scanline start 2560, end 2561
[ 2380.318346] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=143373 end=143374) time 7 us, min 2543, max 2559, scanline start 2560, end 2561
[ 2461.111529] audit: type=1100 audit(1659869924.717:101): pid=2935 uid=1000 auid=1000 ses=3 msg='op=PAM:authentication grantors=pam_unix acct="root" exe="/usr/bin/su" hostname=? addr=? terminal=/dev/pts/1 res=success'
[ 2461.111699] audit: type=1101 audit(1659869924.717:102): pid=2935 uid=1000 auid=1000 ses=3 msg='op=PAM:accounting grantors=pam_unix acct="root" exe="/usr/bin/su" hostname=? addr=? terminal=/dev/pts/1 res=success'
[ 2461.112555] audit: type=1103 audit(1659869924.717:103): pid=2935 uid=1000 auid=1000 ses=3 msg='op=PAM:setcred grantors=pam_unix acct="root" exe="/usr/bin/su" hostname=? addr=? terminal=/dev/pts/1 res=success'
[ 2461.112789] audit: type=1105 audit(1659869924.717:104): pid=2935 uid=1000 auid=1000 ses=3 msg='op=PAM:session_open grantors=pam_unix acct="root" exe="/usr/bin/su" hostname=? addr=? terminal=/dev/pts/1 res=success'
[ 2480.167104] input: GXTP738:00 27C6:011A as /devices/pci0000:00/0000:00:15.2/i2c_designware.2/i2c-2/i2c-GXTP738:00/0018:27C6:011A.0003/input/input31
[ 2480.167433] input: GXTP738:00 27C6:011A Stylus as /devices/pci0000:00/0000:00:15.2/i2c_designware.2/i2c-2/i2c-GXTP738:00/0018:27C6:011A.0003/input/input32
[ 2480.167626] input: GXTP738:00 27C6:011A UNKNOWN as /devices/pci0000:00/0000:00:15.2/i2c_designware.2/i2c-2/i2c-GXTP738:00/0018:27C6:011A.0003/input/input33
[ 2480.167742] input: GXTP738:00 27C6:011A Keyboard as /devices/pci0000:00/0000:00:15.2/i2c_designware.2/i2c-2/i2c-GXTP738:00/0018:27C6:011A.0003/input/input34
[ 2480.172813] hid-multitouch 0018:27C6:011A.0003: input,hidraw0: I2C HID v1.00 Keyboard [GXTP738:00 27C6:011A] on i2c-GXTP738:00
[ 2480.263024] input: SYNA3602:00 0911:5288 Mouse as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-SYNA3602:00/0018:0911:5288.0004/input/input35
[ 2480.263300] input: SYNA3602:00 0911:5288 Touchpad as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-SYNA3602:00/0018:0911:5288.0004/input/input36
[ 2480.263558] hid-multitouch 0018:0911:5288.0004: input,hidraw1: I2C HID v1.00 Mouse [SYNA3602:00 0911:5288] on i2c-SYNA3602:00


  Kernel: 5.19.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: initrd=\initramfs-5.19-x86_64.img
    root=UUID=2f41c442-39ea-44e5-a9cf-f47167b23f68 rw
  Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 wm: kwin_wayland vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: CHUWI Innovation And (ShenZhen) product: MiniBook X
    v: N/A serial: <superuser required>
  Mobo: N/A model: N/A serial: <superuser required> UEFI: N/A
    v: ZW-BI-108-S105JWR120-JCB0E-082-C date: 03/24/2022
  ID-1: BAT0 charge: 28.9 Wh (100.0%) condition: 28.9/28.9 Wh (100.0%)
    volts: 8.7 min: N/A model: WB SR 1 WB Lion Battery type: Li-ion
    serial: <filter> status: charging
  RAM: total: 11.43 GiB used: 3.19 GiB (27.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Celeron N5100 bits: 64 type: MCP arch: Tremont
    built: 2019 process: Intel 10nm family: 6 model-id: 0x9C (156) stepping: 0
    microcode: 0x1D
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1.5 MiB desc: 1x1.5 MiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1020 high: 1100 min/max: 800/2800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1100 2: 1100 3: 1100
    4: 783 bogomips: 8912
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
    arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt clwb cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept ept_ad erms est flexpriority flush_l1d fpu fsgsbase fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs pge pln pni
    popcnt pse pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep
    sha_ni smap smep split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer
    tsc_known_freq umip vme vmx vnmi vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Vulnerable: Clear CPU buffers attempted, no
    microcode; SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel JasperLake [UHD Graphics] driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: DSI-1
    empty: DP-1 bus-ID: 00:02.0 chip-ID: 8086:4e61 class-ID: 0300
  Device-2: Generic USB Camera type: USB driver: uvcvideo bus-ID: 1-7:2
    chip-ID: 0a03:b041 class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 22.1.3
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: vesa
    alternate: fbdev gpu: i915 display-ID: 0
  Monitor-1: DSI-1 res: 1280x800 size: N/A modes: N/A
  OpenGL: renderer: Mesa Intel UHD Graphics (JSL) v: 4.6 Mesa 22.1.3
    direct render: Yes
  Device-1: Intel Jasper Lake HD Audio driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 chip-ID: 8086:4dc8
    class-ID: 0403
  Sound Server-1: ALSA v: k5.19.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.55 running: no
  Device-1: Intel Wi-Fi 6 AX201 160MHz driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:4df0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-8:3
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Message: Unable to run lvs. Root privileges required.
  Device-1: cryptlvm maj-min: 254:0 type: LUKS dm: dm-0 size: 396.47 GiB
  p-1: sda5 maj-min: 8:5 size: 396.49 GiB
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 15.33 GiB (3.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Netac model: SSD 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0A0 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 128 GiB size: 124.93 GiB (97.60%) used: 12.13 GiB (9.7%)
    fs: ext4 dev: /dev/dm-2 maj-min: 254:2 mapped: volume-root label: N/A
    uuid: N/A
  ID-2: /boot/efi raw-size: 100 MiB size: 99.8 MiB (99.76%) used: 67.1 MiB
    (67.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A uuid: 5BDE-D6A4
  ID-3: /home raw-size: 128 GiB size: 124.93 GiB (97.60%) used: 3.13 GiB
    (2.5%) fs: ext4 dev: /dev/dm-3 maj-min: 254:3 mapped: volume-home
    label: N/A uuid: N/A
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 6 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 maj-min: 254:1 mapped: volume-swap label: N/A
    uuid: 4eae7288-c922-4c36-88a5-ee2543f79846
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/sda3 maj-min: 8:3 size: 79.36 GiB fs: ntfs label: Windows
    uuid: 48A2F693A2F6852A
  ID-3: /dev/sda4 maj-min: 8:4 size: 1000 MiB fs: ntfs label: Recovery
    uuid: 1CC0F76AC0F74892
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: Generic USB Camera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.1 speed: 480 Mb/s power: 500mA chip-ID: 0a03:b041
    class-ID: 0e02 serial: <filter>
  Device-2: 1-8:3 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 213 Uptime: 58m wakeups: 1 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 Packages:
  pacman: 904 lib: 254 Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.20

This is quite annoying as sometimes although not frequently, both stop working and i can’t call modprobe :frowning:

Any help is hihly appreciated. If i missed posting important debugging information, just let me know .

Thak you so much for any help provided.


Try this and see if that solves the issue

Thank you very much for the input @bogdancovaciu

After running xinput list i get the following:

WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ xwayland-pointer:10                       id=6    [slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:10              id=7    [slave  pointer  (2)]
⎜   ↳ xwayland-pointer-gestures:10              id=8    [slave  pointer  (2)]
⎜   ↳ xwayland-touch:10                         id=10   [slave  pointer  (2)]
⎜   ↳ xwayland-tablet stylus:10                 id=11   [slave  pointer  (2)]
⎜   ↳ xwayland-tablet eraser:10                 id=12   [slave  pointer  (2)]
⎜   ↳ xwayland-tablet cursor:10                 id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ xwayland-keyboard:10                      id=9    [slave  keyboard (3)]

Anyway, i added the “blacklist psmouse” line to the conf file. Don’t know how to go about the keyboard though

I see a lot of mentions about keyboards stop working under wayland in some circumstances, but i can’t quite pinpoint why is happening … maybe related to libinput. You could still use X11 session and see if the issue happens there too.

Unfortunately the first suggestion didn’t change the fact that the touchpad stops sometimes.

Using X11 didn’t also :frowning:

Do you have any other ideas on how to get more information as to trace the origin of the problem? Or where to get relevant logs

journalctl gives me a little more information.

The touchpad failure is preceded by these events:

Aug 08 11:14:54 manjaro kstart5[2575]: Omitting both --window and --windowclass arguments is not recommended
Aug 08 11:14:54 manjaro kwin_wayland_wrapper[2575]: 2579
Aug 08 11:14:54 manjaro systemd[590]: Started Konsole - Terminal.

i see this error that seemed to trigger the plasma restart.

Aug 08 11:19:22 manjaro kwin_wayland[618]: kwin_core: XCB error: 3 (BadWindow), sequence: 9490, resource id: 16777255, major code: 129 (SHAPE), minor code:>

The culprit seems to be the i915 intel’s driver , i guess? And for some reason, every time a restart from the display server i loose the touchpad and/or keyboard…

I tried to address the following error caused typically (so i read) by i915 failures:

[drm] *ERROR* Atomic update failure on pipe A

I made sure microcode is loaded at boot time, and i deactivated the psr :

$ cat /etc/modprobe.d/i915.conf
$ options i915 enable_psr=0 enable_guc_loading=1 enable_guc_submission=1

Deactivating the psr seemed to make it freeze less, and Activating GuC seems to make it worse. Of course this is just a hunch stemming from feeling.

A post was split to a new topic: Joystick and touchpad are randomly stop working