Keybind not working anymore XFCE

Since a few weeks some keybind doesn’t work with XFCE.

The issues is only with the “super” key but not with each combinaison.

For example:

  • I’ve mapped +w, +m , +& to firefox, thunderbird and amixer and those don’t work.
  • But for +é , +f , +c +t with amixer, thunar, copyq, terminator, these do work!

If I remap the problematic keybind via the GUI, it will last until the next reboot and then it’s lost again.

Does someone have any idea where the problem lies?

1 Like

Hi there! Make sure the file ~/.config/autostart/xcape.desktop exists with the following content:

[Desktop Entry]
Exec=xcape -e 'Super_L=Alt_L|F1'

and that the file is writeable by your user:

ls -al  ~/.config/autostart/xcape.desktop

should give something like:

-rw-r--r-- 1 frolic_fringe frolic_fringe 9 Feb 24 10:06 xcape.desktop

(where the w is important)

1 Like

As I’m an editor here on the site I’ve edited your post for readability. Please press the orange pencil at the top right of your post to see what I did so you can use the same tricks in the future…

cc @screwtape :point_up_2:

I’ve also added some more detail to your answer as it might also be an issue of file rights. :bowing_man:

@screwtape thanks, i had to create the file, check the perm and rebooted to no avail. The keybinds are still not working.

I forgot: I have the following script in my autostart :

sleep 10
setxkbmap -option ctrl:nocaps
xcape -e ‘Control_L=Escape’

I have the feeling that it might be a locale problem:

  • S + c e f t x 2 é : works
  • S + w m & : doesn’t

Maybe my azerty belgian layout has something to do with it?

@Fabby thanks it’s def better… However the render as a divided square on my system. imo it’s more confusing than a simple S.

1 Like

Nondedju! Gaa zaait ook giene gemakkelijke! Whatever makes you happy is fine…


Ok, then my linux/manjaro-voodoo has reached it’s end - sorry. But you might be on the correct track.

tcheu dis, zullen nous dialect parler? Well that’s what i’m used to see online, thanks for understanding :slight_smile:

1 Like

Thanks, i’m not really sure how to go further, I guess I’ll roam the xfce forum.