Key combination alt doesn't work


I installed Manjaro a few days ago and am an average linux user,

I’ve got this issue where I was playing a mmo and noticed that the combination alt or shift + é (2 on qwerty) wasn’t working on my azerty keyboard, the key works separately and works with ctrl
I used the Manjaro Logs Helper to get some logs

h!ttps:// (remove ! char)

Thanks for the help!

Hello, after I’ve been searching for the last few days, I found some directions…

I tried to simulate the shorcut and viewing the logs via

xdotool keydown "Alt_L"; xdotool key "XF86LogGrabInfo"; xdotool keydown "eacute"; xdotool key "XF86LogGrabInfo"; xdotool keyup "eacute" keyup "Alt_L"

and got this logs : h!ttps:// (removes ! char)

The interesting part seems to be

Information    [ 18273.657] (II) Printing all currently active device grabs:
Information    [ 18273.657] Active grab 0x41533981 (core) on device 'Virtual core keyboard' (3):
Information    [ 18273.657]       client pid 1274 /usr/bin/kglobalaccel5 
Information    [ 18273.657]       at 18273560 (from passive grab) (device frozen, state 6)
Information    [ 18273.657]         core event mask 0x3
Information    [ 18273.657]       passive grab type 2, detail 0xb, activating key 11
Information    [ 18273.657]       owner-events true, kb 0 ptr 1, confine 0, cursor 0x0
Information    [ 18273.657] (II) End list of active device grabs

I then tried to kill “kglobalaccel5” and my key combination was working again, but it seems that another process is calling it to access the global shortcut.

Is their a way to know what software is calling “kglobalaccel5” ?

:+1: Welcome to Manjaro! :+1:

Unfortunately, you’ll have to do that for all 3 categories…

Edit: The specific issue was with Alt+~ which was on the same key as é and kwin was using that. After that was removed everything worked fine again…


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.