Kernel version is different in Manjaro Settings Manager and uname -r

uname -r shows
but Manjaro Settings Manager shows linux 5.4.100-1

Why is it different?

uname -r shows 5.4.100-1-MANJARO on my end, so i suppose your kernel package is not up-to-date.

Have you rebooted since the last kernel update?

Yes, I have rebooted it.

What does the following return?
pacman -Qs linux54

As I mentioned here this kernel may be ignored during updates. Check Pamac settings or /etc/pacman.conf file.

I installed 5.10.18-1 kernel, rebooted, removed kernel version 5.4.100 and rebooted. But still ever uname -r still shows 5.4.18-1-MANJARO and Manjaro Settings Manager shows it is running linux 5.4.100-1 when it is not even installed.

I didn’t find anything in pamac settings or /etc/pacman.conf that mentioned kernel. Is there anything specific, I could check?

grep -i ignorepkg /etc/pacman.conf 

In pamac > Preferences > Advanced > “Ignore upgrades for”. pamac writes this info to pacman.conf.

Check the output of:

# What does the install history show:
grep -i  linux5 /var/log/pacman.log

# In less, keep clicking "n" to find next pattern. "q" to quit. 
# Focus on the build image and generating grub. 
# Were they successful: 
less -p linux5 /var/log/pacman.log

# What does the Manjaro's kernel command show:
mhwd-kernel -li

# What's in the boot directory:
ls -l /boot
cat /boot/linux*.kver

# What's in cache/downloaded:
ls -l /var/cache/pacman/pkg/linux5*

# Double check which kernel running:
cat /proc/version

# What does grub menu show:
grep -E -i  '(vmlinuz|menuentry )' /boot/grub/grub.cfg

So the question remains: Why does Manjaro Settings Manager GUI show a different kernel version than uname -r.

When I look at my pacman log, kernel 5.4.6 was upgraded to 5.4.18 on 2020-02-25.

If all the parts are there, and things in the past finished successfully, I wonder if you just ran sudo update-grub and reboot. Check the grub menu when you reboot. If you have the quiet options, which I believe is the default, hit ESC to see the menu and select “Advanced options for Manjaro Linux”. You should see your correct 5.10 and 5.4 kernels.

I’m sort of in this same boat as the OP with the kernel “upgrade” not upgrading . . . problem. I saw a notification in the toolbar that “a new kernel is available so you should upgrade it.”

Since I’m new to Manjaro I thought I could run pacman to pick it up, nope. I launched Manjaro settings Manager and saw that I had 5.10-18 installed/running, and 5.11 was available, nothing wrong with 5.10, but why not get the latest–ran the install and rebooted. uname -r still showing 5.10.

Searched the forum and found another thread about kernels and saw the mhwd-kernel data, asked for listed installed kernels . . . 5.11 is “installed” but not running?? I used the command to reinstall the 511 kernel, ran through it, rebooted . . . still uname -r is showing 5.10 as running?

Found another thread that said “sudo update-grub” and then select 5.11 . . . ran that, went into “advanced” in Grub and nothing for 5.11 is showing at all??

Then I thought, O, it will only allow two installed kernels, so I removed linux54, rebooted . . . back into 5.10???

I’m “OK” with 5.10-18, but why is there this “separate” process for upgrading kernels that “installs” them, but doesn’t then select them for “running”???

Let’s say my reason for “installing” linux511 was so that it would be “running”??? How would that be done in theory??

can you return

inxi -Fza 
sudo mhwd-kernel -li
sudo ls /etc/mkinitcpio.d/*.preset
1 Like


Sorry, but were you replying to my post on this thread or the OP?? I didn’t get any email notification on my post, but I ran those commands, just showing basic machine & system information, but, it isn’t a couple of lines, so I don’t just want to post it here . . . .

But my issue remains with kernel still at 5.10.18 . . . even though 5.11 was and is “installed” . . . on cold boot to Manjaro 5.11 isn’t hooking up to “running” status.

The relevant data is much shorter, posting it here:

sudo mhwd-kernel -li
Currently running: 5.10.18-1-MANJARO (linux510)
The following kernels are installed in your system:

  • linux510
  • linux511

~]$ sudo ls /etc/mkinitcpio.d/*.preset
/etc/mkinitcpio.d/linux510.preset /etc/mkinitcpio.d/linux511.preset

You have both kernels installed
and can select one or the other at boot time.
… probably hit ESC to get to the menu
to see and be able to make that choice
if you don’t see the menu by default

1 Like


Thanks for the reply, so far that option isn’t showing up in grub, as posted previously, ran “update-grub” and so far we are going to 5.10 as the option. Previously the “11” wasn’t showing at all in grub . . . . I’ll try it again just for kicks.

for whatever reason, “they” made the boot
you have to hit some key at the right time to get to the menu, I suppose
or edit the grub configuration file
for the boot not to be silent anymore

It’s good to have two (or more) kernels/versions installed
in case one might not work after an update
but now, without trouble, is a good time to figure out how to get to them, how to choose and boot them :wink:

1 Like


Thanks for following along, figured it out . . . I’m in a multi-boot computer, and OpenSUSE has taken charge of grub, so running grub in Manjaro wasn’t getting the message out. I saw “vmlinuz 5.11” in the Manjaro grub-update, but on reboot it wasn’t showing. So I rebooted into Gecko and ran their yast bootloader os-prober and on reboot again . . . 5.11 was there!!! So, it is now showing.

uname -r

  • have you installed Opensuse after manjaro ?
  • both are installed in /boot ?


Good questions, I actually believe Manjaro went in last, but I can’t guarantee that.

As per recommend from the makers of the computer System76, each system has its own /efi/boot partition, one each for oem Pop!, Gecko, and Manjaro. The “ubuntu” based flavors have had “issues” with wiping out my grub menus and just leaving themselves as the sole option, but going this way with separate efi/boot partitions has protected the other systems better than it has on my desktop with 4 drives and 6 linux distros.

I have /dev/sda1 mounted as /boot and /dev/sda2 is mounted as /. /dev/sda1 has the kernel 5.4.100-1-MANJARO however the boot folder on /dev/sda2 had kernel 5.4.18-1-MANJARO. System was booting from /dev/sda2's boot folder instead of the boot partition I had /dev/sda1 mounted as /boot. This could have happened due to some configuration issue during dual boot setup with Linux Mint. I removed mount for /dev/sda1 from /etc/fstab and copied all the files from /dev/sda1 to /dev/sda2's boot folder, updated grub and reboot, this fixed the issue.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.