Kernel taking a long time to boot

Booting into Manjaro takes ages
Using systemd-analyze, it shows that firmware and kernel are what kills the loading time.

Startup finished in 31.425s (firmware) + 8.894s (loader) + 1min 28.226s (kernel) + 3.868s (userspace) = 2min 12.414s

I’m on the 6.1.29-1 kernel with a 7950x, I dual boot but this is running on it’s own separate drive (nvme)
I can’t do much about the firmware so I’m hoping that I can do something to improve the kernel load times. Please help :slight_smile:

Please post the output of

systemd-analyze critical-chain 
1 Like @3.868s
└─ @3.868s
  └─cups.service @3.493s +374ms
    └─ @3.493s
      └─NetworkManager.service @3.430s +62ms
        └─dbus.service @3.249s +134ms
          └─ @3.244s
            └─ @3.244s
              └─snapd.socket @3.209s +35ms
                └─ @3.207s
                  └─systemd-update-utmp.service @3.077s +130ms
                    └─systemd-tmpfiles-setup.service @2.872s +158ms
                      └─ @2.844s
                        └─run-credentials-systemd\x2dtmpfiles\x2dsetup.service.mount @2.873s
                          └─ @1.627s
                            └─systemd-tmpfiles-setup-dev.service @1.322s +268ms
                              └─kmod-static-nodes.service @853ms +47ms
                                └─systemd-journald.socket @850ms
                                  └─-.mount @813ms
                                    └─-.slice @812ms
1 Like

firmware is more or less ok, but kernel isn’t (it’s ~2 secs for me with nvme but otherwise nothing specially speedy, Xfce).

Try looking through the journalctl, as there must me something in there related to this, e.g.

# first errors
journalctl -rxb -p err
# then warnings
journalctl -rxb -p warning

since it’s kernel taking up the time, you should look at kernel log and see where the time accumulates. So run

sudo dmesg

the first number you see is a timestamp.

I once had intermittently the kernel taking very long to start, the time was spent initializing hdd:s. I accidentally fixed it by updating the firmware on an unused (not in fstab) drive.


Check your /etc/fstab and compare it with what is really mounted :wink:

Okay I looked and found that for some reason, I was getting errors for usb 1-2: device descriptor read/64, error -110 like 4 times, hub 1-0:1.0: config failed, hub doesn't have any ports! (err -19) and usb 1-2: device not accepting address 5, error -62.

It seems to be something with USB, but all my USB ports are working fine?

I disabled XHCI hand off because of this and it booted very quickly; but I don’t think this is an ideal solution, I would like to be able to run my ports at their rated speed

Have you errors reported, when you create a new initrd ?

Then there may be some drivers missing

Please read the logfile of your last update (especially the creation of the initrd)

You can run this and look for complaints:

sudo mkinitcpio -P

Super weird behavior… After I disabled XHCI Hand-off, it booted instantly; I turned it back on to test if it would still be borked but it wasn’t…?

Startup finished in 29.696s (firmware) + 2.059s (loader) + 3.944s (kernel) + 3.600s (userspace) = 39.300s

Super confused.

Dual-booting with Windows can cause this, you’ve probably just reset things.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.