Kernel problem I guess : No irq handler

While boot, I am getting this error.

[marko@marko-hpenvy ~]$ hostnamectl

Static hostname: marko-hpenvy
Icon name: computer-convertible
Chassis: convertible
Machine ID: 24e2c57f6ba84d06b308aa0bfc428c1c
Boot ID: af82a8aa5386476aa19adf8bcc9a13e3
Operating System: Manjaro Linux
Kernel: Linux 5.8.3-2-MANJARO
Architecture: x86-64


I would say:

  1. Upgrade your UEFI/BIOS if possible
  2. installing irqbalance could be helping. Don`t forget to start and enable the service.
  3. Add pci=nomsi,noaer to GRUB_CMDLINE_LINUX= in /etc/default/grub and execute sudo update-grub in a terminal. (that should suppress the message and let the system boot)

Since it is a bug somehow by reading the kernel bug reports, idk what else could be done there.


Oh, I’m also getting this message at every bootup, but never care about it. Oopsie :sweat_smile:

But the system worked.
In a few parts I’m always having trouble (drivers for audio, ethernet and gpu) is this the cause?

Before changing the /etc/default/grub file permanently I would test it from the grub menu as proposed by Bogdan:


this coming from this change in linux kernel


Also effecting AMD 3600XT CPU kernel

Grub fixes do not work. And installing irq balance is no solution.

1 Like

I didn’t find fix for this issue… I tried every kernel, same thing

1 Like

i have the same problem,

Everyone should at least list their kernel and motherboard and bios version

I think this happened after i flashed the bios so it may be a bios update that caused it

Kernel : 5.9

Motherboard : Gigabyte X570 AORUS ELITE (rev. 1.0)

Bios : F31b

1 Like

same here
kernel 5.9.1-1
mb: ASRock > B550 Phantom Gaming-ITX/ax
cpu: AMD Ryzen 7 3700X

Hi, same here:

Kernel: 5.9.10-1
Mainboard: ASUS B550m plus (updated bios didn’t change anything)
CPU: Ryzen 3600

Same thing, showing this after Bios upgrade

MSI X570 Game Plus
Bios: 7C37vAC1(Beta version)
Kernal: 5.9.11-2

Bios update solved this problem and maybe triggered other problems … :confused: (under investigation)

1 Like

I updated my BIOS and still no joy

Kernel : 5.9

Motherboard : Gigabyte X570 AORUS ELITE (rev. 1.0)

Bios : F31o

@ lkovacs
ty for the update
Would you mind mentioning your motherboard and bios version that you upgraded to?

Hi sorry for late answer
my mobo: B550 Phantom Gaming-ITX/ax

latest bios : 1.80 with Update AMD AGESA Combo-AM4 V2 patch C

Same problem during boot, with same hardware as yours:

  • Gigabyte x570 AORUS ELITE
  • Bios: F30

So still no solution to this?

1 Like

I just updated to kernel 5.10 and the problem is fixed!!!

I updated the Kernel 5.10 too, but then it’s stuck on the no irq screen.
Generally my system is sorta bricked after the last updates (many programms won’t launch).

I’ve also updated to Linux 5.10, but problem is still not fixed.

What motherboard and what version bios are you using I updated my motherboard to the latest version