Kernel Panic with Dell Latitude 7390

Hi,

I bought an older Dell 7390 and want to run Manjaro, but whenever I try to boot, I get this screen.

Ubuntu also doesn’t boot: hangs at the boot screen. I tried 2 different USB drives. BIOS is up to date.

The integrated Dell hardware tests went OK. Windows 11 works fine.

Any ideas to fix this. Thx in advance.

Make sure to take a trip to the BIOS settings.
Ensure all the things are set/unset … AHCI mode on, then disable anything like speedstep, virtualization, etc. Possibly try doing these one at a time and seeing how the bootup works.

Your photo tells you that there is a hardware error. I’m afraid there’s nothing we can do to fix that.

It’s set to AHCI and I disabled Turbo Boost already. I will disable VT and also try speedstep (but this will be bad).

The hw tests went fine and Windows 11 works fine, but I don’t want Windows on it. I doubt that there is a hw fault.

Oh and I forgot to mention … of course check for BIOS updates.

BIOS is up to date, but the update enabled turbo boost again. I just disabled it and this time it booted up.

Edit: worked just once. No it’s not booting again. Now the caps lock led is flashing and I just get a blank screen. After some seconds the device service led shows a system hang.

Edit2: tried Linux Mint and it’s the same: blank screen. However I don’t get the kernel panic message anymore.

Edit3: I installed Debain 12. That worked fine. But after that I also just get a blank screen.

Hard to believe with the displayed hardware errors…

It is as it is. Sure I didn’t install all missing drivers, but the system log didn’t show any problems so far.

I just started MemTest86. That also needs some CPU power.

I installed Debian with full encryption. The first time I had to enter the password (after GRUB) I got a system hang while entering the password. Very strange.

Edit: the first check of MemTest86 finished without any errors.

Edit2: MemTest86 finished without any issues. With Debian I sometimes see “drm cpu pipe a fifo underrun”. however it looks like I need to give up and install Windows 11 again.

Edit3: the behavior changes in battery mode: Manjaro boots up, but freezes after a few seconds.

Edit4: I installed Windows 11 23H2 and all Drivers and worked with the device for about 2h without any problems.

Another buyer of this laptop checked it with Linux Mint and has no probs with it: Dell Latitude 7390 13,3" Touch FHD,i5 8350U, TB3, 16GB RAM, 256GB SSD, SIM, WLAN, BT uvm. | mydealz

Looks like there is really something wrong with my device. Too bad. I wonder that Windows has no problem with it.

You did try disabling Intel SpeedsStep (and SpeedShift) right? I found a couple of posts yesterday where people fixed similar ‘hardware’ errors (caused by buggy uefi firmware) by turning them off. Obviously, tracking latest bios releases would also be essential here.

The other guy did a BIOS update as well. I tried it again, just do make sure. The device freezed during boot:

Edit1: I did a BIOS factory reset (don’t know why I didn’t do that before. ATM the Linux Mint Live session is running for a few minutes.

Edit2: I tried to boot from Manjaro and came back to the kernel panic, see first post. I booted Linux Mint again and this still works. Just tried to start firefox and it freezed again.

I had a similar issue, here is what i did, no guarantees, but remove the memory modules, clean the module terminals, reinsert.

Reset the BIOS to Factory defaults and give it a try.

The memory check with MemTest86 passed.

How long?

MCE is in all cases I encountered pretty accurate. That MemTest was passed just means that the RAM acts normal and written data to RAM can be read again with CPU powered correction under low load.

Not recommended, but if you think that Linux is overreacting here, then disable mce on the kernel by a parameter:

mce=off

https://github.com/torvalds/linux/blob/master/Documentation/arch/x86/x86_64/boot-options.rst

In any case, it may well be that Windows has not reached the faulty area of ​​your RAM. This is mainly due to the type of caching/buffering. Linux is global and all programs share it, while Windows is file-based, which means: It creates cache on runtime and drops it when closed, while Linux drops only the oldest cache if RAM is full, just in case the cache can be reused.

An MCE error can als indicate a CPU Problem, since it “RIPs” when intel_idle is running. Probably try this parameter:

intel_idle.max_cstate=0

Anyway, it is some sort of hardware error for sure. And I would advise you a refund if possible. Such errors can come and go, mostly unpredictable.

1 Like

20+ years ago - some hardware pushers refused to refund when the hardware failed on Linux - they claimed Linux destroyed the hardware.

Then I devised a response to that rejection

No Linux does not kill hardware - it expose it’s flaws

You may, by accident, have gotten such system.

MemTest86 did its default 4 tests for about 3 hours. The system was supposed to be used with Manjaro. Therefore Windows is not an option to me. I will return the device. Bad luck.