Kernel panic when running updates

Hello everyone,

Running kernel 5.8…

I was running the latest update when my network failed in the middle of it. After that, I started having random kernel panics, so I decided to boot in the command line and run the update by hand.

Now, everytime that I try to update the system, I get an error:

Kernel panic - not syncing: Fatal exception at interrupt

at the end of a lot of low-level messages.

The error happens at “random” when doing the full update, meaning that it is not at a particular package.

Can anyone please help? I would like to avoid reinstalling the system from a Live USB.

Thank you!


Please try the same procedure while in 5.4 kernel (for instance) because is a LTS kernel.
If you get the same, then i suggest to check the CPU, could be a hardware failure.

1 Like

Can you post the hardware info ?

Thank you for replying. I am a bit new with this low-level troubleshooting so please be patient with me.

Yes, the problem happens with 5.4-LTS as well. I checked the memory and the hard disk suspecting the hardware error, it seems they are both OK. I also checked with/without battery and the problem is still there.

Suspecting hardware, I booted onto Windows and checked everything from there. Windows seems to behave fine (but I know it is a different partition).

After the kernel panic, I removed / reinstalled kernel 5.4, but didn’t help.

But I think it is important, the only way to reproduce the kernel panic is running pacman/pamac and updating packages.

Is there an easy way to copy from command line to another computer? I am stuck in the command line.

My hardware info (is there any particular output that would be helpful?):

Samsung RF711
Quad Core Intel Core i7-2630QM
Chipset: Intel Corporation 6 Series / C200 Series
Kernel: 5.8.3-2-MANJARO x86_64
Nvidia GeForce 540M
Mem: 1951.4/7969.6
HD 931.51 GB

Thanks again,

It is very likely that your root filesystem is full, which can happen if you have /var on the root filesystem itself and you don’t regularly clean out the package cache. If the root filesytem fills up, then you can indeed experience a kernel panic.

Check /var/cache/pacman/pkg and delete old packages. I usually delete them all, with…

sudo paccache -rvk0

… because I keep a number of full system backups anyway.

@Aragorn thanks for the tip. I deleted all old packages, it cleared almost 10 GB of space. But unfortunately, I still get the error when running pamac .

I am trying to either do a full system update, or first, to reinstall linux58, thinking that maybe, when I initially lost the network, the upgrade was in the middle of upgrading the kernel.

But no, I still get the kernel panic.

Boot up from the live medium. Open up a terminal window and type the following command… :arrow_down:

su -

Now, type the following command… :arrow_down:

manjaro-chroot -a

It will detect your Manjaro installation, and if you have more than one GNU/Linux system installed, it will let you choose the Manjaro root partition. Select the correct partition.

Now enter the following commands, and be sure to let them finish, no matter how long it takes. :arrow_down:

pacman-mirrors -f 5 && pacman -Syyu
mhwd-kernel -i linux58
sync && exit

It should now be safe to reboot your computer. :crossed_fingers:

Thank you @Aragorn,

I did what you suggested.

Updating pacman-mirrors worked alright. But when I ran the first command:

pacman -Syyu

I got the same kernel panic…

Are we looking at a true hardware error, possibly with my partition, as Windows works OK, or should I try something else?

At this point, I rather suspect a faulty memory module. I would advise running memtest86+ and letting it run for long enough. :thinking:

Another possibility is overheating, which can have the same effects as faulty hardware, although if the temperature gets too high, the machine will normally automatically shut off. But then again, you can already start experiencing faulty behavior before it gets to that point.

@Aragorn thanks a lot for the support and help through all these steps.

One of the first things I did was run the memory check (it passed successfully) because the caps lock light was flashing. Made me think of a hardware error.

Today the live image froze while I was just playing with it, kernel panic again.

Very strange that Manjaro is hitting the kernel panic after the latest updates, while Windows 10 has no trouble, as I used my Windows session for a few hours yesterday to check.

Makes me think of a very particular driver / hardware issue.

I am going to format the root partition and reinstall Manjaro. Not a lot of hope, as the live USB failed earlier.

If it still fails I’m going to try formatting my home partition as well. And if still fails I will use live USB or install from another Linux distribution, just for the sake of getting to the bottom of it.

I’ll change the memory modules if it fails under Windows as well.

Again, thanks a lot @Aragorn for the help. Very much appreciated.

1 Like

The thing is that Windows does not actually check the hardware’s integrity. It’ll just try using it nevertheless. :man_shrugging:

The thing is that Windows does not actually check the hardware’s integrity. It’ll just try using it nevertheless.

How does that not surprise me at all??? :grinning:

I have new information: I downloaded the Live image for an earlier version in Manjaro (19.0.2) and for a couple of hours it has not failed.

It seems that the issue is indeed with the very latest update from Manjaro.

I will install this version and avoid any driver / kernel updates for a bit and I guess I’ll take it one at a time to find out exactly what breaks my system.

In that case, I suspect the processor microcode. :thinking:

Edit: misquote

In that case, I suspect the processor microcode.

I will upgrade apps but take it slowly when upgrading drivers (video card, networking) and the kernel. Hopefully I can quickly pinpoint the offending item.

You’ve misquoted me. :wink:

The thing to keep in mind is that partial upgrades are not supported. But I do recommend trying an older kernel ─ perhaps 5.4. It’s an LTS kernel, and if you’re on older hardware, that might be a better option. :thinking:

@Aragorn, I said before: thank you very much for you guidance and support.

I reinstalled the system using an older Manjaro media (19.0.2) and it worked alright. Using Manjaro 20 was giving me kernel panics even on the Live USB.

But now, after installing from Manjaro 19 and running a full update, everything has been stable for a day or so. I am sticking to kernel 5.4 for now, somehow being on 5.8 and the updates messed my configuration.

The good thing is, I have a separate home partition, so besides installing a few programs, it was not that painful.

Thanks again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.