Kernel panic on boot because of missing "GLIBC_2.34"


After I booted into my system, I was greeted with this message, declaring a kernel panic and that it couldnt sync due to “GLIBC_2.34” being missing
I tried following the tutorial on the official site, to recover grub.
This however sadly didn’t work out, as I was once again confronted with “GLIBC_2.34” being missing in the chroot.

Also, this is not the fully up to date version of Manjaro, but instead 21.2.1 on both the PC and USB Stick.

I did take pictures of the screen and put in a link to the tutorial originaly but am not allowed to share them here since my account is pretty new.
This most likely happend due to me trying to install base-devel via pacman -Sy, because various efforts towards installing VSC with git clone and makepkg did not work out.
I was an idiot once more but would much prefer to not reinstall my OS and set up everything again for the third time in two month, so I really hope something can be done about this.

I appreciate any help, thank you!

Yes, this lead to a partial update. Never use -Sy to install packages:

Boot from usb, manjaro-chroot into your installation and fully update:

$ sudo pacman -Syu
1 Like


$ sudo pacman -Syu
$ sudo pacman -Syyu

just brought up the same error of GLIBC_2.34 being missing again.

I really appreciate the help but have already reinstalled the OS.
Also thank you for this maintenance article, I will be a lot more careful in the future