Kernel panic during update (again...!), did all recovery steps but Gnome won't start

My original post wasn’t clear enough. The following is an edit where I try to give as much detail of the situation as possible.

My laptop crashed during a big update, and I can’t make it work anymore. Here’s the details of what happened, and what I tried:

  1. I ran pamac update && pamac upgrade, and there were a lot (really) of packages to be updated. I chose to do it and authenticated.

  2. The update started, but after a few second, the screen freezed (systemd was the package being updated at that point), and the flashing LED of my CapsLock keyboard key suggested a kernel panic.

  3. After reboot, I got a blank screen with an error message about a missing vmlinuz file and failure to load the kernel (I don’t have the exact message… I should have taken note at once)

  4. In Grub shell, I found that in the relevant partition I had a file /boot/linux69-x86_64.kver and no vmlinuz-anything

  5. I used a recent ISO image of Manjaro to access my system via manjaro-chroot -a /mountpoint – I made sure everything was in order and that it was the right partition.

  6. I updated the mirrors (as per this guide from this forum), but when I ran pamac -Syyu I got a bunch of messages like:

:: File /var/cache/pacman/pkg/libwireplumber-0.5.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

I chose yes everytime, but the update failed in the end anyway.

  1. So I emptied the pacman cache (pacman -Scc), and then I ran pamac reinstall systemd, which gave:
Resolving dependencies...
Checking inter-conflicts...
Checking keyring...                                                                                [1/1]
Checking integrity...                                                                              [1/1]
Loading packages files...                                                                          [1/1]
Checking file conflicts...                                                                         [1/1]
Error: Failed to commit transaction:
conflicting files:
- systemd: /usr/lib/systemd/system/system-systemd\x2dcryptsetup.slice already exists in filesystem,
  if this file is not needed, remove it and retry
- systemd: /usr/lib/systemd/system/system-systemd\x2dveritysetup.slice already exists in filesystem,
  if this file is not needed, remove it and retry
  1. So, I manually deleted these files, re-ran pamac reinstall systemd, which completed successfully this time.

  2. Finally I ran pamac update && pamac upgrade one last time – some packages got updated – and finally I ran sudo update-grub, which also completed successfully.

But then, when I rebooted on my laptop’s drive, after two minutes of loading (the logo of my laptop’s constructor whith the three dots in the middle and the Manjaro logo at the bottom), I got to a blank screen. I couldn’t change TTY (when I did I just got a “_” symbol going on and off at the top left button of the screen). Finally I got an error message on the original TTY, saying “Could not load Gnome display manager” (I’m not 100% sure of the exact wording).

After checking that I got the same result after a second reboot, and a third with fallback initramfs, I went back to my live ISO, and used manjaro-chroot -a /mountpoint to run the two commands:

pamac reinstall gdm
systemctl enable gdm.service

Finally, I rebooted, and was greeted again by a blanck screen, just worst: now I don’t have any error message no matter how long I wait, nor can I switch TTY (no visual feedback to confirm I have switched to another TTY, not even a character in a corner of the sceen like mentioned above).

And that’s it, here I am. I gave you every last bit of information I had… I hope that we will be able to work from that!

I’m sure helpful volunteers would be happy to help you out, however so far we have nothing to go on at all. I see you have previous topics that may be related. It’s up to you to link them if they are pertinent.

Please help us help you and edit your topic title and first post accordingly.



Your profile says NVIDIA gpu. Read the stable update thread for solutions to problems with the latest NVIDIA driver.


I have re-written my whole post to give as much information as possible. Please come read it.

What about some inxi ?

  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --verbosity=8 --filter --width 
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
sudo inxi --verbosity=8 --filter --width 
  Kernel: 6.9.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64
    lang=en_US keytable=fr tz=Europe/Paris misobasedir=manjaro
    misolabel=MANJARO_GNOME_240 quiet systemd.show_status=1 splash
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: GNOME v: N/A tk: GTK v: 3.24.42 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: N/A Distro: Manjaro base: Arch Linux
  Type: Laptop System: Micro-Star product: Cyborg 15 A12VF v: REV:1.0
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Micro-Star model: MS-15K1 v: REV:1.0 serial: <filter> part-nu: 15K1.3
    uuid: 3caf41a6-37c5-4440-a541-006624a7cd4d UEFI: American Megatrends LLC.
    v: E15K1IMS.310 date: 03/29/2024
  ID-1: BAT1 charge: 43.1 Wh (98.6%) condition: 43.7/52.0 Wh (84.1%)
    volts: 11.6 min: 11.4 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: discharging
  System RAM: total: 32 GiB available: 31.06 GiB used: 4.46 GiB (14.4%)
    igpu: 60 MiB
  Array-1: capacity: 64 GiB slots: 2 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: Controller0-ChannelA-DIMM0 type: DDR5 detail: synchronous
    size: 16 GiB speed: spec: 5600 MT/s actual: 4800 MT/s volts: curr: 1.1
    min: 1.1 max: 1.1 width (bits): data: 64 total: 64 manufacturer: SK Hynix
    part-no: HMCG78AGBSA095N serial: <filter>
  Device-2: Controller1-ChannelA-DIMM0 type: DDR5 detail: synchronous
    size: 16 GiB speed: spec: 5600 MT/s actual: 4800 MT/s volts: curr: 1.1
    min: 1.1 max: 1.1 width (bits): data: 64 total: 64 manufacturer: SK Hynix
    part-no: HMCG78AGBSA095N serial: <filter>
PCI Slots:
  Slot: 0 type: PCIe lanes: 16 status: in use info: J6B2 length: long
    volts: 3.3 bus-ID: 00:01.0 children: 1: 01:00.0 class-ID: 0300 type: display
    2: 01:00.1 class-ID: 0403 type: audio
  Slot: 1 type: PCIe lanes: 1 status: in use info: J6B1 length: short
    volts: 3.3 bus-ID: 00:1c.3
  Slot: 2 type: PCIe lanes: 1 status: in use info: J6D1 length: short
    volts: 3.3 bus-ID: 00:1c.4
  Slot: 3 type: PCIe lanes: 1 status: in use info: J7B1 length: short
    volts: 3.3 bus-ID: 00:1c.5 children: 1: 04:00.0 class-ID: 0200 type: network
  Slot: 4 type: PCIe lanes: 1 status: in use info: J8B4 length: short
    volts: 3.3 bus-ID: 00:1c.6
  Info: model: 12th Gen Intel Core i7-12650H socket: U3E1 bits: 64
    type: MST AMCP arch: Alder Lake gen: core 12 level: v3 note: check
    built: 2021+ process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154)
    stepping: 3 microcode: 0x424
  Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
    cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
    L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 406 high: 498 min/max: 400/4600:4700:3500
    base/boost: 2277/4700 scaling: driver: intel_pstate governor: powersave
    volts: 0.9 V ext-clock: 100 MHz cores: 1: 400 2: 400 3: 400 4: 400 5: 400
    6: 400 7: 498 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400 15: 400
    16: 400 bogomips: 86048
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep smx split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip user_shstk vaes vme vmx vnmi
    vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Vulnerable: No microcode
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS; IBPB: conditional;
    RSB filling; PBRSB-eIBRS: SW sequence; BHI: BHI_DIS_S
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:46a3 class-ID: 0300
  Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile]
    vendor: Micro-Star MSI driver: nvidia v: 550.78 non-free: 550.xx+
    status: current (as of 2024-04) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ bus-ID: 0000:01:00.0 chip-ID: 10de:28a0
    class-ID: 0300
  Display: server: v: with: Xwayland compositor: gnome-shell
    driver: X: loaded: nvidia failed: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: i915 display-ID: :0
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1521 built: 2020 res: 1920x1080
    dpi: 142 gamma: 1.2 chroma: red: x: 0.592 y: 0.349 green: x: 0.329 y: 0.557
    blue: x: 0.153 y: 0.118 white: x: 0.314 y: 0.329
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: EGL v: N/A platforms: active: N/A inactive: wayland,x11,surfaceless
  API: OpenGL Message: GL data unavailable for root.
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Micro-Star MSI
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8
    class-ID: 0401
  Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:22be class-ID: 0403
  API: ALSA v: k6.9.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.7 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic scope: global broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000
    bus-ID: 0000:04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:2 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 1.02 TiB used: 186.32 GiB (17.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SFYRS1000G
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: EIFK31.6 temp: 22.9 C
  ID-2: /dev/sda maj-min: 8:0 model: USB Flash size: 117.75 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s lanes: 1
    mode: 3.2 gen-1x1 tech: SSD serial: <filter> fw-rev: 1100
  Message: No optical or floppy data found.
  ID-1: / raw-size: 897.06 GiB size: 881.9 GiB (98.31%)
    used: 186.31 GiB (21.1%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2 label: N/A uuid: d781dc69-126d-4138-b1da-43f9a24f5435
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1 label: N/A uuid: 5570-4D8E
  Alert: No swap data was found.
  ID-1: /dev/dm-0 maj-min: 254:0 mapped: ventoy size: 3.66 GiB fs: N/A
    label: MANJARO_GNOME_240 uuid: 2024-05-13-11-37-23-00
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 34.16 GiB fs: swap label: swap
    uuid: 3edf65c8-b606-4168-b7c5-b88b5269beaa
  ID-3: /dev/sda1 maj-min: 8:1 size: 117.72 GiB fs: N/A label: Linux-live
    uuid: A825-377E
  ID-4: /dev/sda2 maj-min: 8:2 size: 32 MiB fs: N/A label: VTOYEFI
    uuid: 83A6-E98E
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-4:3 info: Xenta JLab JBuds Mouse type: keyboard,mouse,HID
    driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 1d57:fa60 class-ID: 0301
  Device-2: 1-10:2 info: Intel AX201 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0026 class-ID: e001
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Device-1: 2-1:2 info: Silicon Motion - Taiwan (formerly Feiya ) Disk
    type: mass storage driver: usb-storage interfaces: 1 rev: 3.1
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 power: 504mA
    chip-ID: 090c:2000 class-ID: 0806
  System Temperatures: cpu: 31.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Packages: 1698 pm: pacman pkgs: 1691 libs: 492 tools: gnome-software,pamac
    pm: flatpak pkgs: 7
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  CPU top: 5 of 430
  1: cpu: 600% command: ps pid: 30285 mem: 4.10 MiB (0.0%)
  2: cpu: 98.2% command: firefox pid: 28966 mem: 444.4 MiB (1.3%)
  3: cpu: 33.4% command: firefox pid: 29320 mem: 245.6 MiB (0.7%)
  4: cpu: 15.5% command: gnome-shell pid: 28137 mem: 280.7 MiB (0.8%)
  5: cpu: 10.5% command: Xorg pid: 28039 mem: 139.2 MiB (0.4%)
  Memory top: 5 of 430
  1: mem: 444.4 MiB (1.3%) command: firefox pid: 28966 cpu: 98.2%
  2: mem: 280.7 MiB (0.8%) command: gnome-shell pid: 28137 cpu: 15.5%
  3: mem: 245.6 MiB (0.7%) command: firefox pid: 29320 cpu: 33.4%
  4: mem: 139.2 MiB (0.4%) command: Xorg pid: 28039 cpu: 10.5%
  5: mem: 129.5 MiB (0.4%) command: firefox pid: 29189 cpu: 2.8%
  Processes: 430 Power: uptime: 3m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend,
    test_resume image: 12.38 GiB services: gsd-power, power-profiles-daemon,
    upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Compilers: clang: 17 gcc: 14.1.1 alt: 13 Shell: r-netns (sudo)
    default: Bash v: 5.2.26 running-in: kthreadd inxi: 3.3.34