Kernel Panic before splashscreen

Hi, this morning i opened up my laptop and got the manjaro password splashscreen, i turned off my laptop cuz i had to go and when i started it again it wouldn’t start and my caps lock light is blikning in a - - - patern wich from what i found indicates kernel panic, the screen don’t even turn on, i tried charging it but still doesnt work, also i tried to install manjaro in dual boot with windows and it corrupted windows a few month. also i’m a student and i rly need my laptop and its data.

Shiz bro, first try to find a way to save your data, that is the most important.
Second as the windows is corrupted and majaro is not booting, I suggest you burn a 4 gig usb with kde or xfce with rufus. Boot the the computer from the usb but pressing f8/f12 in the bios.Select usb and boot from it. It a problem persists, then it is a hardware problem, and I suggest giving us a few details as well as checking it by a nearby computer shop. I am a xfce standout, and a computer enthusiast, and by your descripcion I see that you have a pentium n5000, which is a good processor, being a quad and all the good goodness. That paired with a 4 gig to 16 gig ram is a good combo, but we can help more it you give more info about the computer.
inxi -fazy

thx for the reply, I’m an enthusiast too, this is why i picked that cpu, but i can’t even go to bios since the screen won’t even turn on. Also windows got corrumpted by manjaro’s install, 6month ago. The problem may come from the dual boot thing (i don’t remeber the name of it) cuz i don’t even reach its splashscreen wich usually always show up at startup so i can choose my OS.

Manjaro has not been fully developed yet, even after all these years. If you connect it to a smart tv, for example, you will see the internet keep reconnecting and not working, due to confusion of the os not understanding to which network card to give full power. This and many many other small bugs are sadly common, and the end users has to tweak this by themselves. One such problem is in dual booting, and the manjaro os can’t figure out which kernel to use, due to the freedom of the kernel use on the end user and the windows kernel not being able to change. This might as well be the reason the why your windows had failed to start, and your manjaro is not working right now.

Enough about software and diagnosis, now come to the solutions.

  1. If you say that you are computer enthusiast, so you might know a bit about your computer’s internals, (i.e you might have opened your computer up previously a couple of times) .So, if you are able easily access your hard drive/ssd/nvme, so try to change it with a storage device ,(hard drive/ssd/nvme) which has manjaro/ windows pre installed and is in working condition.Try another laptop’s storage device, like the laptop you are typing on. If it works, kudos! If you have nvme, and can’t change out the storage device, try removing the nvme stick and plugging in a usb with manjaro and booting from it.
  2. You should try this too, plugging an external monitor, and and checking if it posts/starts. If it doesn’t, try step 1 and repeat.
    Do try it and tell us about your progress, this will enable us to help you even more. But, if all fails, send it to a trusted computer shop, and he will hopefully help you.
1 Like

I’m not typing on a lapotop but on my gaming desktop.
the storage is 64GB of soldered emmc so i can’t swap/read anything from it.
even with the Manjaro bootable usb stick the screen won’t turn on, even with external monitor.

also windows got corrupted on the instal and the recovery tools didn’t manage to fix it, and i deleted window’s partitions few month ago to have more storage on manjaro, nothing changed recently and i updated everything 1week ago.
Also i have a wifi/bluetooth pcie card inside the laptop and from 6 drivers designed for that card i tried only 3 managed to enable bluetooth and none enabled the wifi, wich is kinda annoying for a laptptop.
The laptop have 4GB of LPDDR4 ram wich is good enough for the price and use i get from it.

I miss my windows cuz since i swaped for manjaro everything is going wrong, even if i knew that it was going to happen, i didn’t expect such a bad experience, may be caused by the fact that laptop is not popular cuz it is a low end laptop.

Anyway, thx for the help, i hope someone is going to find an anwser, if not then i’m going to send it to warranty services on monday or thuesday.

Yeah it is really frustrating, when you get all these problems and cant fix them all at once. Be patient, and The best thing is to send to specialised services. However, the problem doesn’t lie with Manjaro, or any other os for that matter, and wait, did you mention drivers. Yeah, please don’t try that on Manjaro, as there is a bit of translation needed for windows to linux drivers. Kernels are stored on the storage, and it is the exact reason I suggested the storage swapping out. Specialised services may be able to solder out the emmc storage, and find ways, Don’t worry, as they might figure it out.