Kernel errors and some problems

I have latest 5.10.7 kernel installed. I often have issues in journalctl log, like:

wpa_supplicant[389]: nl80211: kernel reports: key addition failed
kernel: psmouse serio1: elantech: elantech_send_cmd query 0x00 failed.
systemd-modules-load[205]: Failed to find module 'v4l2loopback-dc'

and always these ones:

    kernel: Bluetooth: hci0: don't support firmware rome 0x11020000
    pipewire[1012]: Failed to receive portal pid: org.freedesktop.DBus.Error.NameHasNoOwner: Could not get PID of name 'org.freedesktop.portal.Desktop': no such name

When I have upper messages I may experience issues with my touchpad (it is seen as an ordinary mouse), very long shutdown times, stack trace spams in the logs. These errors appear sometimes only and a reboot fixes them most of the time.

This problems begun with 5.10 kernels. Now I cannot shift to 5.9 kernel, it stucks at boot always. Is this a hardware problem? Otherwise, how can I track the problem?
My inxi -Faz result:

 System:    Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=6b0569e6-71a6-459e-99cc-ac225fe06b91 rw 
           udev.log_priority=3 ec_sys.write_support=1 sysrq_always_enabled=1 systemd.unified_cgroup_hierarchy=true 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire S3-391 v: V2.17 serial: <filter> 
           Mobo: Acer model: Hummingbird2 v: V2.17 serial: <filter> UEFI [Legacy]: Insyde v: 2.17 date: 07/18/2013 
Battery:   ID-1: BAT0 charge: 29.8 Wh condition: 33.9/35.5 Wh (96%) volts: 11.7/11.1 model: SANYO AP11D3F type: Li-ion 
           serial: <filter> status: Discharging 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M525 serial: <filter> charge: 100% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 21 L2 cache: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13574 
           Speed: 826 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 826 2: 1120 3: 866 4: 1791 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0166 
           Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 3-4:2 chip ID: 04f2:b33b 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 120 size: 290x160mm (11.4x6.3") diag: 331mm (13") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.3.3 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k5.10.7-3-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Foxconn driver: ath9k v: kernel port: 2040 
           bus ID: 02:00.0 chip ID: 168c:0034 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 223.57 GiB used: 127.15 GiB (56.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SUV400S37240G size: 223.57 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 87RA 
Partition: ID-1: / raw size: 182.62 GiB size: 178.75 GiB (97.88%) used: 127.15 GiB (71.1%) fs: ext4 dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.38 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 maj-min: 8:3 
Sensors:   System Temperatures: cpu: 54.0 C mobo: 50.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 211 Uptime: 13m wakeups: 3 Memory: 3.67 GiB used: 2.12 GiB (57.8%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1850 lib: 465 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.2.02

First and foremost - check if your firmware version is the latest available for your system.

The 5.10 kernel has it’s own issues - and if your system works better with 5.9 I would switch to it.

The team faces problems with 5.10 and 5.11 too - e.g. the tools to build ISO suffers from a temp file problem in kernel 5.10 and switching to 5.9 - then it works.

If you prefer a supported kernel then you could try using the 5.4 LTS kernel.

1 Like

I had tried 5.4 kernel before, and I had issues with them also. The problem was, I was not able to use 5.9 kernel also, it had stucked every boot.
After your post I tried to uninstall and reinstall the 5.9 kernel (and 5.4 also) and it seems 5.9 working now. The only error reported i pipewire (I read some about the bluetooth error that it is harmless).
If the firmware you mentioned is bios, it is the latest.
Thank you, I will watch for possible issues.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.