Kernel 5.8.6 not always starting

I’m on Manjaro 20.1 with kernel 5.4.64 lts
I just installed 5.8.6…rebooted and working perfectly.
But sometimes if I reboot it gets stuck with black screen(with motherboard logo) during startup(1/5 times)

But it mainly happens if I shutdown the machine and then start it(4/5 times)

Is there any way to fix this?

(Adding 'acpi=off '/ ‘pci=noacpi’
in grub not working)

can you please
add theses kernels

sudo mhwd-kernel -i linux419

reboot , press Esc and Stay on these LTS version

since end 5.6 , version 5.7 and 5.8 , family haswell , broadwell , ivy cpu & motherboard have freeze or works slow

moreover you don’t provide the logs when these errors occur

I can now provide logs… because I can use 5.8.6
Just sometimes it doesn’t start and I have to press the restart button and it starts

so you can try with

sudo journalctl -b -1 ( boot before )

Logs begin at Sat 2020-09-19 20:17:34 IST, end at Thu 2020-09-24 14:17:20 IST. –
Sep 24 14:15:35 King kernel: microcode: microcode updated early to revision 0x21, date>
Sep 24 14:15:35 King kernel: Linux version 5.8.6-1-MANJARO (builder@db927223e331) (gcc>
Sep 24 14:15:35 King kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UU>
Sep 24 14:15:35 King kernel: KERNEL supported cpus:
Sep 24 14:15:35 King kernel: Intel GenuineIntel
Sep 24 14:15:35 King kernel: AMD AuthenticAMD
Sep 24 14:15:35 King kernel: Hygon HygonGenuine
Sep 24 14:15:35 King kernel: Centaur CentaurHauls
Sep 24 14:15:35 King kernel: zhaoxin Shanghai
Sep 24 14:15:35 King kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating po>
Sep 24 14:15:35 King kernel: x86/fpu: Supporting XSAVE feature 0x002: ‘SSE registers’
Sep 24 14:15:35 King kernel: x86/fpu: Supporting XSAVE feature 0x004: ‘AVX registers’
Sep 24 14:15:35 King kernel: x86/fpu: xstate_offset[2]: 576, xstate_sizes[2]: 256
Sep 24 14:15:35 King kernel: x86/fpu: Enabled xstate features 0x7, context size is 832>
Sep 24 14:15:35 King kernel: BIOS-provided physical RAM map:
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009dfff] us>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x000000000009e000-0x000000000009ffff] re>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000de2adfff] us>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x00000000de2ae000-0x00000000de755fff] re>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x00000000de756000-0x00000000de765fff] AC>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x00000000de766000-0x00000000de874fff] AC>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x00000000de875000-0x00000000dee48fff] re>
Sep 24 14:15:35 King kernel: BIOS-e820: [mem 0x00000000dee49000-0x00000000deee9fff] ty>
lines 1-24

can you give
( open terminal windows for copy all text )

sudo journalctl -b -1 -p4 

– Logs begin at Sat 2020-09-19 20:17:34 IST, end at Thu 2020-09-24 14:38:27 IST. –
Sep 24 14:15:35 King kernel: MDS CPU bug present and SMT on, data leak possible. See h>
Sep 24 14:15:35 King kernel: #5 #6 #7
Sep 24 14:15:35 King kernel: ENERGY_PERF_BIAS: Set to ‘normal’, was ‘performance’
Sep 24 14:15:35 King kernel: ata2.00: supports DRM functions and may not be fully acce>
Sep 24 14:15:35 King kernel: ata2.00: supports DRM functions and may not be fully acce>
Sep 24 14:15:35 King kernel: nvidia: loading out-of-tree module taints kernel.
Sep 24 14:15:35 King kernel: nvidia: module license ‘NVIDIA’ taints kernel.
Sep 24 14:15:35 King kernel: Disabling lock debugging due to kernel taint
Sep 24 14:15:35 King kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module 450.66 W>
Sep 24 14:15:36 King kernel: ACPI Warning: SystemIO range 0x0000000000000428-0x0000000>
Sep 24 14:15:36 King kernel: ACPI Warning: SystemIO range 0x0000000000000540-0x0000000>
Sep 24 14:15:36 King kernel: ACPI Warning: SystemIO range 0x0000000000000530-0x0000000>
Sep 24 14:15:36 King kernel: ACPI Warning: SystemIO range 0x0000000000000500-0x0000000>
Sep 24 14:15:36 King kernel: lpc_ich: Resource conflict(s) found affecting gpio_ich
Sep 24 14:15:36 King kernel: r8169 0000:03:00.0: can’t disable ASPM; OS doesn’t have A>
Sep 24 14:15:36 King kernel: at24 0-0051: supply vcc not found, using dummy regulator
Sep 24 14:15:36 King kernel: urandom_read: 6 callbacks suppressed
Sep 24 14:15:37 King kernel: sd 4:0:0:0: [sdc] Optimal transfer size 33553920 bytes no>

can you add

sudo pacman -Syyu pastebinit
sudo journalctl -b -1 | pastebinit

and give return url

Bad API request, invalid api_dev_key

Installed arch today…kernel 5.8.10 is working perfectly fine

Now I’m more confused!!

Howdy!

Try to sudo mkinitcpio -P && sudo update-grub !

Have a wonderful day!

I’m now on arch
Will soon b on Manjaro again
Will give it a try

Thank you

Not working :pensive: