Kernel 5.16.2-1 installed but not running

Currently running Manjaro KDE Qonos 21.2.2 with kernel 5.15.16-1. Decided to install the latest kernel 5.16.2-1. After rebooting the PC, Manjaro Settings Manager shows that kernel 5.16.2-1 is installed but not running. Why? Thanks to savvy members for helping solve this issue.

In order to boot with that kernel, you must first select it in the “Advanced options for Manjaro Linux” submenu of GRUB.

By default, GRUB will always boot with the kernel that was last selected, which is why you’re still running the 5.15 kernel now. In order to change this behavior, you can set a default entry that GRUB must pick. Look near the top of /etc/default/grub. You will see the following entry… :arrow_down:


1 Like

Press Esc during boot to get into grub menu > advanced options and boot with 5.16

Depending on the hardware used, it can also be Shift instead of Esc. At least that’s what I found out for my own laptop. :slight_smile:

1 Like

Both should normally work.

Thanks to all for sharing your knowledge. Pressing ESC didn’t get me anywhere. Once in Grub menu, selected Advanced Options and only kernel 5.15.16 was listed. That’s odd.

How did you install the 5.16 kernel?

And how do you know it’s installed?

  1. clicked Manjaro Settings Manager
  2. selected Kernel
  3. selected kernel 5.16.2-1
  4. clicked install
  5. rebooted
  6. clicked Manjaro Settings Manager and selected Kernel and noticed that kernel 5.16.2-1 is installed but not running + kernel 5.15.16 is marked as installed and running.

Try this… :arrow_down:

sudo mhwd-kernel -i linux516
sudo update-grub

Have a look at

More specifically

  1. Followed @aragorn and @Mirdarthos suggestions - from the terminal:
sudo mhwd-kernel -li                                                                                     ✔ 
[sudo] password for snowdust: 
Currently running: 5.15.16-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515
   * linux516
    ~  sudo mhwd-kernel -i linux516                                                                      ✔  8s  
:: Synchronizing package databases...
 core                                        167.7 KiB   359 KiB/s 00:00 [########] 100%
 extra                                      1899.9 KiB  1418 KiB/s 00:01 [#######] 100%
 community                                     6.9 MiB  2.36 MiB/s 00:03 [#####] 100%
 multilib                                    174.3 KiB  2.21 MiB/s 00:00 [#######] 100%
warning: linux516-5.16.2-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...
  1. Rebooted
  2. In Grub menu, selected Advanced options … kernel 5.16.2-1 still not listed
  3. Booted into desktop session, clicked Manjaro Settings, selected Kernel … kernel 5.16.2-1 is shown as installed but not running. Kernel 5.15 is listed as still running.
  4. Should I uninstall kernel 5.16.2-1? or Should I install a fresh copy of Manjaro KDE?
    Thanks to all for your kind support.

If the kernel is not listed in GRUB, then this can only mean one thing, i.e. that the GRUB you’re booting with is not the GRUB that’s controlled by Manjaro, or more precisely, not by the Manjaro system you’re booted into.

I am guessing you’ve installed a second Manjaro on the same system. Am I right?

I suspect you’ll have to uninstall 5.16:

mhwd-kernel --remove linux516

Followed by a reboot and then reinstalling it:

mhwd-kernel --install linux516

And reboot again, to if it’s available in the Advanced... menu now.

@Aragorn :

  1. ssd M.2 running a fresh install of Manjaro KDE as of yesterday and running kernel 5.16.2
  2. ssd (sda) running Manjaro KDE installed several several moons ago and currently having both kernels 5.15 & 5.16 installed
  3. ssd (sdb) running Manjaro Cutefish installed several weeks ago and running kernel 5.16.2

@Mirdarthos : will follow your suggestions and report back.

Bingo! There you go! I rest my case. :stuck_out_tongue:

The one you installed yesterday has become the primary GRUB. You’ll have to override that by reinstalling GRUB from within the one in which you want to use the 5.16 kernel, which I’m guessing is the second one.


sudo grub-install --no-rs-codes  --recheck
sudo update-grub
1 Like

@Aragorn: followed your suggestion and launched the command line from ssd(sda) which is my everyday go-to disk, but … unfortunately the problem still persists. Upon reboot the screen went black for a while, enough to scare me, then got to the login screen and immediately checked with MHwd settings and kernel 5.16.2 is still listed as installed only. Kernel 5.15 is marked as installed and running.
For the second time launched the command line in the terminal and this is what I get:

sudo grub-install --no-rs-codes  --recheck                                                               ✔ 
[sudo] password for snowdust: 
Installing for x86_64-efi platform.
Installation finished. No error reported.

@Mirdarthos : followed your suggestion. Removed and reinstalled kernel 5.16. Upon boot, checked the advanced options in the grub menu and kernel 5.16 still not listed. Got to the desktop and checked the Manjaro Mhwd settings and kernel 5.16 listed as installed only and kernel 5.15 shown as installed and running.
Thanks for helping.

In that case I’m with @Aragorn. You seem to have a rogue GRUB.

Or, actually, it could just be your boot priority. But that you’ll have to check yourself. I think.

Or post the output of:

sudo lsblk

Along with an explanation what each drive is for.

Also the output for:

efibootmgr -v
1 Like

can you return result

sudo mkinitcpio -P

is all ok or there is an error ?