Kdenlive does not want to render AMD VAAPI (mlt_repository_init: failed to dlopen)

Friends, I understand that this refers to the program, but the situation is very incomprehensible. There are files that she cannot find with the system. But for some reason, she still does not want to use them and gives an error when rendering hardware accelerated (experimental) VAAPI AMD 264.

mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltmovit.so (libmovit.so.8: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltopencv.so (libopencv_tracking.so.407: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltrtaudio.so (librtaudio.so.6: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltsox.so (libsox.so.3: cannot open shared object file: No such file or directory)
[h264_vaapi @ 0x7f330c201fc0] No usable encoding profile found.

Any ideas?

My PC:

OS: Manjaro Linux 
V KDE Plasma: 5.27.4
V KDE Frameworks: 5.105.0
V Qt: 5.15.9
V of kernel: 6.3.0-1-MANJARO (64-bits)
Graphic server: X11
Processors: 4 × Intel® Core™ i3-9100F CPU @ 3.60GHz
RAM: 7,7 GB
GPU: AMD Radeon RX 470 Graphics

Also, there is no support for a video card when recording or broadcasting video through the OBS program (obs-studio-amf).
And SimpleScreenRecorder doesn’t want to record video with h264_amf either.
Tell me, maybe I need to install some additional packages in order for the hardware argument to work.

You may need to install the none free Mesa, which includes h264 / h265 en-/decoder

https://nonfree.eu/

1 Like

Screenshot_20230509_192946
Does it look like it’s installed?

It does not have the ability h264 and h265 in the official repo by default.

See:

Marvelous. I installed the update data.
If anyone does not understand how to do this, then.

  1. Follow the link https://nonfree.eu/.
  2. Run the commands listed at the top of the page.
  3. Update the databases in pacman (manager).
  4. Pacman manager should offer to update components.

But! Surprisingly, now with the same setting (hardware acceleration) in Kdenlive, video rendering occurs, but the video card still does not participate in the video encoding process. The entire load, as before, lies on the central processor.

OBS Studio and SimpleScreenRecorder still don’t work with video card like before. SimpleScreenRecorder is generally unloaded from memory when you select the h264_amf codec and start recording.

It turns out interesting that despite the openness of drivers for AMD video cards, in order for it to work for real, you still have to use proprietary software. What then is the point at all in Linux? It’s pure coding to sit in it and that’s it … or watch videos in FullHD, no more …
What a big lie is hidden here, that despite the much publicized openness of the software, we come to the fact that we are essentially forced to use closed software. I am extremely disappointed. Why is Linux better then W…s?
Moreover, hundreds of packages that are installed by default in the system, changes to the Linux kernel for each distribution separately, all this makes Linux very similar to W…s and other closed operating systems.
It turns out that all that torment and learning to use this system, which has been going on for the third year with me (exactly three years I have been using Linux), were in vain. Since the understanding has come that it is easier to just take and install W … s and not experience terrible anguish and pain from constantly arising problems. You just take, install and do not waste time looking for answers to completely banal things that should go in the open with the operating system.
Yes, I certainly understand that Linux has many advantages, but it will take more than one year to understand, learn and use them all. Unlike W…s, where you download some program from a torrent with an activator and use it without actually paying, perhaps paying only with the telemetry of your actions, files and computer life. But if there is nothing to hide, then why “pay more” time for Linux?

I would like to express my unconditional gratitude to all those who develop open source software. But we come to the fact that the main programs are “imposed” on us to use closed source. I have nothing to hide and for many years I did not even think about changing W…s. But if we are talking about comprehensive open source software, then why are the main components in this case “imposed” with closed source? I was very glad that I started using Linux, before this huge disappointment.
Instead of just minding my own business, I have to spend a lot of time getting Linux up and running properly. Although, at the moment it takes away the computing power of the video card from me. I don’t even know what to do now.

Do you have hardware acceleration properly configured?

https://wiki.archlinux.org/title/Hardware_video_acceleration

This does not demonstrate any fail or lie.
It does however demonstrate you have yet to grasp some of these concepts in full.

Calm down and learn a bit.
Or go back to windoze … no one is stopping you.

What are you even going on about?
That adobe doesnt make a creative suite for linux? Or that some codec is proprietary?
That is not a linux failure in the least.
To the extent we are talking about external (rather than personal) ‘forces’ … they have very little to do with opensource … rather with the physical and intellectual properties you wish to use… possibly encouraged by some other factor such as economic or employment.

That all said … neither Arch nor Manjaro is a free-only or political distro. You can choose how many bits of free/open/non-free/closed components you like … for something totally free look at a distro like Parabola … I think you will find that the difference between what you have now and something ‘free software only’ will be markedly different.

h264 is a proprietary codec.
A definition of ‘proprietary’:
“Owned by a private individual or corporation under a trademark or patent: a proprietary drug.”
If you want to use it … then you gotta use that non-free bit, accepting the licenses and restrictions.
Fault of freedom? Hardly.

1 Like

Thanks for the advice. I need to spend half a year to understand that article and test all possible options from it. But I did it easier - I put W…s on an old HDD and now I can not waste time learning the various nuances of using Linux. Still, I currently use Linux as the main system.


I’m talking about non-free software, in my particular situation. When it seems like AMD drivers are open source and, in theory, all programs should work fine with open source, and also support all the features of HardWare, but it turns out that I need to go through 9 circles of hell in order for hardware acceleration to work. However, I also need to use open source software. I didn’t talk about everything Linux. Since I can’t even imagine how many programs are actually written for it today and how they make life easier for people. I spoke specifically for the situation that I have. That in order to use AMD with open drivers, I have to install it in the end, it’s not clear what and it’s not clear how, in order for the video card to work 100%.

Yes, I am not fully versed in various issues. But what I see still causes me a slight shock and a sense of deception.


After such troubles, many wonder why Linux is so unpopular…

Linux is by far the most popular kernel on planet earth. Where from are you?

Only in one area, the windows desktop gamer paradigm, does another operating system hold higher popularity.

Where from are you??

planet earth, hello! Where from are you? Do you have problems in reading comprehension of englisch languake? Or just in basic knowledge?

Android is Linux.

See that graph overwhelmingly at the top? Yes, that one. That’s one of Linux. Then there are the one that recently started increasing, called “others” is probably largely Linux, and furthermore of course the one called Linux.

Add these up, and you see the Linux market share of web browsing devices. But in my previous post i also referenced servers, IoT and supercomputers, all of which above 90’% using Linux.

So we can safely say Linux is 80% popular, with all others sharing single digit popularity, combining to 20% of operating systems running on planet earth.

Congratulations

tell me again, where from are you? Just visiting from delusionaland?

Fine. Let’s face it. What average user can take the Android you’re so proud of and use it for any device? It’s as hard as taking the Linux kernel and using it for the average user. Those. I want to say that Android is far from naked Linux, and the Linux kernel can only be used by specialists or development teams who use it for their distributions.
My intentions are too simple. Take a woman who is 60 years old and ask her to install and use Android, Linux, Windows. I can hardly imagine how this conditional woman is looking for information on installing Linux. And Windows will be easy for her. Don’t you know hundreds of jokes and memes that Linux is too difficult. I’m not talking about the millions of servers used for industrial purposes. I’m speaking from the standpoint of the average user for whom Windows has done everything they can to make it easy to use. Unlike Linux, where you have to learn everything yourself. Starting from what should be the partition table for your hard drive and ending, for example, with such difficult questions, the topic of which I raise in my first post in this thread.
Again. I don’t think that millions of servers running Linux or billions of smartphones running Android are not some significant number. I’m talking about simpler things. Such as the ergonomics of interaction with the operating system. Agree that smartphones are those devices on which either never or very rarely one of the ordinary users installs the operating system on their own, with the exception of cases of automatic flashing with already written programs that make this process easy.
I would like you to understand my position. I am glad and happy that there are Linux and distributions based on it, there may be billions of them. But when it comes to ordinary simple things, for example, using an AMD video card to the full, for some reason I have to study this issue and spend a lot of my time to make the video card work and do its job, for example, decoding the video stream. But “out of the box” this function is not. Unlike Windows, which installs faster (even on an old HDD), has a familiar and intuitive interface, and can also work with any hardware that can be connected to a computer without experiencing terrible pain from having to install some kind of a program about which you can find information only on a certain forum, and it is not clear how an ordinary user can get to it.
Of course, Windows has its drawbacks, but in terms of ease of use for the average user, it’s easier to choose what many people use than to stay with oneself and choose what only a few use (as a home operating system).

Sorry if I hurt your feelings. All the best. I think further dialogue is pointless.


For example, now, after a full system reinstall, I can’t start LibreOffice because I get this error:

javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

And just googling this error, I never found a solution, spending 30 minutes on it.

Im gonna skip all the other diatribes and point out that this looks like a non-standard java …
And … you dont need java for libreoffice … in fact most people disable JRE in LibreOffice in order to get a small performance boost.

Maybe you can benefit from the env var?

STOC_FORCE_NO_JRE libreoffice

Very surprising as I can find related (albeit unrequired) articles all over the place … example: