[KDE] Windows on 144hz monitor are 60fps - Dual monitor setup w/ one 60hz & one 144hz

Hello, this is my first time here.

I am currently having an issue where the windows on my main display (which is 144hz) seem to run at 60hz. My display is set to 144hz, cursor is moving at 144hz, games are playing at 144hz but not the desktop windows. If I disable my second monitor which is 60hz, they all work perfectly and so smoothly. (Honestly just found out about this now. I though it was all like this but oh my god I missed so much.)

I looked at couple of compositor settings as well as nvidia settings but nothing seems to be working so far. Please help.

System:    Kernel: 5.12.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5 Distro: Manjaro Linux 
           base: Arch Linux 
CPU:       Info: Quad Core model: AMD Ryzen 5 1500X bits: 64 type: MT MCP arch: Zen rev: 1 cache: L2: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 56013 
           Speed: 3500 MHz min/max: N/A Core speeds (MHz): 1: 3500 2: 3500 3: 3500 4: 3500 5: 3500 6: 3500 7: 3500 8: 3093 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI driver: nvidia v: 465.31 bus-ID: 1f:00.0 
           Device-2: Oculus VR Rift CV1 Sensor type: USB driver: uvcvideo bus-ID: 4-1:2 
           Device-3: Oculus VR Rift CV1 Sensor type: USB driver: uvcvideo bus-ID: 4-3:4 
           Display: x11 server: X(.)Org 1.20.11 driver: loaded: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080

Welcome to the forum! :wave:

Tip: When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):


  • Use HTML:


Please edit your post accordingly.

Don’t forget to search the forum. :wink:

Hey there, thanks for the tip! I edited accordingly.

I did search a lot for this issue, but never had an exact solution. I would really appreciate if this issue gets fixed. I am also a beginner, so might need some more guidance ^^

Update. I did a lot of tinkering. I have no idea what additional stuff I did could have impacted this, but my last resort was to disable compositor on startup. This fixed it for me. My windows/browser is 144fps too.

This can be closed now.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.