KDE Wayland: Vertical Bar + Top bar: App Launcher Button blocked by top bar and almost unclickable, on X11 works OK

I am using KDE plasma desktop environment. Because I have first used GNOME DE and I like its desktop panel/dock layout, I have customized KDE to look and function as similar as possible.

That means, I have bottom Application “dock” set vertically on right side of the screen and another bar on top side of the screen. The App launcher button/icon is then in top right corner of the screen.

Recently I have started trying out wayland. After switching to wayland, this setup becomes wery clunky, because the App launcher icon becomes unlickable to the extent of top bar width, only small portion of the button remains active, even though it is visible. Furthermore, after clicking the app launcher menu is hidden behind top bar and doesnt move “on top of it.”

It might seem that wayland “desktop” has a little shifted coordinates, because if I click to very top corner right side, I get window from hidden task-icons widget, that is on top but on left side.

None of these issues occur on X11 session, on same settings.

inxi --admin --verbosity=7 --filter --no-host --width

System:
  Kernel: 5.10.34-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=c3941287-a07b-4844-bffb-b439646b54a7 ro quiet
  resume=UUID=a32e7c07-2745-437d-8730-6009ad9568a5 udev.log_priority=3
  Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_wayland vt: 2 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Nitro AN515-54 v: V1.31 serial: <filter>
  Mobo: CFL model: Octavia_CFS v: V1.31 serial: <filter> UEFI: Insyde v: 1.31
  date: 06/29/2020
Battery:
  ID-1: BAT1 charge: 56.6 Wh (100.0%) condition: 56.6/57.5 Wh (98.4%)
  volts: 17.6 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
  status: Full
Memory:
  RAM: total: 15.48 GiB used: 3.03 GiB (19.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: D (13)
  microcode: DE cache: L2: 8 MiB bogomips: 38400
  Speed: 4087 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4087 2: 4001
  3: 4012 4: 4096 5: 4088 6: 4081 7: 4047 8: 4099
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec
  xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
  vendor: Acer Incorporated ALI driver: nvidia v: 460.73.01
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f15
  class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:3
  chip-ID: 0408:a061 class-ID: 0e02
  Display: wayland server: X.Org 1.21.1.1 compositor: kwin_wayland driver:
  loaded: modesetting,nvidia display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
  s-diag: 583mm (23")
  Monitor-1: XWAYLAND0 res: 1920x1080 hz: 120 dpi: 143
  size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.0.3
  direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
  bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.34-1-MANJARO running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 14.2 running: yes
  Sound Server-4: PipeWire v: 0.3.26 running: yes
Network:
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet
  vendor: Acer Incorporated ALI driver: alx v: kernel port: 3000
  bus-ID: 07:00.0 chip-ID: 1969:e0b1 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 3000
  bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp8s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 1-14:4 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 953.87 GiB used: 259.11 GiB (27.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200 MTFDHBA1T0TCK
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: P1MA003 temp: 43.9 C
  scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 944.77 GiB size: 928.94 GiB (98.32%)
  used: 259.11 GiB (27.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: c3941287-a07b-4844-bffb-b439646b54a7
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
  uuid: B3C3-72F0
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
  uuid: a32e7c07-2745-437d-8730-6009ad9568a5
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Logitech M105 Optical Mouse type: Mouse
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
  power: 100mA chip-ID: 046d:c077 class-ID: 0301
  Device-2: 1-5:3 info: Quanta HD User Facing type: Video driver: uvcvideo
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0408:a061
  class-ID: 0e02
  Device-3: 1-14:4 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
  class-ID: e001
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 272 Uptime: 2m wakeups: 1 Init: systemd v: 247 tool: systemctl
  Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1745 lib: 488
  Shell: Bash v: 5.1.4 running-in: alacritty inxi: 3.3.04

Is there a way how I could resolve this other than remaking the whole layout to “avoid collisions” of all the desktop panels/objects?

Thank you very much in advance, if the description is too complicated I try can to make some pictures that will add to description of the issue.

EDIT: Added inxi output. Flameshot seems to be unable to make screenshots on waland (is that possible?)