KDE Wayland - Black screen with mouse after update

I just registered in the forum to post about this issue that happened to me twice. It happened the same way, after an update, upon reboot I end up with a black screen with a functional mouse after login. I still can spawn windows and open the launch dialog with ALT+SPACE but no desktop background, menu or icons whatsoever.

The first time I couldn’t “fix” it despite searching for solutions and had to do a fresh install.

This time happened again but this time I tried something different. I had two monitors attached, one through HDMI and the other through VGA, both on board graphics (this is a Ryzen desktop), so I unplugged the VGA monitor and rebooted. After reboot the desktop came back again and after pluging it back and fiddling with the settings I’m now back to a working environment as before the update. Kernel 5.9

I hope this helps any poor soul that suffers from this bug.

I’ve had this happening once but tried alt+space to bring up krunner, which worked.

plasmashell --replace

got me back to a working desktop.
Also a multi-monitor setup but X11 instead of wayland.

That kernel is EOL - you should switch to a supported kernel like 5.10 (LTS).


Thanks for the kernel suggestion. I think it was the default on the “maybe not so latest” iso or I burned the wrong iso. I’ll try that replace parameter next time.

Thanks again!

It solved it straight away. Thanks again

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.