KDE volume keys not working

Hi, im using KDE Plasma as desktop environment, and volume keys stopped working. I had this issue before and solved by adding volume widget to desktop, now happens again, I tried adding more but doesnt seem to work. When opening volume annel it says “No output or input devices found”.

However the microfones do sound, just cant change volume or mute with volume keys.

After reading some other questions, which’s solutions didnt solve my problem, here are the outputs usually asked to post, in advance:

Kernel version -> 5.10.59-1-MANJARO
stem@manjaro ~> cat /etc/lsb-release
stem@manjaro ~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC285 Analog [ALC285 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
stem@manjaro ~> systemctl --user --no-pager -l status pulseaudio.{socket,service}
○ pulseaudio.socket - Sound System-no-pager -l status pulseaudio.{socket,service}
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor preset: enabled)
     Active: inactive (dead)
   Triggers: ● pulseaudio.service
     Listen: /run/user/1000/pulse/native (Stream)

ago 19 16:15:06 manjaro-localhost systemd[1113]: pulseaudio.socket: Socket service pulseaudio.service not loaded, refusing.
ago 19 16:15:06 manjaro-localhost systemd[1113]: Failed to listen on Sound System.

○ pulseaudio.service
     Loaded: masked (Reason: Unit pulseaudio.service is masked.)
     Active: inactive (dead)
TriggeredBy: ○ pulseaudio.socket
stem@manjaro ~> inxi -Fxxz 
System:    Kernel: 5.10.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 
           tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20KGS1SS14 v: ThinkPad X1 Carbon 6th serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: LENOVO model: 20KGS1SS14 v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N23ET50W (1.25 ) 
           date: 06/25/2018 
Battery:   ID-1: BAT0 charge: 56.0 Wh (100.0%) condition: 56.0/57.0 Wh (98.3%) volts: 13.0 min: 11.5 
           model: SMP 01AV431 serial: <filter> status: Full 
CPU:       Info: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A 
           cache: L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33615 
           Speed: 700 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 5: 700 6: 700 
           7: 700 8: 700 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:5917 
           Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:3 chip-ID: 5986:2115 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 
           Sound Server-1: ALSA v: k5.10.59-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel port: efa0 bus-ID: 00:1f.6 
           chip-ID: 8086:15d7 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: efa0 bus-ID: 02:00.0 
           chip-ID: 8086:24fd 
           IF: wlp2s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:2 
           chip-ID: 8087:0a2b 
           Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
Drives:    Local Storage: total: 238.47 GiB used: 80.17 GiB (33.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-000L7 size: 238.47 GiB speed: 31.6 Gb/s 
           lanes: 4 serial: <filter> temp: 45.9 C 
Partition: ID-1: / size: 233.38 GiB used: 80.17 GiB (34.4%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 53.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 240 Uptime: 27m Memory: 15.38 GiB used: 2.55 GiB (16.6%) Init: systemd v: 248 Compilers: 
           gcc: 11.1.0 clang: 12.0.1 Packages: 1401 pacman: 1394 snap: 7 Shell: Bash v: 5.1.8 running-in: konsole 
           inxi: 3.3.06 

Im relatively new to manjaro, and dont know what could be, thanks in advance

Whenever I had this issue, rebooting helped. Have you tried it?

Yes, I did reboot but the problem is still there

Try restarting alsa or pulseaudio. If that doesn’t work, I’m out of my depth, sorry. Wait for the smart guys! Good Luck!

Thank you so much, restarting pulseaudio worked perfectly

In that case, mark the issue solved, thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.