KDE System Tray Notification Popup Location in the Middle of the Screen - How to I Move it Back?

My Notification Popups on my KDE Plasma desktop have started appearing in the bottom center of my desktop - They used to be located just under the system tray which, on my desktop, is on the top right of my primary monitor.

Can anyone advise where I go to set this back? It’s rather annoying when you’re in the middle of coding and every 5 minutes a popup appears in the middle of the screen. If any other info would help here, please let me know.

System Settings → Personalization → Notifications

Thanks @Aragorn - exactly what I was looking for. Annoyingly, however, that’s how mine is set at the moment. I’ve tried changing it to “Choose Custom Position” and set the top right corner. When I do this it appears in the top right corner of my second monitor (which is to the right). I tried setting the position to the top left corner and it appears in the top left of my second monitor.

This started going weird when I changed the scaling setting from 150% to 125% and then back again over the course of today (rebooting between each change) - I wonder if that’s confused something somehow or it’s confused with my monitor set up in some way.

Well, I cannot help you with a multi-monitor setup, nor with scaling — I have only one monitor and I use the native resolution.

Perhaps logging out and back in will make a difference, and while you’re at it, between logging out and logging back in, try deleting the cache from a tty login… :arrow_down:

rm -rf ~/.cache/*

I’m giving @Aragorn the solution here as it most accurately reflects an answer to the question that I posed, so will probably be most useful to any returning users.

It did not, however, fix my problem. I think I’ve stumbled on a bug. I managed to fix it by setting the Notifications settings back as they were (as per @Aragorn 's handy screenshot) after my experimentation, then I did the following…

  1. Go to Settings > Display and Monitor
  2. Switched my “Primary” monitor to my secondary one
  3. Clicked “Apply”
  4. Switched the “Primary” setting back again
  5. Clicked "“Apply” again
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.