Kde system settings crash when clicking on kernel

When I open system settings and click on Kernel system settings crashes and when I say crashes it disappears from the screen.


Please open it from a terminal with the command:


…and provide any output it provides when you do that and this happens.

Hope you manage!

[demo@manjaro ~]$ systemsettings

(process:3705): GLib-GObject-WARNING **: 10:28:09.248: cannot register existing type 'PamacSnapPlugin'

(process:3705): GLib-GObject-CRITICAL **: 10:28:09.248: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:3705): GLib-CRITICAL **: 10:28:09.248: g_once_init_leave: assertion 'result != 0' failed

(process:3705): GLib-GObject-CRITICAL **: 10:28:09.248: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(process:3705): GLib-GObject-WARNING **: 10:28:09.255: cannot register existing type 'PamacFlatpakPlugin'

(process:3705): GLib-GObject-CRITICAL **: 10:28:09.255: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:3705): GLib-CRITICAL **: 10:28:09.255: g_once_init_leave: assertion 'result != 0' failed

(process:3705): GLib-GObject-CRITICAL **: 10:28:09.255: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed
Segmentation fault (core dumped)

Thank you! Now let’s hope the smart people sees it, because I see it and I’m completely lost…

Here is my system info if that helps:

[demo@manjaro ~]$ inxi --admin --verbosity=7 --filter --width
  Kernel: 6.0.6-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.0-x86_64
    root=UUID=45ca132d-4a37-4dc3-afa0-be2e80d6a4a2 rw quiet pci=nocrs
    acpi=force "acpi_osi=Windows 2022" ibt=off
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.7 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP Spectre x360 Convertible 15-df1xxx
    v: N/A serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 863F v: 54.24 serial: <superuser required> UEFI: AMI
    v: F.28 date: 07/14/2022
  ID-1: BAT0 charge: 69.4 Wh (100.0%) condition: 69.4/69.4 Wh (100.0%)
    volts: 13.0 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: full cycles: 178
  Device-1: hid-0018:04F3:2992.0003-battery model: ELAN2514:00 04F3:2992
    serial: N/A charge: N/A status: N/A
  RAM: total: 15.26 GiB used: 4.83 GiB (31.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-10510U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 level: v3 note: check
    built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2892 high: 3100 min/max: 400/4900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3009 2: 3037 3: 3093
    4: 2514 5: 3000 6: 3100 7: 3086 8: 2300 bogomips: 36812
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand
    rdseed rdtscp rep_good sdbg sep sgx smap smep ss ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:9b41
    class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Hewlett-Packard
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 4 bus-ID: 3b:00.0
    chip-ID: 10de:1d13 class-ID: 0302
  Device-3: Chicony HP Wide Vision FHD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:3 chip-ID: 04f2:b67b class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88")
  Monitor-1: eDP-1 mapped: eDP-1-1 model: AU Optronics 0x30eb built: 2017
    res: 3840x2160 hz: 60 dpi: 284 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: 3840x2160
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce
    MX250/PCIe/SSE2 direct render: Yes
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:02c8 class-ID: 0401
  Sound API: ALSA v: k6.0.6-2-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 261.75 GiB (28.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 40.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 239 GiB size: 234.94 GiB (98.30%) used: 47.66 GiB (20.3%)
    fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8 label: N/A
    uuid: 45ca132d-4a37-4dc3-afa0-be2e80d6a4a2
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 68.8 MiB (71.6%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: 6865-B8CE
  ID-3: /home raw-size: 415.57 GiB size: 407.98 GiB (98.17%)
    used: 214.02 GiB (52.5%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
    label: home uuid: 1f7a0eb8-f3e9-46ef-a88a-e3ae0ed0233d
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs label: Recovery
    uuid: 28C6655CC6652AF0
  ID-2: /dev/nvme0n1p11 maj-min: 259:9 size: 16 GiB fs: swap label: N/A
    uuid: 1b9cd8e2-756a-4a24-9641-d3cdd3bed29a
  ID-3: /dev/nvme0n1p12 maj-min: 259:10 size: 3 MiB fs: ufs label: N/A
    uuid: 6354a81a1b0b8929
  ID-4: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-5: /dev/nvme0n1p4 maj-min: 259:4 size: 219.37 GiB fs: ntfs label: N/A
    uuid: EAEA681CEA67E375
  ID-6: /dev/nvme0n1p5 maj-min: 259:5 size: 961 MiB fs: ntfs label: N/A
    uuid: 863E127D3E126709
  ID-7: /dev/nvme0n1p6 maj-min: 259:6 size: 40 GiB fs: ext4 label: rootMX21
    uuid: ae691757-a5f4-43d3-9580-0da970b5827f
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Elan Micro Wireless Keyboard type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 04f3:01a4 class-ID: 0301
  Device-2: 1-5:3 info: Chicony HP Wide Vision FHD Camera type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b67b class-ID: 0e02 serial: <filter>
  Device-3: 1-9:4 info: Synaptics type: <vendor specific> driver: N/A
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00bb
    class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 48.0 C pch: 45.0 C mobo: N/A gpu: nvidia temp: 55 C
  Fan Speeds (RPM): N/A
  Processes: 250 Uptime: 48m wakeups: 772 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: 1714 pm: pacman pkgs: 1708 libs: 490 tools: pamac,pikaur,yay
  pm: flatpak pkgs: 6 pm: snap pkgs: 0 Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.23

you again… your system is messed up…

and what is this parameter?:

it should be like this:
acpi_osi='Windows 2022'

In trying to get bluetooth working on this laptop I was instructed on this site to use that statement.
I updated from what I was told to match the current version of Windows that is on this system.
Okay I might have read it wrong.
Let me fix it.

This is what it shows without me changing anything

GRUB_CMDLINE_LINUX_DEFAULT="quiet pci=nocrs acpi=force acpi_osi='Windows 2022' ibt=off"

this looks ok, you can save it, and update grub:
sudo update-grub

did that
Still same issue

[demo@manjaro ~]$ systemsettings

(process:1896): GLib-GObject-WARNING **: 14:37:40.924: cannot register existing type 'PamacSnapPlugin'

(process:1896): GLib-GObject-CRITICAL **: 14:37:40.924: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:1896): GLib-CRITICAL **: 14:37:40.924: g_once_init_leave: assertion 'result != 0' failed

(process:1896): GLib-GObject-CRITICAL **: 14:37:40.924: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(process:1896): GLib-GObject-WARNING **: 14:37:40.931: cannot register existing type 'PamacFlatpakPlugin'

(process:1896): GLib-GObject-CRITICAL **: 14:37:40.931: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:1896): GLib-CRITICAL **: 14:37:40.931: g_once_init_leave: assertion 'result != 0' failed

(process:1896): GLib-GObject-CRITICAL **: 14:37:40.931: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed
Segmentation fault (core dumped)

that parameter is not likely related to this issue, i just noticed it…
just to check, post output from:
grep CMDLINE /etc/default/grub

and with the system settings, i told you in the another thread with the python issues that your system is messed up…

do you have installed these plugins?

[demo@manjaro ~]$ grep CMDLINE /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet pci=nocrs acpi=force acpi_osi='Windows 2022' ibt=off"

I browsed with pacman gui but it didn’t show those packages
How do I check for plugins?
And I’m sure my system was messed up but I thought with the steps we took before we fixed things.
I know I didn’t reinstall everything but I haven’t ran every application and every option in every application.
Please don’t give up on me.
I am trying to do the right thing.

check with:
pacman -Qs 'libpamac-flatpak-plugin|libpamac-snap-plugin'

no, we didnt fixed it, as you can see… but i dont think that now even the reinstall would help haha

[demo@manjaro ~]$ pamac -Qs 'libpamac-flatpak-plugin|libpamac-snap-plugin'
Available actions:
  pamac --version     
  pamac --help, -h     [action]
  pamac search         [options] <package(s)>
  pamac list           [options] <package(s)>
  pamac info           [options] <package(s)>
  pamac install        [options] <package(s)>
  pamac reinstall      [options] <package(s)>
  pamac remove         [options] [package(s)]
  pamac checkupdates   [options]
  pamac update,upgrade [options]
  pamac clone          [options] <package(s)>
  pamac build          [options] [package(s)]
  pamac clean          [options]

sorry, wrong command:
pacman -Qs 'libpamac-flatpak-plugin|libpamac-snap-plugin'

and the crash happens only when you click on the kernel option?

[demo@manjaro ~]$ pacman -Qs 'libpamac-flatpak-plugin|libpamac-snap-plugin'
local/libpamac-flatpak-plugin 11.4.1-1
    Flatpak plugin for Pamac
local/libpamac-snap-plugin 11.4.1-1
    Snap plugin for Pamac

I haven’t clicked every option but that one for sure.

so check the options… but it looks like the system settings are not the issue, but pamac is…
reinstall them and see if there are any errors:

sudo pacman -S libpamac-flatpak-plugin libpamac-snap-plugin

With those plugins installed it causes the issue.
I removed both of those and it is working correctly.
To my knowledge I don’t use flatpaks or snaps.
I might have played around with some snaps in the past but nothing as of now that I know of.

So you got me curious and I clicked on Hardware configuration and it just displayed a black screen
Never mind clicked on it a second time and it worked.

is the screenshot accurate, because it looks messed up… this is how it should look: