KDE switching to virtual workspace two after startup

Hello everybody, i managed (thanks to this forum) to set easyeffects to startup on my second virtual workspace after startup. Now manjaro is switching to the second workspace after startup wich is the problem for me. I would like that after startup easyeffects is starting on my second virtual wokrspace but focus should remain on workspace one. Couldnt find any solution
Operating System: Manjaro Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 5.15.85-1-MANJARO (64-bit)
Graphics Platform: X11
System Version: ThinkPad T410s

Put the below script into a file, and set it as a startup script in the same menu you set startup programs. Also, remove easyeffects from your startup programs as it will be started by the script instead.

kstart easyeffects
qdbus org.kde.kglobalaccel /component/kwin org.kde.kglobalaccel.Component.invokeShortcut "Switch to Desktop 1"

Thanks you, but its not working. Easyeffects is starting in but not switching back to Workspace 1

After doing some testing on my own, looks like easyeffects launches too slow so we need to insert a delay. Try this one instead.

kstart easyeffects
sleep 0.5
qdbus org.kde.kglobalaccel /component/kwin org.kde.kglobalaccel.Component.invokeShortcut "Switch to Desktop 1"

Tweak as needed, the number after sleep is in seconds.

Very nice,thank you so much!

Wouldn’t it be easier to use the window or program setting (from the window menu in the top left corner) to force easyeffects open on the second desktop?

OP has already done that. The problem is that when a window is opened, plasma switches to the desktop that program is on (in this case desktop 2). However, OP wants to start with desktop 1 opened on their screen (with the program hidden in desktop 2) instead.

Exactly, this is all due to easyeffects has no minimize to systray option. I had the same issue with thundbird and solved it with birdytray, a semi good solutoin for me, but it works.

Ok, sorry didn’t get that :man_shrugging:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.