KDE: Strange effect when downloading attachments in Thunderbird

Good day everyone.

Since several updates ago; Thunderbird shows a strange effect when I try to download or open an attachment.
The boxes indicating the operation with that file appear with a white color in both background and text.
Only by clicking on “Open with” or until I press some button the text is displayed…
But, let’s see, what is the “Cancel” or “OK” button?

The problem occurs on a computer with a KDE + nVidia card.

I have another system with KDE but using the Intel integrated graphics card and the phenomenon does not occur.

In this nVidia system I am using a custom theme and colors:

Global: "Breath2 2021 Dark"
Application style: Oxygen
Plasma style: Sweet-mars
Colors: Sweet
Windows decoration: Sweet-dark-transparent
Icons: BeautyLine
Cursors: Sweet-cursors

Then I have tried changing to (but the effect is the same)

Global: "Breath2 2021 Dark" -> "Breeze Dark"
Application style: "Oxygen" ->  "Breeze"
Plasma style: "Sweet-mars" -> "IOTA-Plasma" -> "Breeze"
Colors: Sweet -> "Breath2 2021B Dark" -> "Breeze Dark"
Windows decoration: "Sweet-dark-transparent" -> "Oxygen" -> "Breeze"
Icons: "BeautyLine" -> "Breeze Dark"
Cursors: "Sweet-cursors" -> "Breeze"

I have tried other global themes with no luck.

I hope someone has some advice that can help me to solve this situation.

In Firefox I don’t have this problem (which I would assume should happen even though they are different Mozilla products).

Regards and thank you in advance.

System:    Host: UKnow Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.5 Distro: Manjaro Linux
Machine:   Type: Desktop System: Gigabyte product: G1.Sniper B6 v: N/A serial: <superuser required>
           Mobo: Gigabyte model: G1.Sniper B6-CF v: x.x serial: <superuser required> BIOS: American Megatrends v: F3
           date: 08/20/2015
CPU:       Info: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP cache: L2: 8 MiB
           Speed: 4371 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 4371 2: 4390 3: 4330 4: 4343 5: 4390 6: 4389 7: 4357
           8: 4387
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 470.63.01
           Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia resolution: 1920x1080~60Hz
           OpenGL: renderer: NVIDIA GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel
           Device-2: NVIDIA GM206 High Definition Audio driver: snd_hda_intel
           Sound Server- ...
Network:   Device-1: ...
           Device-2: ...
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 61 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 334 Uptime: 7h 35m Memory: 31.32 GiB used: 6.09 GiB (19.4%) Shell: Bash inxi: 3.3.08

Thunderbird is a GTK-based application and does not follow the theme settings of Plasma, which is Qt-based. I would suggest using a different GTK theme in System Settings. :arrow_down:

Appearance → Application Style → Configure GNOME/GTK Application Style

1 Like

Actually, the breeze-gtk theme follows the color scheme of Plasma.

Yes, but neither Thunderbird nor Firefox use the Breeze theme. They do their own thing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.