KDE Settings crash while installing themes

Anyone else having crashing issues with KDE Settings while installing themes and while making changes within settings?

You have to be careful when downloading new themes, and especially global themes.

Plasma theming is a matter of applying different themes to different aspects of the user interface, i.e.

  • The Plasma theme. This is the look & feel of your panels and widgets.

  • The application theme. This is the look & feel of anything shown inside of a (Qt-based) application window, but there are two caveats…:
    – GTK applications must be configured separately; and
    kvantum themes use scalable vector graphics and must be configured via kvantum-manager.

  • The window decoration. This is the window border and title bar.

  • The cursor theme.

  • The color scheme. This will not work on kvantum-based themes, nor on GTK themes.

  • The fonts.

  • The wallpaper and wallpaper configuration ─ i.e. static, slide show, dynamic, et al.

If you install a global theme, then this must take care of all of the above. That’s a lot of ground for the theme developer to cover, and the theme must also be applied via a single click. Therefore, it is not uncommon for some of those global themes to mess things up and cause System Settings to crash, or worse, ruin your entire desktop. Furthermore, some themes were written for the earlier versions of Plasma 5 and may no longer be compatible with any release of Plasma from the last five years or so.

My advice is always to stay away from the global themes and just theme one aspect at the time.


I understand everything you said and I pay attention to what I’m installing. Im not a newbie to Manjaro or to linux itself but everything you said still doesn’t answer my question as to why KDE Settings is crashing (for me) all of a sudden. I’m asking if any other KDE user is having crashing issue also. Thank You for your quick (un-solved) comment

I thought the answer to your question was worded in between the lines of my reply. It is crashing because you’ve installed a broken and/or incompatible theme.

And yes, other people have fallen into that trap as well, and for the same reasons.

I understand that but maybe I should of said what theme im using when the crashing happens. Im using the default Breeze Theme. So, is the default theme incompatible? Im sure it is not. The crashing happens not only when Im installing a theme but every where within the settings app.

For what its worth …
I generally dont use these embeedded search/install things in plasma.
But trying to do so right now seems to consistently produce this:

An Error Occured
The installation of /tmp/VufZOZ-Materia-Manjaro.tar.gz failed, as the downloaded package does not contain any 
useful meta information, which means it is not a valid KPackage.

Just a follow up to this post about 2 weeks ago with no luck at all. I found this while sending in another bug report, lots of packages are missing? I did a fresh install of Arch KDE, Manjaro KDE, Kubuntu, and KDE Neon with all of these have the same result of system settings crashing while floating around in system seetings. I really dont want to change my desktop just because there’s a bug in KDE at the moment. Yes, that’s how frustrating this is.
Any help will be greatly appreciated.
The packages containing debug information for the following application and libraries are missing:

  • /usr/bin/systemsettings5
  • /usr/lib/libQt5Qml.so.5
  • /usr/lib/libQt5Core.so.5
  • /usr/lib/qt/plugins/systemsettings_sidebar_mode.so
  • /usr/lib/libKF5Declarative.so.5
  • /usr/lib/libKF5WidgetsAddons.so.5
  • /usr/lib/libsystemsettingsview.so.3
  • /usr/lib/libKF5QuickAddons.so.5
  • /usr/lib/qt/plugins/kcms/kcm_screenlocker.so
  • /usr/lib/libKF5KCMUtils.so.5
  • /usr/lib/libQt5Widgets.so.5

I dont know how you are missing things like this - ^ this is from qt5-base for example.

1 Like

I completly agree. I have no clue how these are missing. I even did a fresh install and still have the same results?

But they arent on other installs.
(qt5-base is required by things like kscreenlocker)
What ISO did you use?

The newest Manjaro KDE ISO, the latest Arch IOS and which ever Kubuntu has on thier website. I think Kubuntu didnt even have 5.20 running when I downloaded that ISO. KDE Neon was also the latest ISO. All have same results with system settings crashing.