KDE Scrolling Speed

How can I increase mouse scrolling speed in KDE plasma?
I noticed this problem only recently. I’m pretty sure it was OK the last week, but I changed mouse recently as well, so I’m not sure was it triggered by mouse or update.
I don’t have Advanced option in the settings like mentioned here - Mouse wheel speed • KDE Community Forums
I found this post - Scrolling speed, but it is not clear how it was fixed. The biggest issue for me is Firefox, but I would like to increase scrolling speed in all the applications. I don’t see related settings in Firefox, only Smooth Scrolling, that doesn’t affect speed.

did you check system-settings → hardware → inputdevices ? there is a setting for the speed and the speed-profil (adaptive or flat). adaptiv is what might be the better solution.

Probably by switching to a different mouse.

That’s peculiar, because that section should be present in the Plasma System Settings.

That said however, the section referenced there doesn’t have anything to do with scrolling speed. It is for setting the acceleration of the mouse pointer when you move the mouse.

There used to be a scrolling speed adjustment option in Plasma — concretely, an adjustment of the amount of lines that a single notch of the mouse wheel would scroll — until a few years ago, but it was dropped as part of an upgrade to Plasma and/or X.Org.

It might still be possible to set the amount of lines via X.Org itself, but I’m not sure — you’ll have to consult the X.Org documentation for that, but upon a cursory glance through their documentation, I can’t seem to find anything relevant. :man_shrugging:

As for Firefox, you’ll have to dig into the about:config and find the following key… :arrow_down:


It’ll have a number set to it, visible in the middle of the box. Change that number to the amount of lines it must scroll per notch of the wheel.

No, that’s for setting the acceleration of the mouse pointer when moving the mouse.

The issue may appears only after sleep.
I just turned on my PC and mouse is working fine.
Let me try to duplicate the problem.

Thanks, @Aragorn
This is how My Mouse Settings Look like.
Is this what I should have or I can unlock more settings?

This is what I was looking for from this post Mouse wheel speed • KDE Community Forums.
There is a “mouse wheel scrolls by” input.

That’s how it should be in any recent enough Plasma installation.

That’s how it used to be, but that’s already several years old now.

Thanks @Olli
I did try this option, but it didn’t help.

Got it. Thanks. I’ll report back if I can replicate the issue.

I can’t reproduce this issue. Even after sleep and hibernation mouse scrolling is fine.
My mouse is attached to a KVM switch, so I will blame KVM.
The problem probably went away after KVM reboot.

You had not mentioned this (important) detail. Always remember that the quality of the advice you’ll get is only going to be on par with the quality of the information you provide.

1 Like

Yes, I agree it is important, I just forgot about this as it was working seamless.
I didn’t think about KVM until we ruled out other options.

A keyboard-video-mouse switch should have been the first thing mentioned in the original post.

KVMs are also notorious for blocking “multimedia keys” and other custom buttons on different Logitech and Microsoft keyboards.

They’re not simple passive devices, as one would view a USB hub or extension cable.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.