KDE Powerline glyphs missing in VSCode integrated terminal only

I recently switched from bash to zsh and was pleasantly surprised that Manjaro KDE already contains some configs for this shell, including Powerline. However, while it works perfectly in regular Konsole (xterm) with no missing glyphs, for some strange reason VSCode (OSS) refuses to display these same glyphs and shows ‘glyph missing’ rectangles instead, in spite of the fact that both regular terminal and VSCode integrated one have the same setup. I tried messing with fonts, but to no avail: regardless of which font I use (I tried all of the patched ones) the glyphs are still not there and I have no idea where there problem might be.

It might be worth noting that Powerline glyphs do work in bash (not zsh) in VSCode integrated terminal. Which confuses me even more.

PS. Wanted to include a screenshot (or a link to it), but it was forbidden, so you’ve gotta imagine :slight_smile:

2 Likes

I had the same problem in gnome edition

Solved it by installing ttf-meslo-nerd-font-powerlevel10k and change "terminal.integrated.fontFamily" in vscode settings to MesloLGS NF

4 Likes

Had the same issue on gnome edition, Manjaro 21.2pre.
Inside VS Code settings.json, just add
"terminal.integrated.fontFamily": "NotoSansMono Nerd Font"
“NotoSansMono Nerd Font” is the default font of my terminal

7 Likes