KDE Plasma won't start AND my computer won't connect to my network

Today I wanted to replace my 2 Nvidia GPUs (970s) with a new AMD GPU (RX 6950 XT). I had to move my wifi card (Archer T6E) to a different slot on the motherboard due to the much larger GPU. Now neither KDE Plasma nor my internet work.

I looked at the Network Configuration article on the archwiki since I’ve been trying to prioritize Internet. I can’t ping public websites or my default gateway. “ip route show” and the IPv6 version didn’t provide any output. The network interface when set to UP say NO-CARRIER.

I do have other devices on the WiFi network so I’m sure it’s not that.

Let me know what you need, and I guess the best way to get terminal output to you considering.

Thanks in advance.

inxi -Fazy

Might be a good start.

1 Like

Here you go

  Kernel: 6.1.62-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=a9e31dae-9c1d-43e5-8b4c-5cd1ca90b685 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Console: tty 2 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MEG X570 ACE (MS-7C35) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.30
    date: 07/19/2019
  Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 3783 high: 3800 min/max: N/A cores: 1: 3600 2: 3800
    3: 3800 4: 3800 5: 3800 6: 3800 7: 3800 8: 3800 9: 3800 10: 3800 11: 3800
    12: 3800 bogomips: 91245
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 21 [Radeon RX 6950 XT] vendor: Gigabyte driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-2
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 2f:00.0 chip-ID: 1002:73a5 class-ID: 0300
  Display: server: X.org v: driver: X: loaded: nvidia gpu: amdgpu
    tty: 240x67
  Monitor-1: HDMI-A-2 model: Dell SE2719H serial: <filter> built: 2020
    res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.54x13.23")
    diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: radeonsi surfaceless: drv: radeonsi
    inactive: wayland,x11
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 23.1.9-manjaro1.1
    note: console (EGL sourced) renderer: AMD Radeon RX 6950 XT (navi21 LLVM
    16.0.6 DRM 3.49 6.1.62-1-MANJARO), llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan Message: No Vulkan data available.
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 2f:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: JMTek LLC. USB PnP Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 5-2:2 chip-ID: 0c76:161e class-ID: 0300
  API: ALSA v: k6.1.62-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.84 status: off with: pipewire-media-session
    status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter
    driver: bcma-pci-bridge v: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 25:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  Device-2: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 26:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp38s0 state: down mac: <filter>
  Device-3: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp39s0 state: down mac: <filter>
  Device-4: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 28:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:5 chip-ID: 8087:0029
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 3.18 TiB used: 365.25 GiB (11.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD30PURX-64P6ZY0 size: 2.73 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-1: / raw-size: 465.47 GiB size: 457.09 GiB (98.20%)
    used: 365.25 GiB (79.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 44.5 C mobo: N/A gpu: amdgpu temp: 37.0 C
    mem: 32.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
  Processes: 261 Uptime: 6h 42m wakeups: 0 Memory: total: 80 GiB note: est.
  available: 78.5 GiB used: 1.53 GiB (2.0%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1707 pm: pacman pkgs: 1693 libs: 448 tools: pamac pm: flatpak
  pkgs: 12 pm: snap pkgs: 2 Shell: Bash (login) v: 5.2.15 running-in: tty 2
  inxi: 3.3.31

what do you mean it wont start? so how did you get the inxi output?
did you remove the nvidia drivers + its configs?

1 Like

There are no plasma processes running, when I boot it’s a black screen with a familiar “RDRAND is not reliable on this platform…” message; one I’ve been given reason to believe is harmless based on looking to the message online. Normally it goes to the login screen after a second. I can get to TTY fine. Kstart fails and I can get you that output it if you’d like. Just let me know if there are any additional arguments that would be helpful.

To get the output I what I ended up doing was “inxi -Fazy > inxi.txt” then mount a USB and move it over before I could actually post it.

I did remove linux510-nvidia thinking it could be the reason why Plasma wasn’t happy. I only realized after this that I didn’t have an Internet connection to the computer.

I didn’t think about configs. Where would they be located? I’ll try googling, but can’t hurt to ask here to make sure I’m not missing something.


Display: server: X.org v: driver: X: loaded: nvidia gpu: amdgpu

Remove the Nvidia driver - Configure Graphics Cards - Manjaro

Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter
driver: bcma-pci-bridge v: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 25:00.0 chip-ID: 14e4:43a0 class-ID: 0280

I’m pretty sure that should using broadcom-wl driver and if it was working before then I don’t know why it isn’t now. You could try blacklisting bcma.

sudo sh -c "echo 'blacklist bcma' > /etc/modprobe.d/blacklist-bcma.conf"
1 Like

follow mrlavender link on how to remove the drivers, you can do it from tty…
and check configs:
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"
check for some nvidia.conf and xorg.conf…
if not sure you can take a picture of the output and post it here …

the wifi in question is the intel ax200 one? or the broadcom one?

1 Like

Doing so will change the name and thus your NetworkManager will likely point to the wrong card.

Use the following command in a terminal to verify the new name for your wi-fi

ip link

The name may be something like wlp <busNumberSlotNumberDeviceNumber> - see example

 $ ip link
[ ... ]
4: wlp4s0f1u3: ....
[ ... ]

Because mhwd - when installing Nvidia driver - installs a configuration in /etc/X11/xorg.conf.d and blacklisting configs in /etc/modproble.d - you need to remove the nvidia drivers and the configs using a console (TTY). To access a tty

  • boot to grub - ensure grub is shown by holding shift while booting.
  • press e on the highlighed entry
  • use the arrow key to move down to the kernel command line
  • press end to get to end of the line
  • insert a space and the number 3
  • press f10 to boot
  • Enter your username at the prompt and password to login

Remove nvidia driver - which one depends on your system

To list installed driver

mhwd -li

Remove the nvidia driver - use the name from above output - e.g. the most recent driver is will be video-nvidia

sudo mhwd -r video-nvidia

Do a full system update

sudo pacman -Syu

Install the default driver package

Use either auto

sudo mhwd -a pci free 0300

Or manual

sudo mhwd -i pci video-linux



I’ve blacklisted it as Mr Lavender said.

Brahma: the Broadcom is the one that is the one I’m looking to use.

linux-aarhus: So it looks like it’s called wlp40s0 when I run ip link.

Also, after following the steps, I believe I’ve now removed all nvidia drivers/configs. When I run mhdw -li now, it says “No installed PCI configs! No installed USB configs!”

Inxi also no longer shows “nvidia gpu” as it did before.

there should be installed video linux, post output/picture from:
mhwd -l -li
there should also be the driver for the broadcom wifi…

They didn’t show up with “mhdw -li”, but they do with “mhdw -l -li”.

I see:

if they dont show up with mhwd -li, it means you have no drivers installed, so install them:
sudo mhwd -i pci video-linux
sudo mhwd -i pci network-broadcom-wl

So since I don’t have internet on this device, would I have to grab them on another device and bring them over on USB or something? Is there a guide for that if so?

use usb tethering from your phone, that should work…

1 Like

You need to turn it on …

ip link set wlo1 up
1 Like


This is one step I did try beforehand. But ultimately it doesn’t stay up on reboot, doesn’t provide internet access, and says NO-CARRIER even when up, which I believe means there’s a deeper problem.

brahma: I’ll try to look into setting that up.

So you successfully change state to up and still have connection problems?

I also just realized your earlier post states you are trying to get a different card working?

…whatever the case getting a working network connection from one of your devices will help to solve the general symptoms.

1 Like

I’m absolutely open to using either in the short term, I was just answering someone’s question.

Willing to try whatever works.

connect your phone via cable to your pc, make sure your phone is connected to internet, and enable usb tethering in your phone…

1 Like

It’s connected, I changed the phone setting to enable tethering, and I see it on “ip link” now. It didn’t say “UP” by default, but I set it so it does now.

I’m still not able to ping anything though.