Kde plasma won't open after enabling intel tearfree on manjaro

Hello first of all I exited inxi -b :

  Host: GNB-1588-B1-i5 Kernel: 6.9.3-3-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
  Type: Laptop System: ARCELIK A.S. product: GNB-1588-B1-i5 v: 03
    serial: <superuser required>
  Mobo: Quanta model: TWD v: TBD serial: <superuser required> UEFI: Insyde
    v: GR162 date: 05/27/2014
  Info: dual core Intel Core i5-3210M [MT MCP] speed (MHz): avg: 1575
    min/max: 1200/3100
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: NVIDIA GK208M [GeForce GT 740M] driver: nouveau v: kernel
  Device-3: Chicony USB HD Webcam driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting dri: crocus,nouveau gpu: i915 s-res: 1366x768
    resolution: 1366x768
  API: OpenGL v: 4.5 compat-v: 4.2 vendor: intel mesa v: 24.0.9-manjaro1.1
    renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
  Device-1: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae
  Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx
  Device-3: TP-Link Archer T3U [Realtek RTL8812BU] driver: rtw_8822bu
    type: USB
  Local Storage: total: 839.88 GiB used: 142.2 GiB (16.9%)
  Memory: total: 12 GiB available: 11.56 GiB used: 2.95 GiB (25.5%)
  Processes: 214 Uptime: 8m Shell: Zsh inxi: 3.3.34

I’m using an old machine with dual video cards. I like to use the intel video card and hibernate the nvidia video card, but when using the intel video card sometimes random small dots appear and disappear on the screen. I had this problem in ubuntu and enabling ubuntu intel tearfreeze solved my problem. When I enable intel tearfreeze in Manjaro, the login screen does not appear.

I enabled intel tearfreeze like this:

  • I created the 20-intel.conf file with sudo nano /etc/X11/xorg.conf.d/20-intel.conf and wrote the following in it :
  Section "Device"
      Identifier "Intel Graphics"
      Driver "intel"
      Option "TearFree" "true"

But when I saved the file and restarted, the login screen did not open.

I also tried typing this later and the result was the same :

  Section "Device"
      Identifier "Intel Graphics"
      Driver "intel"
      Option "AccelMethod" "sna"
      Option "TearFree" "true"
      Option "DRI" "3"

How can I activate intel tearfree in manjaro?
I don’t want to use my Nvidia video card by default because it tires the system too much. Instead, I prefer DRI_PRIME=1 or prime-run to open the program I want with nvidia.

The logging file is /var/log/Xorg.0.log. There, you can check what went wrong.

The /var/log/Xorg.0.log file at the time I got the error said the following:

[    17.024] (--) Log file renamed from "/var/log/Xorg.pid-561.log" to "/var/log/Xorg.0.log"
[    17.024] 
X.Org X Server
X Protocol Version 11, Revision 0
[    17.024] Current Operating System: Linux GNB-1588-B1-i5 6.9.3-3-MANJARO #1 SMP PREEMPT_DYNAMIC Mon Jun 10 09:50:04 UTC 2024 x86_64
[    17.024] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64 root=UUID=993b7bc3-1523-490b-8215-c0ea751364c7 rw quiet splash udev.log_priority=3
[    17.024]  
[    17.024] Current version of pixman: 0.43.4
[    17.024] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    17.024] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    17.024] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 11 12:53:09 2024
[    17.024] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    17.024] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    17.024] (==) No Layout section.  Using the first Screen section.
[    17.024] (==) No screen section available. Using defaults.
[    17.024] (**) |-->Screen "Default Screen Section" (0)
[    17.024] (**) |   |-->Monitor "<default monitor>"
[    17.024] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    17.024] (**) |   |-->Device "Intel Graphics"
[    17.024] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    17.024] (**) Allowing byte-swapped clients
[    17.024] (==) Automatically adding devices
[    17.024] (==) Automatically enabling devices
[    17.024] (==) Automatically adding GPU devices
[    17.024] (==) Automatically binding GPU devices
[    17.024] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    17.024] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    17.024] 	Entry deleted from font path.
[    17.025] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    17.025] 	Entry deleted from font path.
[    17.025] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    17.025] 	Entry deleted from font path.
[    17.025] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    17.025] 	Entry deleted from font path.
[    17.025] (==) FontPath set to:
[    17.025] (==) ModulePath set to "/usr/lib/xorg/modules"
[    17.025] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    17.025] (II) Module ABI versions:
[    17.025] 	X.Org ANSI C Emulation: 0.4
[    17.025] 	X.Org Video Driver: 25.2
[    17.025] 	X.Org XInput driver : 24.4
[    17.025] 	X.Org Server Extension : 10.0
[    17.025] (++) using VT number 2

[    17.025] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    17.026] (II) xfree86: Adding drm device (/dev/dri/card2)
[    17.026] (II) Platform probe for /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card2
[    17.027] (II) xfree86: Adding drm device (/dev/dri/card1)
[    17.027] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/drm/card1
[    17.038] (--) PCI:*(0@0:2:0) 8086:0166:152d:1054 rev 9, Mem @ 0xd3000000/4194304, 0xc0000000/268435456, I/O @ 0x00006000/64, BIOS @ 0x????????/131072
[    17.038] (--) PCI: (1@0:0:0) 10de:1292:152d:1054 rev 161, Mem @ 0xd2000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x????????/524288
[    17.038] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    17.038] (II) LoadModule: "glx"
[    17.038] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    17.040] (II) Module glx: vendor="X.Org Foundation"
[    17.040] 	compiled for, module version = 1.0.0
[    17.040] 	ABI class: X.Org Server Extension, version 10.0
[    17.040] (II) LoadModule: "intel"
[    17.040] (WW) Warning, couldn't open module intel
[    17.040] (EE) Failed to load module "intel" (module does not exist, 0)
[    17.040] (EE) No drivers available.
[    17.040] (EE) 
Fatal server error:
[    17.040] (EE) no screens found(EE) 
[    17.040] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    17.040] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    17.040] (EE) 
[    17.040] (EE) Server terminated with error (1). Closing log file.

In my previous answer I think I copied something wrong, so I pasted the /var/log/Xorg.0.log file from when I got the error.

If there are friends like me who have this problem, I solved it as follows.

  • sudo pacman -S xf86-video-intel
  • sudo nano /etc/X11/xorg.conf.d/20-intel.conf
  • I pasted the following into it, saved and exited:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “DRI” “2” # DRI3 is now default
#Option “AccelMethod” “sna” # default
#Option “AccelMethod” “uxa” # fallback
Option “TearFree” “true”

  • I verified that it is enabled with cat /var/log/Xorg.0.log | grep TearFree

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.