KDE Plasma Widgets Blank on RPi4

Just did a fresh install on my RPi4 and started getting into tweaking the interface. Everything seems to be working fine, except for the widgets. They are showing blank in the Add widgets window and none of the graphs in the widgets show anything.

For reference, I installed the regular Manjaro in virtualbox on my laptop and it all shows fine:

Any ideas?

Here is a screenshot of my inxi too

I do not know why you have this issue but I just wanted to say that I have not experienced this issue, all is well on my setups. So there is hope. :slight_smile:

1 Like

Thanks man. It’s so odd. I don’t want to reinstall. I’m actually reading through you thread about drivers. The only thing that stuck out to me so far was was driver for X11 as modesetting. It’s probably just missing some files or something. not sure how to reinstall maybe just certain packages.

Did you try wayland? Or if you are using wayland, did you try switching to x11? Just to see if the widgets show up. If it works with one and not the other… likely not an install issue. Funky desktop issues for me are usually due to old settings in ~/.config and ~/.local.

So I’m going through what’s installed on the VM vs what’s installed on RPi4 and so far:


Installed these just now and tried to log out / login and I got a blank screen. Rebooting now LOL

EDIT: Reboot came back fine. Still no dice with the widgets

Still no luck. Doing a full package diff between the two systems now and installing what I think might affect it lol

Going to try switching to testing branch

Well testing didn’t offer any new updates. Tried switching to plasma-git and it borked the whole system. Reflashing my SSD and starting over. I’ll check the widgets on a completely fresh install before I change anything.

Welp, completely fresh install. All I did was connect to wifi and same issue… ugh.

That is really odd. I checked again, this time with my setup in the office with a 4K monitor and it works fine for me. I am not doing a fresh install, maybe I can try that this evening.

Edit: I switched to a wayland session just to make sure, and it works too.

Yeah it’s really weird. The only thing different that I’m doing is using balena etcher to write the install image to a USB SSD vs doing anything with the SDcard. I could rule that out by doing a fresh install on the SD.

How do I switch to wayland to check that?

Install plasma-wayland-session and then reboot. I am not sure where to switch in sddm, but there will be something to click to select Plasma Wayland rather than Plasma.

Still no go and running way slower on wayland. Gonna try the SDCard install to eliminate that.

Widget graphs and stuff, require real OpenGL to function.

Install mesa-demos and give the output of glxinfo -B please. :slight_smile:

Ok stand by. Flashing a fresh image

@Strit heres the output…

Fresh install. Ran updates. Installed mainline kernel.

Are you reserving sufficient memory for 4k video? Do you have cma-384 or greater set in your config.txt file? ie. dtoverlay=vc4-fkms-v3d,cma-384

I dont remember needing to do that before. Was trying to change one thing at a time to see what does it.

# See /boot/overlays/README for all available options

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4

# Enable 4Kp60 Video

# Overclock CPU

Yup, changes.

I use:


But I have used the fkms too, both should work.

Without the cma-384 I can run at 1920x1080 without issue, but when using a 4K monior I must increase the video memory or I get weird video issues and kde crashes. I am unsure if setting it up to cma-512 is beneficial or not. I suspect 512 is better for 4K, with 384 being the minimum.

You can run:

$ cat /proc/meminfo

At the bottom there are two lines concerning the CMA. CmaFree shows available video memory and this number changes as you run apps.