KDE Plasma went almost totally unresponsive while using Flameshot

Like many times before, I started making a screenshot with Flameshot. The desktops started bleeding into one another, I couldn’t switch between open windows etc., most things on the screen looked stuck, so I was unable to exit my apps safely.

I looked for solutions. I tried killing processes through htop (I was able to start Konsole), but it didn’t help. Pressed Ctrl + Alt + F7 and then Ctrl + Alt + F1, nothing. Pressed the power button once and got the logout option. I tried logging in and out and, of course, all the apps were closed, as if I rebooted, which I then did, to come here.

Seems like I didn’t lose any progress, but this is worrying, as it could happen at a more inconvenient time. It wasn’t a system crash, but the effect was pretty much the same.

I have had some smaller issues with KDE over the past couple months. The Individual Core Usage widget would start glitching very badly, but that went away. Tiling windows to a half or a quarter of the screen was problematic, and it isn’t like it used to be now. When I tile a window down, the window isn’t sharp anymore.

  Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
  Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux

  Info: model: 11th Gen Intel Core i5-11600K 
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] 
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Asus VC239 serial: <filter>
    built: 2016 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel Graphics (RKL GT1)
    direct render: Yes

  System Temperatures: cpu: 27.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 279 Uptime: 21m wakeups: 0 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1482 libs: 375 tools: pamac Shell: Zsh v: 5.9 running-in: konsole
  inxi: 3.3.23

How do you make screenshots? Maybe this issue is related

1 Like

Have you tried Spectacle?


I make them by pressing PrtScn.
I don’t think I was having the same problem as kobaz, because I pressed Esc as soon as I realized something wasn’t working right, and I saw a notification from Flameshot which read that the screenshot had been aborted. Also, I think I shouldn’t have been able to start the terminal if the screen was frozen by Flameshot.

Yes. I had been using Spectacle for a while, but I wasn’t satisfied with it. I make a lot of screenshots. I found Flameshot a lot more convenient.

Right now I’m trying to configure Spectacle to flow like Flameshot, but I can’t seem to get rid of the window which comes up when I take a screenshot.

Tried KSnip?

Open spectacle → Configure → Shortcuts

You can redefine e.g. like this


1 Like

I changed the “After taking a screenshot” to “Do not copy anything” and started Spectacle from the Application Launcher. When I select the area I want copied and hit Enter, which is the way I need to use screenshotting programs, the annoying window appears again.

I’ve tried KSnip. I was able to configure it to work pretty much the same as Flameshot. Since KSnip is found in the KDE Store, I assume I can expect it to work without hiccups in KDE Plasma?

EDIT Can’t set PrtScn as the hotkey for KSnip, had to set Ctrl+Print, which is weird.

Are you taking shots of the whole screen or part of it?

I have Print to launch spectacle on the shortcuts page and on the general page I have Use -ls-used capture mode.

In my case where I only using parts of the screen - Print lkaunches cpectacle ready to take the shot - when it is done the wondow stays open because you have saved anything yet - perhaps you wnat t to annota the picture before it goes to disk or inserted in a doc.

Part of it.

Both spectacle and ksnip is great on Wayland

Ksnipped the Spectable I use


Perhaps ksnip is for Plasma what flameshot is for xfce - I feel the plasma apps more intuitive - perhaps that is just me - I never got far with Flameshot - we each have our favorites.

I switched to KSnip. It annoys me that I can’t set PrtScn as the hotkey, but have to use Ctrl+PrtScn. I comfort myself by using Enter as the capture key instead of Ctrl+C (that is what I used in Flameshot).

I hope this will prevent future freezes. That would make sense, since the problem occurred while taking a screenshot. I’ll see what happens.

Thanks to everybody.

You could have a look at shutter as well. It has some nice features and configurable shortcuts.

It looks nice, but my main concern is stability. I reckon/hope that KSnip is less likely to freeze my desktops because it is Qt based.