KDE Plasma Power Profiles Widget

Here’s a blog post from Nate Graham about the feature:

I’ve surfed around a bit on Google, reddit, and here to find out if anyone has been able to get this new feature working, but haven’t found anything definitive yet. Closest related topic is this:

According to comments in Nate’s blog, power-profiles-daemon needs to be installed for this feature to work, along with a kernel >= 5.12. I satisfied both of these conditions (using kernel 5.15), but the feature still doesn’t work, which leads me to ponder if my CPU (Intel i7-4770k) might not support the feature (which would be surprising, since it supports “power profiles” on Windows, so at least I know the hardware is capable).

Just curious if any other Manjaro KDE users have been able to get this feature working. Do I need to uninstall/disable TLP (which comes installed by default on Manjaro)? I’m generally wary of tinkering with my system’s defaults in fear of irreparably breaking something, so I’d like advice first. Thanks in advance.

Is the power-profiles-daemon enabled, is it running?

systemctl status power-profiles-daemon

You do not need to, but it may cause conflict.

1 Like

Thanks for replying. Yes, power-profiles-daemon appears to be running upon system restart, without my having to enable it manually.

● power-profiles-daemon.service - Power Profiles daemon
     Loaded: loaded (/usr/lib/systemd/system/power-profiles-daemon.service; dis>
     Active: active (running) since Sun 2021-12-26 12:16:17 PST; 49s ago
   Main PID: 1472 (power-profiles-)
      Tasks: 3 (limit: 19118)
     Memory: 1.2M
        CPU: 30ms
     CGroup: /system.slice/power-profiles-daemon.service
             └─1472 /usr/lib/power-profiles-daemon

I just took one for the team and uninstalled TLP, rebooted my system, and the widget still doesn’t appear. So through process of elimination, my conclusion is my hardware doesn’t support the feature (yet). But I could be wrong.

What does the following print?

gdbus introspect --system --dest net.hadess.PowerProfiles --object-path /net/hadess/PowerProfiles --only-properties




It’s “Battery and brightness” plasma applet residing in system tray.

node /net/hadess/PowerProfiles {
  interface net.hadess.PowerProfiles {
      readwrite s ActiveProfile = 'balanced';
      readonly s PerformanceInhibited = '';
      readonly s PerformanceDegraded = '';
      readonly aa{sv} Profiles = [{'Profile': <'power-saver'>, 'Driver': <'placeholder'>}, {'Profile': <'balanced'>, 'Driver': <'placeholder'>}];
      readonly as Actions = ['trickle_charge'];
      readonly aa{sv} ActiveProfileHolds = [];
* balanced:
    Driver:     placeholder

    Driver:     placeholder

Yeah, I read that in the blog post I linked in the OP, and that’s exactly where I’ve been looking for it.


I suppose one thing I should have noted is this is on my desktop PC, so no battery is present. It could be that I completely missed the point of this “power profiles” feature, and am an idiot, since this could very well be a feature meant exclusively for laptops. I’ve seen power profiles on Windows desktops and assumed this was pretty much the same thing (I generally don’t do this since my Windows knowledge is fairly limited these days, but “power profiles” stuck out to me as a Windows term, FWIW). If I’m completely wrong and have wasted everyone’s time, I’m so sorry. :upside_down_face:

Same here, on a laptop, powerprofilesctl list shows balanced and power-saver but the applet shows nothing, also going to energy settings the profiles tab shows nothing

Looks like someone should file a bug to bugs.kde.org