KDE Plasma Power Profiles not available


I’m on a PIneBook Pro, running Manjaro (which was pre-installed):
I’m sure power profiles were working on the KDE battery status indicator before, but they are not available anymore at time of writing:

power-profiles-daemon is executing correctly:

> systemctl status power-profiles-daemon
● power-profiles-daemon.service - Power Profiles daemon
     Loaded: loaded (/usr/lib/systemd/system/power-profiles-daemon.service; enabled; preset: disabled)
     Active: active (running) since Sat 2022-10-08 19:29:23 CEST; 6min ago
   Main PID: 408 (power-profiles-)
      Tasks: 3 (limit: 4321)
     Memory: 4.2M
        CPU: 130ms
     CGroup: /system.slice/power-profiles-daemon.service
             └─408 /usr/lib/power-profiles-daemon

and the two available profiles can be listed:

> powerprofilesctl list
* balanced:
    Driver:     placeholder

    Driver:     placeholder

Any idea, please?

thanks in advance

The driver in question needs to support it.

And it seems the Pinebook Pro battery does not support it.

That’s strange: if I run (from an SD card) this distribution (based on Manjaro kernel) GitHub - SvenKiljan/archlinuxarm-pbp: Arch Linux ARM for Pinebook Pro and GNOME DE, the profiles are shown and can be set…

Moreover, the list shown by powerprofilesctl confirm that they are not available? I thought they’d say the other way round.

Maybe it’s something Gnome does then?

Have you tried our Gnome edition to see what happens there?

Same here on Pinebook Pro with Manjaro KDE (originally installed on the machine, fully upgraded since) : No power profiles available. (But I didn’t know they even existed, so I can’t tell if they were previously available).

I’ll try ASAP.

But were you saying that the values shown on the command line confirm that the battery is not supported?

Is it a recent pinebook pro? I bought mine in 2020, but didn’t use it much so I might remember wrongly.

Mine is quite recent, from August 2022.