Kde Plasma often crash and can't add addons

This my laptop information.
My computer’s desktop environment often stuck and crash. In this situation, I can’t do anything only force reboot. My panel also can’t add addons.It’s so terrible that i can’t stand this.
Is there any method to fix it?

this is ‘normal’ behavior on plasma 5.25 … if you want add widgets, you need to disable global menu

1 Like

Welcome to the forum!

Unfortunately, this appears to be a quite common occurrence since the upgrade from Plasma 5.24.6 to 5.25.5. It would be irresponsible of me to give you any statistics about the amount of people who’ve got serious enough problems with Plasma 5.25, but I reckon that the percentage is very high.

However, just as unfortunately, there does not appear to be any direct way out of this misery at the level of the Manjaro distribution itself, given that the decision was made — driven by very vocal requests and complaints from newbies — to include Plasma 5.25 in the most recent update to Manjaro Stable, whereas Plasma 5.24 is a very polished LTS (“long-term support”) release that is still being maintained with updates from upstream.

We held back 5.25 for quite some time, even though it was already available in Manjaro Unstable and Manjaro Testing, but many newbies were urging us to switch to 5.25 in Manjaro Stable as well, and the management decided to give in. And now we are in this mess, where for a great number of users — myself included — Plasma 5.25 is simply not usable. And to make matters worse, KDE is also not going to be releasing any more fixes for 5.25, because they are already seeking to roll out 5.26.

The above all said, there is away to have a usable KDE Plasma on an otherwise fully updated Manjaro Stable for now, but there’s no telling how much longer this will work, because it involves a partial-upgrade scenario, which Manjaro does not and will not support.

The trick is to roll back to the state of the system right before the update of 12 September 2022, add the line IgnoreGrp = plasma to /etc/pacman.conf, and then update the system again. This will update everything in the system but leave Plasma at 5.24.6. And like I said, it works for now, but it may (and probably will) lead to problems at some point later in time when KDE Frameworks gets another update.

A number of people — again including myself — are brainstorming on possible solutions to the problem, but there is no guarantee that we’ll come up with something. But at least there’s a little sparkle of hope for every Plasma user for whom the upgrade to 5.25.5 has left them with an unusable system.

Cross your fingers… :crossed_fingers:


does this mean i could delete this panel ,then add addons and enable global menu finally?

thanks, you perfectly solved my doubts. hope the next version could be better.

you can try out if it works like this, if not, you will have to be without the global menu

1 Like

This is not normal at all! I have Plasma 5.25.5 on Arch here since its release and this has never happened!

I have tried, it doesn’t work. Hope next version will be better.

I will try arch. However I’m worried about the stability of arch. Is there a simple way convert manjaro to arch? because i don’t wanna lose my data.

1 Like

Short answer for now is to stick with Breeze/Breath themes, get rid of all desktop widgets (I’ve found that the analog and digital clocks are OK) and stick to a rather plain vanilla desktop until these bugs with the KDE 5.25 series are ironed out.


I had no issues with plasma 5.25.5. Not on manjaro stable, manjaro testing or on one arch install I have.
But I saw in your neofetch output, that you run a different theme. I run breeze. And your theme seems to include gtk2 also. Maybe that could cause the issue?

And for the global menu I use a widget called “active windows control”, because it allows me to have the close-button in the upper panel too, what is the only reason I use the global menu for. And with this widget, no problems here.

If there are really so many issues reported, than it would be interesting to know if those people did also run themes which include gtk2 maybe.

I don’t know and don’t think, that will solve your issues with plasma. Like I said, changing the theme could maybe.

And I’m almost new to manjaro also, so I don’t know how close the manjaro-unstable branch is to arch, but if you want to switch this could help. It are actually only two commands:

I switched from the stable to the testing branch very soon. I’m not recommending it, but since you wanted to try arch anyway, you could try to switch branches before.

1 Like

Plasma does not use GTK. screenfetch lists the theme that is set for GTK applications, but that’s irrelevant.

1 Like

Was just an idea, because the theme is one difference to my setup.

I changed some global themes ,such as Breeze , breeze dark. Howerver it didn’t work.
At first , I thought it was a nvidia graphics card driver error. I also tried change graphics card drivers.It still didn’t work.
Maybe the only thing i can do is waiting to update.

just dont use global menu, if thats whats causing it, untill its fixed

Easy way is only remove global menu, change panel widget arangement and add global menu back. It works.

To be honest: I find Arch to be significantly more stable than …
As for converting, I can not advise you anything other than a clean reinstall. I’m still keeping an eye on the big M though, because I’m dealing with it on some customer machines.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.