KDE Plasma not showing displayport monitor's resolutions


Today I tried to connect my laptop to a monitor, which supports 2560x1440@144Hz. However, the laptop and Plasma is unable to recognize the monitor’s supported resolution.

My laptop is a 2017 Dell XPS 13 with intel graphics. I’m running the 5.15.138-1-MANJARO kernel. I am running X11. I haven’t tried wayland, but I’d rather not use it if I don’t have to because I’d need to reconfigure a lot of things, and not everything will work correctly.

The monitor works perfectly fine on my desktop, which is also running Manjaro (on a 6.1 kernel though, IIRC), and has an Nvidia 1080Ti and using proprietary drivers, and on X11.

In order to connect this laptop to the monitor, I need to use a usb-c to displayport adapter. I know that this adapter works, because I’ve used it in the past on the same laptop with Windows, and I haven’t had any issues. However, it’s been a while.

What should I try next?

EDIT: to be clear, I realize it might be possible to add the monitor resolution manually with xrandr, but I don’t want that. I want the autodetection to work properly, if possible.

EDIT2: well, I tried to add the resolution manually anyway, both at 144Hz and 60Hz, but it still doesn’t work.