KDE Plasma - newly installed apps do not appear in Start menu

Hey,

I’ve downloaded newest KDE Manjaro ISO from the site via torrent, installed it on my Lenovo Ideapad S540-14IWL and upgraded all the packages. I went on to install the latest kernel, Nvidia 440 bbswitch drivers, and modesetting (I want to install optimus-manager). After that point, whenever I try to download something from Pamac (Tried it on minecraft-launcher, R and Inkscape), it doesn’t appear in start menu even though there are no warnings/irregularities in pamac/pacman log while installing. Up to the point before installing drivers, all apps were added to the start menu (GIMP and LibreOffice, e. g).

I should also note that I’m running dual boot Windows, on a 100 MiB boot partition. I’ve ruled out that this isn’t the problem since I’m running testing branch on desktop, and I’ve partitioned the drives exactly in the same order, and on my desktop PC I’m having no errors whatsoever.

Every bit of help will be appreciated!

Regards,
Alarg

Have you logged out and logged back in?

1 Like

Of course, and powered off/powered on.

It’s strange behavior. You always can manually add apps through Menu editor (right click on menu icon).

1 Like

I’m aware of that. I’ve tried reinstalling my OS several times and it always ends up the same way. I’ll wait for a few days to see whether an update fixes something. In the meantime, if anyone has a concrete solution, I’d appreciate it very much! :slight_smile:

Regards,
Alarg

You might want to try

$ kbuildsycoca5 --noincremental

Also see here: Plasma menu no longer updating? Solution.

2 Likes

Your solution worked! Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.