KDE plasma freezes all the time

Did you see what I added at the end of my post?

Alternatively there is another way to install this driver, but it requires manual intervention so let try to automatic method first.

OK I think I have an idea why it doesn’t work, you probably need to edit the PKGBUILD when Pamac asks you, type E key, and then edit the line 43 to:


//EDIT: it would be easier to do that from the graphical interface, open Pamac, then search for nvidia-340xx-dkms, then click on it once, on the right side panel click on the button Build Files, and then modify the line 43 of the PKGBUILD to change the kernel name, to the currently used one, in your case edit _kernelname=linux to _kernelname=linux510 then you can click on BUILD button and Aplly on bottom right corner, you can see the terminal output by clicking on the icon in bottom right corner while it is building the driver package.

//EDIT2: this driver package is not meant for Manjaro but for Arch Linux, so this is probably why some tinkering is needed.

Thank you again, but still something wrong. I tried that in the graphic editor, but still getting some kind of error:

==> Starting build()...
NVIDIA: calling KBUILD...
make[1]: *** /usr/src/linux510: No such file or directory.  Stop.
nvidia.ko failed to build!
make: *** [Makefile:202: nvidia.ko] Error 1
==> ERROR: A failure occurred in build().


I’m not sure then why it fails, I’m no expert so I can’t help more to install this specific package. However, there is an alternative, it is to install the same kind of package manually, following this guide here

But you will also need to manually add a configuration file to bypass incompatibility with the current xorg in Manjaro, following these instruction, before rebooting:

Create the file /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf from terminal

sudo nano /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf

Copy and paste the following to this file

Section "Files"
  ModulePath   "/usr/lib64/nvidia/xorg"
  ModulePath   "/usr/lib64/xorg/modules"

Section "Device"
  Identifier "Nvidia Card"
  Driver "nvidia"
  VendorName "NVIDIA Corporation"

Section "ServerFlags"
  Option "IgnoreABI" "1"

Save the file and exit nano text editor by pressing CTRL+X then Y (you can follow at the bottom what it does). It should bring you back to the terminal.

Reboot and see if it works. it may not work in which case we could revert changes from terminal, but I’ll add info if needed in that case (tell us if you can access the forum in case your computer can not properly boot then, or make sure you can access forum from another device before trying these instructions).

//EDIT: It may also be required to make sure the Nouveau driver is blacklisted so it doesn’t load, to do that first create a config file for modprobe:

sudo nano /usr/lib/modprobe.d/blacklist-nouveau.conf

then copy and paste the following in it

blacklist nouveau

then save and exit nano editor with CTRL+X then Y

But first try without blacklisting Nouveau, if it all works verify in inxi that the Nvidia driver is properly loaded and working for your video card, and then you could blacklist it to make sure it never loads.

//EDIT: also another needed step is to add the Nvidia packages to the ignore list to avoid the similar AUR packages to try to install/update and replace these ones just installed manually (which they can’t install install/update/replace because of the difference in kernel between Arch and Manjaro, example above for failure), easy to do directly from Pamac preferences → Advanced → Ignore List (searching for Nvidia and selecting the packages)

Hope you’re not having too much trouble.
I’m off for the night, I’ll be back tomorrow if you need help.

I had troubles with Plasma freezing. Switching to KwinFT remedied mots of the problems.

1 Like

Actually I’m even in more trouble now :smiley:
I didn’t even try that manual installation but now the computer doesn’t boot properly. It gets stuck with a black screen with only cursor (which responds to the mouse).

Is there anything I can do?


I have tried to press ctrl+alt+f2 but it doesn’t do anything. Could it be because of mac keyboard?

Also I can’t boot from the usb stick where I have the manjaro iso file because when I try that booting with alt key pressed it doesn’t show the usb-stick as an option. Only hard drive is visible.

Is there anything that I could still try?


Yes, I did that. It helped!!! If you use the Nouveau driver you should try this tweak. Place this line in your environment folder: QSG_RENDER_LOOP=basic.

Do not use the export command here.

If you can not even access a TTY with the CTRL+ALT+F3 shortcut to work from terminal I don’t know what you should do. To me your issue are because of the open source driver, it may or may not be the case but that is my first guess and I believe it. Trying to install the 340 drivers would help greatly if this is the case.

It is possible to work from the live USB environment too, by chrooting the system, if you really can’t do anything from the normal way, in a TTY, then it is a possibility.

Yeah the TTY doesn’t work…

At this point I would like to just re install the OS but there is a problem too. When I boot with the USB stick on and holding alt key, the usb stick doesn’t show up. Only EFI boot from the hard drive is visible. :confused:

How I’m supposed to go to that live USB environment?


About the TTY, possible that the Fxx key are accessed by pushing another keyboard key like Fn most of the time so it might be CTRL+ALT+Fn+F3 combo.

I don’t know how to access your USB live environment, I would say the same way you did initially :smiley:

Okay! That fn button solved the tty terminal issue! Now I just have to find out what to do next! Thank u!


Try to install Nvidia 340 drivers from another TTY all by terminal. KDE plasma freezes all the time - #9 by omano

It will be annoying as you have to type everything without a single typo error.

Now I got my desktop view back again following these instructions!

So maybe I’ll try that Nvidia 340 driver installation when I have time.


Just a idea, i had many freezes/hang ups and restarts with Manjaro/KDE as i switched to Linux Manjaro/KDE 14month ago and i still use it today.
I had a overclocked CPU and it was always and still is stable under Windows7/Win10 (even in demanding VR Gaming in 5k Resolution/90FPS).

I found out that Manjaro/KDE is more reliable on a stable processor as Windows!
And i had to downclock my CPU with Process Govenor… if you don’t have a overclocked CPU it could still related to the same issue, because when a CPU gets older its required more voltage (or just can’t hold the stable MHz) after the years go on. Its all about the silicon lottery (atleast sometimes) and the Mainboard manufactures gives sometimes a bad default voltage settings.

I want to make this clear… i still could be total wrong here, the problem maybe fixed with GPU driver’s. I just want to show another view related to this freezes/hang ups.

Okay, I think I succeeded in installing Nvidia 340 driver!

  Device-1: NVIDIA C79 [GeForce 9400M] vendor: Apple MacBook5 1 driver: nvidia
    v: 340.108 alternate: nouveau bus-ID: 02:00.0 chip-ID: 10de:0863
    class-ID: 0300

And yea maybe it runs a little bit smoother now! Thank you omano a lot for your help!


1 Like

Nice! You have some option if you run Nvidia Settings, this is where you configure the video card now.

See if it freezes now with this video driver, my guess is that it should fix this issue.

//EDIT: now what I would do is make system backups with Timeshift at least multiple time per year (disable all the automated backups in Timeshift settings, this is not really necessary, manually trigger a backup when you feel like it, for example before every big Manjaro update).
I’m telling you that because in theory, after a kernel update, it should automate some process to ‘reinstall’ the Nvidia driver so it works on next reboot, but in case there is an issue, with the Timeshift backup, you could always get to a TTY and rollback the failed update from terminal to have your system in the state it was when you made the backup.

Also, do not change your kernel, stick with the one you have, kernel 5.10, as this is the one compatible with the driver and the way you installed it. This kernel will continue to be maintained for many years.

@omano Thanks for your help, I followed your instructions and now my pc is functional.

The only thing is, I lost multi gestures (I am in Gnome). Is not as important as the use of a second monitor (now I can) but it could be nice to have it. Do you now what could I do?

Thanks again.

Open a new thread for new unrelated issues, it is a forum rule to have functional searches.