KDE plasma freezes all the time

I installed manjaro KDE plasma today on my old macbook. The system runs very laggy and especially firefox freezes all the time so that I can’t do anything but to boot the computer from the power button. It seems that the cpu usage goes to 100% even in the smal operations which werent no problem in the macOSX. Any ideas what could be the reason?

Here’s the inxi output:

  Host: pietarinkone Kernel: 5.10.93-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=873f89cd-7c31-4fa3-aa71-670e97f56232 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBook5,1 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-F42D89C8
    serial: <superuser required>
  Mobo: Apple model: Mac-F42D89C8 v: Proto serial: <superuser required>
    UEFI: Apple v: MB51.88Z.007D.B03.0904271443 date: 04/27/09
  ID-1: BAT0 charge: 8.7 Wh (97.8%) condition: 8.9/44.7 Wh (19.9%)
    volts: 12.4 min: 10.9 model: SMP bq20z951 type: Li-ion serial: N/A
    status: Full cycles: 488
  RAM: total: 7.52 GiB used: 841.7 MiB (10.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core2 Duo P7350 bits: 64 type: MCP arch: Core Penryn
    family: 6 model-id: 0x17 (23) stepping: 0xA (10) microcode: 0xA0B
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1733 high: 1769 min/max: 1596/1995 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1697 2: 1769
    bogomips: 7963
  Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc
    cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts est flexpriority fpu fxsr ht
    lahf_lm lm mca mce mmx monitor msr mtrr nopl nx pae pat pbe pdcm pebs pge
    pni pse pse36 pti rep_good sep sse sse2 sse4_1 ssse3 syscall tm tm2
    tpr_shadow tsc vme vmx vnmi vpid xsave xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full generic retpoline, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA C79 [GeForce 9400M] vendor: Apple MacBook5 1
    driver: nouveau v: kernel bus-ID: 02:00.0 chip-ID: 10de:0863 class-ID: 0300
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo bus-ID: 1-4:3
    chip-ID: 05ac:8507 class-ID: 0e02 serial: 8J92B1C4C40U3A00
  Display: x11 server: X.org compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 00:08.0 chip-ID: 10de:0ac0 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.93-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: NVIDIA MCP79 Ethernet driver: forcedeth v: kernel port: 21e0
    bus-ID: 00:0a.0 chip-ID: 10de:0ab0 class-ID: 0200
  IF: enp0s10 state: up speed: 1000 Mbps duplex: full
    mac: 00:23:df:a9:21:e6
  IP v4: type: dynamic noprefixroute scope: global
  IP v6: fe80::6c99:fcfd:fd89:1bcf/64 type: noprefixroute scope: link
  Device-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN
    vendor: Apple AirPort Extreme driver: wl v: kernel modules: ssb
    bus-ID: 03:00.0 chip-ID: 14e4:432b class-ID: 0280
  IF: wls3 state: dormant mac: da:92:6a:4d:ab:ed
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 4-1.1:3 chip-ID: 05ac:8213 class-ID: fe01 serial: 002500503883
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 19.75 GiB (8.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: A-Data model: SP600 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD
    serial: 2F2520026264 rev: 5.2 scheme: GPT
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRW GS21N rev: SA18
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 19.75 GiB (8.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 873f89cd-7c31-4fa3-aa71-670e97f56232
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 09B1-A016
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 7 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:3 info: Apple Built-in iSight type: Video driver: uvcvideo
    interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 05ac:8507
    class-ID: 0e02 serial: 8J92B1C4C40U3A00
  Hub-2: 2-0:1 info: Full speed or root hub ports: 5 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed or root hub ports: 7 rev: 1.1
    speed: 12 Mb/s chip-ID: 1d6b:0001 class-ID: 0900
  Device-1: 3-1:2 info: Logitech M105 Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 046d:c077 class-ID: 0301
  Device-2: 3-5:3 info: Apple Built-in IR Receiver type: HID
    driver: appleir,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 100mA
    chip-ID: 05ac:8242 class-ID: 0300
  Device-3: 3-6:4 info: Apple Internal Keyboard/Trackpad (ISO)
    type: Keyboard,HID,Mouse driver: apple,bcm5974,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 40mA chip-ID: 05ac:0237 class-ID: 0301
  Hub-4: 4-0:1 info: Full speed or root hub ports: 5 rev: 1.1
    speed: 12 Mb/s chip-ID: 1d6b:0001 class-ID: 0900
  Hub-5: 4-1:2
    info: Broadcom BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth) ports: 3
    rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:4500 class-ID: 0900
  Device-1: 4-1.1:3 info: Apple Bluetooth Host Controller type: Bluetooth
    driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 05ac:8213
    class-ID: fe01 serial: 002500503883
  System Temperatures: cpu: 78.0 C mobo: N/A gpu: nouveau temp: 79.0 C
  Fan Speeds (RPM): N/A
  Processes: 176 Uptime: 2m wakeups: 2 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1342 lib: 351
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.12


What is output of mhwd -l command?

Post terminal output between three backticks so it is properly formatted, edit your previous post too to properly format it, this is unreadable currently. Example:

terminal output here

mhwd -l output:

> 0000:03:00.0 (0200:14e4:432b) Network controller Broadcom:
                  NAME               VERSION          FREEDRIVER           TYPE
   network-broadcom-wl            2018.10.07               false            PCI

> 0000:02:00.0 (0300:10de:0863) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


Unfortunately, Manjaro doesn’t provide a compatible Nvidia video driver. I suspect your constant freezes and bad performance is because you are using the open source driver called Nouveau.

The compatible driver for your video card would be version 340 and Manjaro doesn’t provide this one since long time now. There is an alternative, installing it from the AUR, but that is at your own risk and is not supported.

If you want to try, you could enable AUR support in Pamac preferences (the Add/Remove Applications program you can find in the Application menu). When AUR support is enabled, you can then search for nvidia-340xx-dkms and install it. It should install and configure the basics to have a working Nvidia version 340 driver, and it should automatically install the Nvidia modules every time there is a kernel update.

If you get a black screen on reboot, you should still be able to revert the changes by accessing a TTY (with CTRL+ALT+F3 keyboard shortcut), login, and remove the installed drivers with command pamac remove nvidia-340xx-dkms

It is possible that you would also first need to install the base-devel tools, and also the kernel header, in order to be bale to install properly the Nvidia driver. To do so, run the following commands (//EDIT: added the driver install command if you want to do it all by terminal):

pamac install base-devel
pamac install linux510-headers
pamac build nvidia-340xx-dkms
1 Like

Thank you for the tips!

I tried to install that driver but an error occured:

Checking nvidia-340xx-dkms dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  nvidia-340xx-dkms  340.108-28    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Building nvidia-340xx...
/var/tmp/pamac-build-pietari/nvidia-340xx/PKGBUILD: line 43: /usr/src/linux/version: No such file or directory
==> Making package: nvidia-340xx 340.108-28 (pe 28. tammikuuta 2022 18.09.50)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found NVIDIA-Linux-x86_64-340.108-no-compat32.run
  -> Found 20-nvidia.conf
  -> Found 0001-kernel-5.7.patch
  -> Found 0002-kernel-5.8.patch
  -> Found 0003-kernel-5.9.patch
  -> Found 0004-kernel-5.10.patch
  -> Found 0005-kernel-5.11.patch
  -> Found 0006-kernel-5.14.patch
  -> Found 0007-kernel-5.15.patch
  -> Found 0008-kernel-5.16.patch
==> Validating source files with b2sums...
    NVIDIA-Linux-x86_64-340.108-no-compat32.run ... Passed
    20-nvidia.conf ... Passed
    0001-kernel-5.7.patch ... Passed
    0002-kernel-5.8.patch ... Passed
    0003-kernel-5.9.patch ... Passed
    0004-kernel-5.10.patch ... Passed
    0005-kernel-5.11.patch ... Passed
    0006-kernel-5.14.patch ... Passed
    0007-kernel-5.15.patch ... Passed
    0008-kernel-5.16.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Starting prepare()...
Creating directory NVIDIA-Linux-x86_64-340.108-no-compat32
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 340.108...........................................................................................................................................................................................................
Applying patch 0001-kernel-5.7.patch...
patching file kernel/Makefile
patching file kernel/conftest.sh
patching file kernel/dkms.conf
patching file kernel/nv-drm.c
patching file kernel/nv-linux.h
patching file kernel/nv-procfs.c
patching file kernel/nv-time.h
patching file kernel/nv.c
patching file kernel/os-interface.c
patching file kernel/uvm/Makefile
patching file kernel/uvm/conftest.sh
patching file kernel/uvm/nvidia_uvm_lite.c
Applying patch 0002-kernel-5.8.patch...
patching file kernel/nv-linux.h
patching file kernel/nvidia-modules-common.mk
patching file kernel/os-mlock.c
patching file kernel/uvm/nvidia_uvm_lite_api.c
Applying patch 0003-kernel-5.9.patch...
patching file kernel/nv-drm.c
patching file kernel/nv-linux.h
patching file kernel/nv.c
patching file kernel/uvm/nvidia_uvm_linux.h
Applying patch 0004-kernel-5.10.patch...
patching file kernel/nv-drm.c
Hunk #1 succeeded at 364 (offset 42 lines).
Applying patch 0005-kernel-5.11.patch...
patching file kernel/conftest.sh
patching file kernel/nv-drm.c
Hunk #1 succeeded at 59 (offset -1 lines).
Hunk #2 succeeded at 211 (offset -1 lines).
Hunk #3 succeeded at 242 (offset -1 lines).
Hunk #4 succeeded at 278 (offset -1 lines).
Hunk #5 succeeded at 408 (offset -2 lines).
Hunk #6 succeeded at 459 (offset -2 lines).
patching file kernel/nv-linux.h
patching file kernel/uvm/nvidia_uvm_linux.h
Applying patch 0006-kernel-5.14.patch...
patching file kernel/nv-drm.c
patching file kernel/os-interface.c
Applying patch 0007-kernel-5.15.patch...
patching file kernel/nv-drm.c
Hunk #1 succeeded at 606 (offset 77 lines).
Applying patch 0008-kernel-5.16.patch...
patching file kernel/os-interface.h
patching file kernel/nv.h
==> Removing existing $pkgdir/ directory...
==> Starting build()...
NVIDIA: calling KBUILD...
make[1]: *** /usr/src/linux: No such file or directory.  Stop.
nvidia.ko failed to build!
make: *** [Makefile:202: nvidia.ko] Error 1
==> ERROR: A failure occurred in build().


Did you see what I added at the end of my post?

Alternatively there is another way to install this driver, but it requires manual intervention so let try to automatic method first.

OK I think I have an idea why it doesn’t work, you probably need to edit the PKGBUILD when Pamac asks you, type E key, and then edit the line 43 to:


//EDIT: it would be easier to do that from the graphical interface, open Pamac, then search for nvidia-340xx-dkms, then click on it once, on the right side panel click on the button Build Files, and then modify the line 43 of the PKGBUILD to change the kernel name, to the currently used one, in your case edit _kernelname=linux to _kernelname=linux510 then you can click on BUILD button and Aplly on bottom right corner, you can see the terminal output by clicking on the icon in bottom right corner while it is building the driver package.

//EDIT2: this driver package is not meant for Manjaro but for Arch Linux, so this is probably why some tinkering is needed.

Thank you again, but still something wrong. I tried that in the graphic editor, but still getting some kind of error:

==> Starting build()...
NVIDIA: calling KBUILD...
make[1]: *** /usr/src/linux510: No such file or directory.  Stop.
nvidia.ko failed to build!
make: *** [Makefile:202: nvidia.ko] Error 1
==> ERROR: A failure occurred in build().


I’m not sure then why it fails, I’m no expert so I can’t help more to install this specific package. However, there is an alternative, it is to install the same kind of package manually, following this guide here

But you will also need to manually add a configuration file to bypass incompatibility with the current xorg in Manjaro, following these instruction, before rebooting:

Create the file /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf from terminal

sudo nano /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf

Copy and paste the following to this file

Section "Files"
  ModulePath   "/usr/lib64/nvidia/xorg"
  ModulePath   "/usr/lib64/xorg/modules"

Section "Device"
  Identifier "Nvidia Card"
  Driver "nvidia"
  VendorName "NVIDIA Corporation"

Section "ServerFlags"
  Option "IgnoreABI" "1"

Save the file and exit nano text editor by pressing CTRL+X then Y (you can follow at the bottom what it does). It should bring you back to the terminal.

Reboot and see if it works. it may not work in which case we could revert changes from terminal, but I’ll add info if needed in that case (tell us if you can access the forum in case your computer can not properly boot then, or make sure you can access forum from another device before trying these instructions).

//EDIT: It may also be required to make sure the Nouveau driver is blacklisted so it doesn’t load, to do that first create a config file for modprobe:

sudo nano /usr/lib/modprobe.d/blacklist-nouveau.conf

then copy and paste the following in it

blacklist nouveau

then save and exit nano editor with CTRL+X then Y

But first try without blacklisting Nouveau, if it all works verify in inxi that the Nvidia driver is properly loaded and working for your video card, and then you could blacklist it to make sure it never loads.

//EDIT: also another needed step is to add the Nvidia packages to the ignore list to avoid the similar AUR packages to try to install/update and replace these ones just installed manually (which they can’t install install/update/replace because of the difference in kernel between Arch and Manjaro, example above for failure), easy to do directly from Pamac preferences → Advanced → Ignore List (searching for Nvidia and selecting the packages)

Hope you’re not having too much trouble.
I’m off for the night, I’ll be back tomorrow if you need help.

I had troubles with Plasma freezing. Switching to KwinFT remedied mots of the problems.

1 Like

Actually I’m even in more trouble now :smiley:
I didn’t even try that manual installation but now the computer doesn’t boot properly. It gets stuck with a black screen with only cursor (which responds to the mouse).

Is there anything I can do?


I have tried to press ctrl+alt+f2 but it doesn’t do anything. Could it be because of mac keyboard?

Also I can’t boot from the usb stick where I have the manjaro iso file because when I try that booting with alt key pressed it doesn’t show the usb-stick as an option. Only hard drive is visible.

Is there anything that I could still try?


Yes, I did that. It helped!!! If you use the Nouveau driver you should try this tweak. Place this line in your environment folder: QSG_RENDER_LOOP=basic.

Do not use the export command here.

If you can not even access a TTY with the CTRL+ALT+F3 shortcut to work from terminal I don’t know what you should do. To me your issue are because of the open source driver, it may or may not be the case but that is my first guess and I believe it. Trying to install the 340 drivers would help greatly if this is the case.

It is possible to work from the live USB environment too, by chrooting the system, if you really can’t do anything from the normal way, in a TTY, then it is a possibility.

Yeah the TTY doesn’t work…

At this point I would like to just re install the OS but there is a problem too. When I boot with the USB stick on and holding alt key, the usb stick doesn’t show up. Only EFI boot from the hard drive is visible. :confused:

How I’m supposed to go to that live USB environment?


About the TTY, possible that the Fxx key are accessed by pushing another keyboard key like Fn most of the time so it might be CTRL+ALT+Fn+F3 combo.

I don’t know how to access your USB live environment, I would say the same way you did initially :smiley:

Okay! That fn button solved the tty terminal issue! Now I just have to find out what to do next! Thank u!


Try to install Nvidia 340 drivers from another TTY all by terminal. KDE plasma freezes all the time - #9 by omano

It will be annoying as you have to type everything without a single typo error.

Now I got my desktop view back again following these instructions!

So maybe I’ll try that Nvidia 340 driver installation when I have time.