Kde plasma does not remember the location of desktop icons

After each reboot, the location of the desktop icons changes. How can this be fixed?

P.S.: I started using linux not so long ago. And sry for bad eng :slight_smile:

KDE Plasma: 5.21.5

LOCK icons does not work


What do you mean by that? Where is this location that should be kept, and where do the shortcuts move?
The Shortcuts Settings are always in the same place:

and once you modify something and Apply, are always saved in ~/.config/kglobalshortcutsrc

I mean desktop icons. After each reboot, the location of the icons changes

fixed the title to avoid confusion

Hi! It didn’t work for me. After the reboot, the browser icons shifted up

You need to tick the LOCK Icons box after you place the icons where you want them, or else they reorgranize by name. It works for me.

Didn`t work. On the ru forum, 1 user wrote that he has the same bug and he does not know how to fix it on his own

You didn’t force a sorting mode? You have UNSORTED selected in the way they sort?

Yes, I have unsorted

I don’t know it works for me, it may be a wrong configuration somewhere, an old configuration that you never merged with the recent changes, or a corrupted file in your Home folder. Try a new user, and see if the behavior works correctly on the new user.

//EDIT: do you have multiple screens?

I have 1 monitor, but in manjaro I have 2 virtual desktops

KDE does not save the location due to the fact that I changed the size of the icons. After I returned the standard value, everything went back to normal (hopefully forever)

In any case, I would like to know how you can change the icons and still remember their positions

P.S.: sry for bad eng

I would like to place each desktop item manually, possibly rearrange them to my taste, but have them stay where I put them between sessions. Locking seems to prevent me from moving either existing or newly created items. Unlocking lets them all move between sessions. Unlocking and relocking is way too clumsy, and I will just find other organizing tools instead of desktop items. If I have missed a way to do what I want, I will greatly appreciate a pointer. Thanks.

It works. If it doesn’t work then check if you have UNSORTED selected under the menu options when you right click. Also maybe it is possible your config files have wrong/unsupported values and a reset could fix weird issues, or maybe just playing with all settings back and forth could sort things out, but it definitely work for me since long time now. It can change the items position on specific conditions like changing desktop resolution, switching main monitor when having multiple, things like that.

I am now getting my desired behavior, with icons unlocked, sorting set to “Manual” (there is no “Unsorted” option in my system), and I deselected “Folders first.” In order to deselect, I had to switch out of Manual sorting, deselect, and then switch back to Manual. I’m not sure exactly what made the difference, but anyway I have what I want now. I had focused to much on Locking, and instead the key was to disable Sorting.

My UI is in French so I translate back what I have, so in your language or English it may be different translation, KDE translation have huge discrepancies in various language sometimes :smiley: