KDE Plasma Crashes, loses effects

Hello everyone I have been using Manjaro for about 2 weeks and been loving it so far.

My only issue is something I’ve had since the beginning, KDE Plasma occasionally crashes and has to restart. My windows stay the same but the bottom panel flashes away for a second and comes back. This happens when interacting with Plasma like changing the volume or bringing up the super key menu. Most of the time the effects don’t come back, so the animations tear, no translucency, etc until I reboot. Sometimes the bottom panel just disappears and I have to reboot with Yakuake.

System info:

System:    Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=2cf91412-22e1-4b59-8ffd-88b13f7bd413 rw 
           quiet apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: B365M Pro4 serial: <filter> UEFI: American Megatrends v: P4.20 
           date: 05/15/2019 
Battery:   Message: No system battery data found. Is one present? 
Memory:    RAM: total: 15.57 GiB used: 7.33 GiB (47.1%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: D (13) microcode: EA cache: L2: 12 MiB bogomips: 57616 
           Speed: 800 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           7: 800 8: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx 
           avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 
           dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp 
           hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm 
           lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq 
           pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep 
           smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
           tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort mitigation: TSX disabled 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Micro-Star MSI driver: nvidia v: 470.57.02 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1e89 class-ID: 0300 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 75 s-size: 1516x487mm (59.7x19.2") s-diag: 1592mm (62.7") 
           Monitor-1: DP-2 res: 2560x1440 hz: 75 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           Monitor-2: HDMI-0 res: 1920x1080 hz: 60 
           OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403 
           Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus-ID: 01:00.1 chip-ID: 10de:10f8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel port: f000 bus-ID: 00:1f.6 
           chip-ID: 8086:15b8 class-ID: 0200 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 04:00.0 chip-ID: 8086:2723 
           class-ID: 0280 
           IF: wlp4s0 state: down mac: <filter> 
           WAN IP: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-13:5 chip-ID: 8087:0029 
           class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Logical:   Message: No logical block device data found. 
RAID:      Message: No RAID data found. 
Drives:    Local Storage: total: 2.3 TiB used: 43.5 GiB (1.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDS500G2B0C-00PXH0 size: 465.76 GiB 
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> 
           rev: 211070WD temp: 43.9 C scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000BX500SSD1 size: 931.51 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 030 scheme: GPT 
           ID-3: /dev/sdb maj-min: 8:16 vendor: TeamGroup model: T253X2001T size: 953.87 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 4A0 scheme: GPT 
           Message: No optical or floppy data found. 
Partition: ID-1: / raw-size: 464.76 GiB size: 456.39 GiB (98.20%) used: 43.15 GiB (9.5%) fs: ext4 
           dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A uuid: 2cf91412-22e1-4b59-8ffd-88b13f7bd413 
           ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 366.7 MiB (35.9%) fs: vfat 
           dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A uuid: 42BE-4994 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Unmounted: ID-1: /dev/sda1 maj-min: 8:1 size: 200 MiB fs: vfat label: EFI uuid: 67E3-17ED 
           ID-2: /dev/sda2 maj-min: 8:2 size: 931.32 GiB fs: apfs label: N/A 
           uuid: db5a7242-1c91-4806-9e3a-a43281c7fd49 
           ID-3: /dev/sdb1 maj-min: 8:17 size: 499.98 GiB fs: ntfs label: N/A uuid: 744618104617D22A 
           ID-4: /dev/sdb2 maj-min: 8:18 size: 453.87 GiB fs: exfat label: new shared uuid: FD07-7868 
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 
           class-ID: 0900 
           Device-1: 1-3:2 info: Valve Wireless Steam Controller type: Keyboard,HID driver: hid-steam,usbhid 
           interfaces: 5 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 28de:1142 class-ID: 0300 
           Device-2: 1-11:3 info: Logitech G502 SE HERO Gaming Mouse type: Mouse,HID driver: hid-generic,usbhid 
           interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 300mA chip-ID: 046d:c08b class-ID: 0300 serial: <filter> 
           Device-3: 1-12:4 info: Microdia Backlit Gaming Keyboard type: Keyboard,Mouse 
           driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 400mA chip-ID: 0c45:652f 
           class-ID: 0301 
           Device-4: 1-13:5 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 
           speed: 12 Mb/s power: 100mA chip-ID: 8087:0029 class-ID: e001 
           Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s chip-ID: 1d6b:0003 
           class-ID: 0900 
           Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 
           class-ID: 0900 
           Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003 
           class-ID: 0900 
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A gpu: nvidia temp: 46 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 311 Uptime: 5h 44m wakeups: 0 Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 
           clang: 12.0.1 Packages: 1349 pacman: 1342 lib: 345 flatpak: 7 Shell: Zsh v: 5.8 running-in: konsole 
           inxi: 3.3.06 


Please share your /etc/X11/mhwd.d/nvidia.conf
Also, try to set the Compositor like this:



This is why the KDE Plasma compositor (it’s called KWin by the way) is crashing.

While I’ve never owned an RTX card, I’ve had the compositor crash on my system numerous times since Plasma 5.21 with a GTX 1060 6GB. I don’t get the crashes anymore as I’ve since swapped to a Radeon RX 570. AMD cards have much better Plasma support than Nvidia because of their officially supported open source graphics drivers.

Unfotunately, it’s a known issue that Nvidia drivers don’t play well with KDE Plasma. You can continue to troubleshoot this like I did, but if you can’t get to a feasible workaround in the end and still want to use Linux, you’ll have to switch to another desktop environment that already has decent Nvidia driver support or replace your RTX card with an AMD equivalent if you choose to stick with KDE.

1 Like

I have an older GTX 960 and never failed me, so i should think the issues are only for the newer models or something that users do?

1 Like

It could be more of a newer model thing because no matter what compositor or Nvidia settings I set back when I still had that GTX 1060, KWin still crashes every so often with the compositor turned on. Besides, I’ve never tried using Manjaro KDE with a Nvidia GPU older than the 10 series such as a GTX 960, so I can’t comment on that.

I set those settings and will see if that works out. Only difference I had was “accurate” instead of “smooth” scaling

My conf is here:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 465.31

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       31.0 - 70.0
    VertRefresh     57.0 - 63.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

Sorry I was not sure if it was the compositor or another component causing the issue. That is sad to hear, if the remedies provided don’t work I might try Xfce. I guess I’d have to find out if that has any nvidia issues as well. At least my experience with Gnome on ubuntu was fairly smooth.

Here’s my compositor settings. Unfortunately I still have some crashes happening.

Ok, see if doing this changes things for you:

1 Like

I have used a GTX 960, 1060, 2060s, and now a 3080 all on Plasma, no issues to speak of.

Please point to the bug report.


This is the closest I can find in terms of KWin’s compositor crashing under Nvidia drivers, and it was first reported earlier this year:

432570 – kwin_x11 crash randomly in KWin::SceneOpenGL::createScene()

In addition, there are quite a few bug tickets related to poor performance with Nvidia drivers; here’s one of them:

414785 – Notifications cause lag/freeze in plasmashell and apps when using an NVIDIA GPU

I forgot to mention that KWin actually stopped crashing for me after turning off the compositor. I had to live with that until I switched to the AMD card I have now.

Looking through this there are quite a few possible fixes:

  1. Enable triple buffering:

added the following to ~/.config/plasma-workspace/env/kwin.sh:

export __GL_YIELD="usleep"

Then chmod +x the file. This script will be run automatically at startup.

Secondly, I added the following to /usr/share/X11/xorg.conf.d/10-nvidia.conf:

Section "Device"
    Identifier "Videocard0"
    Driver     "nvidia"
    Option     "TripleBuffer" "true"

Then restart.

  1. Looks like I solved this problem:
1. End kde session (if running).
2. You need to remove ~/.config/kwinrc
3. Log in to kde.
4. Everything kwin no longer crashes
(This is works for me)

Worth a try