KDE Plasma BUG: Unreliable Taskbar Action

This is the scenario: I have random windows open, firefox, konsole, etc, and do my stuff in linux, and go to click the firefox icon to maximize my firefox app. I fully expect this action to MAXIMIZE my currently MINIMIZED firefox window…however, it OPENS up a new window with every click. This does not happen all the time, but it happens about half of the time and it is a terrible thing. Has anyone amended an issue like this where their taskbar windows open new instances of apps instead of maximizing the minimized, currently loaded app windows? Any help would be greatly appreciated. Thanks.

In many years of using KDE I never encountered such issue. May your compositor disable/crash and that triggers the issue?

//EDIT: I tried to disable my compositor (SHIFT+ALT+F12) and it still works as intended so it doesn’t seem to be the issue.

That’s a new one - though I confess I hate having to click on icons, so I use 'Toggle Present Windows which is bound to a mouse shortcut to bring up windows (including minimised) for me to choose the one I want.

Did you test in a new TEST user desktop?

Not sure how to determine if I’m a test user…is there a way to configure that specifically or is it by default?

You create a new user, and you login as this test user, and you test. If you can’t reproduce the issue on test user, then the issue lies in your normal user files.

Does this bug out more if having virutal desktops enabled? I have 4 virtual desktops for my desktop environment set…

Ah ok, I’ll try that out. By the way, this problem isn’t just for firefox. Also happens when I click on FreeCAD, Brave Browser, etc.

GIMP, in some cases, when I work on it and click through other apps, will disappear entirely (the active app indication on the taskbar will disappear)

It doesn’t matter if it does it with multiple apps. See if you can reliably reproduce the issue on a newly created, unmodified, test user.

Also provide your system information

inxi -Fazy

Open a new instance seems to be the action when the SHIFT key is pressed when clicking the icons. Do you have, by any chance, some problem with the SHIFT key?

I can’t find any setting in KDE settings to make that the default (without SHIFT)

  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=c5936b65-b9c0-4190-9991-83cbfe3054fa rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.3 tk: Qt v: 5.15.3 wm: kwin_wayland vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: GS76 Stealth 11UG v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-17M1 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: E17M1IMS.114 date: 10/25/2021
  ID-1: BAT1 charge: 17.9 Wh (19.2%) condition: 93.1/95.0 Wh (98.0%)
    volts: 14.5 min: 15.2 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: discharging
  Info: model: 11th Gen Intel Core i9-11900H bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x3C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 800 high: 801 min/max: 800/4800:4900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 801 4: 800
    5: 801 6: 801 7: 800 8: 801 9: 801 10: 801 11: 800 12: 800 13: 801 14: 800
    15: 801 16: 800 bogomips: 79888
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Micro-Star MSI
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4
    bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q]
    vendor: Micro-Star MSI driver: nvidia v: 510.54
    alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:249d
    class-ID: 0300
  Device-3: Acer HD Camera type: USB driver: uvcvideo bus-ID: 3-11:3
    chip-ID: 5986:2127 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: with: Xwayland v: 22.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa gpu: i915,nvidia display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0401
  Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228b
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek Killer E3000 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 59:00.0
    chip-ID: 10ec:3000 class-ID: 0200
  IF: enp89s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
    driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 5c:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp92s0 state: up mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:6 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 953.87 GiB used: 112.96 GiB (11.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 3400 MTFDKBA1T0TFH
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P7MA000 temp: 31.9 C scheme: GPT
  ID-1: / raw-size: 97.7 GiB size: 95.61 GiB (97.86%) used: 55.44 GiB (58.0%)
    fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
    used: 25.7 MiB (8.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 364 Uptime: 35m wakeups: 3437 Memory: 31.06 GiB
  used: 4.51 GiB (14.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1392 pacman: 1385 lib: 387 flatpak: 0
  snap: 7 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.15

Shift + left Click on an app in the taskbar just maximizes it for me, haha. Maybe im in the twilight zone and need help getting out of here. HELP!

After you test on another user (this is what you need to do NOW as this is the best thing currently to troubleshoot your issue), if you can reproduce the issue on the test user, try to change the display server. I see you are using Wayland currently, maybe there is an issue with that (hard to see why but just a guess), try to logout, and select the X11/Xorg session instead of the Wayland session and log back in, see if issue persists.

If the issue doesn’t exist on the test user, then we can start other things as it will most likely be wrong configuration/files in your Home folder.

Ok, will do, away from my linux machine, at the moment, although this was an image in my image repository on the local linux machine (you can see how many firefox tabs opened just from constant clicking,hoping that the original instance would maximize):

Create a NEW user - then a new profile with standard settings (Default desktop - fresh and clean) will help you check if it’s your own /home that’s messed up.

Thanks Ben! Will do.