KDE Plasma appears bugged after 17/05 testing update

Opening this thread as per suggestion of other forum members.
After the testing update that went live on the 17th of May, kde plasma bugs out every boot. Namely, sytem tray stops working correctly (nothing gets added), trying to edit any setting in System Settings makes plasmashell fully lock. This issue gets reverted by downgrading to the last stable update (13th of May).

Hardware is nvidia 1060 (3gb) running latest proprietary drivers, kernel 5.17. Will update the thread with journal after reboot.


After latest (21st of May) update, issue persists.
Output of hwinfo --gfx reads

~ > sudo hwinfo --gfx
[sudo] password for ------ : 
28: PCI 600.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.386]
  Unique ID: vTuk.p5J2H1IVo+6
  Parent ID: w+J7.mexhps_MX6B
  SysFS ID: /devices/pci0000:00/0000:00:03.1/0000:06:00.0
  SysFS BusID: 0000:06:00.0
  Hardware Class: graphics card
  Model: "nVidia GP106 [GeForce GTX 1060 3GB]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1c02 "GP106 [GeForce GTX 1060 3GB]"
  SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
  SubDevice: pci 0x3724 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xfb000000-0xfbffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xe0000000-0xe1ffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 98 (42673 events)
  Module Alias: "pci:v000010DEd00001C02sv00001458sd00003724bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #7 (PCI bridge)

Primary display adapter: #28

Output of sudo journalctl -b0 -p4: journal - Pastebin.com

Are you switching branches like there is no tomorrow ? Please don’t say you also switch between KDE-Git and the default KDE packages …
I noticed this in your journal

mai 21 17:35:58 mauricioquintela kstart5[2553]: Omitting both --window and --windowclass arguments is not recommended

that might be related to whatever this scrips/desktop files might do at startup

mai 21 17:32:53 mauricioquintela plasma_session[945]: org.kde.plasma.session: could not start "/home/mauricioquintela/.config/autostart/mathpix-snipping-tool.desktop" : "" ()
mai 21 17:32:53 mauricioquintela plasma_session[945]: org.kde.plasma.session: could not start "/home/mauricioquintela/.config/autostart/nvidia_pm.sh.desktop" 

Anyway … Did you tried this?

1 Like

Are you switching branches like there is no tomorrow ? Please don’t say you also switch between KDE-Git and the default KDE packages …

No, I am not. I normally run testing full time, tried stable when this issue showed up and realized it fixed the issue.

Regarding mai 21 17:32:53 mauricioquintela plasma_session[945]: org.kde.plasma.session: could not start "/home/mauricioquintela/.config/autostart/nvidia_pm.sh.desktop" , this script no longer does anything. Was previously in place to set power limit for GPU on boot, but it’s now empty. Still, I have now removed it.

The second script was auto-generated by kde when adding a program to autostart. If relevant, it reads

[Desktop Entry]
Comment=Mathpix Snipping Tool
Name=Mathpix Snipping Tool

Regarding creating a new user, I tried it when the issue first appeared (17th) and it didn’t help. I will try again now and update the thread, something might have changed.

Just created a new user again, can confirm issue is not present when using a blank account. Any suggestions of logs I can gather that might shed some light on what the issue is?

Thanks for posting your plight. I ran into a similar issue today after updating. It seems the issue is related to kde session management. It works in a new user because they have no prior sessions. Everything works fine from the command line, so it’s not kernel or modules. And to be clear:

I couldn’t login to wifi via Network Manager, because the auth prompt didn’t appear nor could secrets be opened to decrypt the wifi password.

I reset my session back to default and everything works again for me. Maybe not the exact issue you’re seeing. I moved ".config/session to ~/.config/session.old, restarted and all works. I probably only had to logout/login again, but I figured a restart wouldn’t hurt.

I then reconfigured the plasma settings back to what I wanted, saved the session, and everything still works.

Hope this helps.

1 Like

My .config/session directory only contained 1 file, which was related to the tabs open in dolphin.

I fully reset my kde user settings following a previous thread How reset all KDE settings? - #3 by Centrin0 and the issue still remains. Are there any additional configuration files that I must remove to fully reset?

EDIT: Found another thread, the steps discussed here (Panel not remembering settings after reboot & screen edges not working - #7 by brahma) managed to fix my issue.

1 Like

See, now it’s fixed :innocent:

1 Like

Still somewhat curious on what might have caused the issues. A setting that dissapeared causing kde to panic? Some file that got corrupted causing problems? Gonna keep this solution in mind in case it happens again for some reason.

In my KDE life I had a random issue (can’t even remember what) and doing similar things (nuking every plasma config file I could find) fixed the issue.

Now to know what was the issue you could have kept all deleted files and compared them to new generated ones. Or maybe you’ll end up configuring/installing the same thing that had an issue later and understand.

But on a brighter side, you now have a clean KDE to start with. Enjoy no more crashes :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.