KDE Plasma 5.19.5 + systemd 246.4 = Missing "Switch User" option

For anyone experiencing a missing “Switch User” option under the “Leave” menu after the latest updates,
seems that this is a bug, appearing with the Plasma 5.19.5 + systemd 246.4 versions.

As a workaround,
downgrade systemd
to the previous version (245.6 on my system) + reboot fixed it for me - decided to share.

Thx.

1 Like

:+1: Welcome to Manjaro! :+1:

And thank you for sharing with the community. However could you split that into a question and an answer and then mark your own answer as a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

:innocent:

Just to clear this up.

This is not a fix, but rather a workaround, that might make other stuff not work. Especially if you only downgrade the systemd package, and not the systemd-libs and systemd-sysvcompat packages aswell.

1 Like

Agree, but luckily haven’t notice any problems by doing that . And it was the only option to keep the laptop usable. I was hoping that this problem would be sorted by an update soon, however latest big update did not solve it - just checked - had to downgrade back to 245.6-8 . Beyond me how such bug would pass any QA process but… oh, well …

I am also interested in knowing if this is a bug, a feature and if its something that has a fix more than a workaround.

There is currently a bug in plasma, so just do it the old-fashioned way: (always works even without “switch user”):

  • Switch to TTY2 with Ctrl+Alt+F2
  • log in there
  • type startx
  • now you can switch between user1 and user2 with:
    Ctrl+Alt+F1 and Ctrl+Alt+F2
  • repeat with Ctrl+Alt+F3, F4, … for more users.

:+1:

1 Like

Is there any proper fix for this yet? Switch user has been missing for several months! Can’t understand why a key function has just disappeared.

1 Like

Yep, please fix this. I’m not smart enough to know where or how this happens, but my wife is pissed when she can’t login because I remained logged on. It used to not be an issue, now that option to switch user is not there.

2 Likes

My apologies, but as people seem to be still bitching and whining upset about this, I’ve marked my simple workaround as a solution because that’s how we used to do things before we had a Switch User button and once you get used to this way, you’ll forget you ever needed such a button…

:innocent:

According to this bug report this should be fixed in 5.20, but the last post there does disagree. Still lets hope this is fixed soon, as my wife regularly wakes me up to get into her session and refuses to learn shortcuts with 3 buttons :sweat_smile: