KDE Plasma 100% global scale does not work for Qt apps

I have been using KDE Plasma for a while now, with the global scale set the default to 100%. Recently, probably following a reboot after an update, I noticed that all KDE programs (including the start menu, taskbar, switcher, settings and the decoration on windows etc.) as well as all Qt based programs suddenly got scaled up to what looks like 125%. Other programs, like Firefox, Electron apps remain unaffected.

Increasing the global scale to 125% and beyond seems to affect all programs correctly, it is only 100% that behaves strange.

Here’s what I tried so far to no effect:

  • Rebooting, multiple times
  • Updating
  • Trying out testing and unstable branches
  • Resetting plasma config (cd .config && mv *rc plasma-old/ && mv kdeglobals plasma-old/) and rebooting
  • Setting QT_SCALE_FACTOR globally to a number lower than 1 - this broke a lot of things

Does anyone know what might be causing this? I saw a few older questions with similar issues, but those were reported resolved by updates.

Thanks in advance for any help!

Do you have any other QT env var settings interfering?

echo "$QT_FONT_DPI"

(I think thats all of them…)

I noticed the same with a newly installed Manjaro. Qmmp, in my case.

CPU: 12-core AMD Ryzen 9 7900X (-MT MCP-) speed/min/max: 3123/3000/5650 MHz
Kernel: 6.1.29-1-MANJARO x86_64 Up: 3h 14m Mem: 7140.7/63442.8 MiB (11.3%)
Storage: 4.14 TiB (12.3% used) Procs: 426 Shell: Zsh inxi: 3.3.27

I had Global Scale set to 125% for a while and then I switched back to 100%. I increased Font DPI to 120.

I tried the Qt env vars from the post above:

 ~ echo "$QT_FONT_DPI"                                                                                                                                                                   

 ~ echo "$QT_SCALE_FACTOR"                                                                                                                                                               

 ~ echo "$QT_SCALE_FACTORS"                                                                                                                                                              

 ~ echo "$QT_SCREEN_SCALE_FACTORS"                                                                                                                                                       
 ~ echo "$QT_AUTO_SCREEN_SCALE_FACTOR"                                                                                                                                                    
 ~ echo "$QT_AUTO_SCREEN_SCALE_FACTORS"                                                                                                                                                  

I cannot add screenshot nor a link to a screenshot yet. Anyway qmmp is scaled and has strange white area (compared to a qmmp-skin in gwenview where it is 100%) .

Thanks for help.

OK, I can insert link like this: [Ukázka kódu](https://i.postimg.cc/QMMR25TR/qmmp2.png)

Also, I tried qt5ct but this tool does not offer any scaling-related options.

V .

After some investigation I found solution. Qmmp 2.1.2 is based on Qt 6.5 and important environment variable is QT_FONT_DPI. It works quite well but some values causes visual glitches.

$ QT_FONT_DPI=96 qmmp

starts Qmmp unscaled.

$ QT_FONT_DPI=120 qmmp

starts Qmmp scaled to 125% which causes glitches. Values 144 or 192 (i.e. 150% and 200%) works well.

I needed to run Qmmp from application launcher so I wrote a simple script:


QT_FONT_DPI=118 qmmp "$1"

This script starts Qmmp scaled, without visual glitches and with argument so I can click *.flac in Double Commander and start music playing in Qmmp.