KDE panel is not showing active windows

My panel(task bar) isn’t showing active windows, so i only can switch between windows with shortcuts.

Welcome to the forum!

What you first and foremost need to understand is that the panel and the task bar are not the same thing. In Plasma, the task bar is a widget on the panel, and I’m guessing that you have accidentally removed the task bar widget from your panel.

Right-click an empty spot on your desktop and choose “Enter Edit Mode” from the popup menu. Then right-click the panel and choose “Add widgets”. You will get a list of widgets on the left, and the ones that are already on the panel will show a number next to them.

If the task manager is not on the panel yet — there are two to choose from, i.e. a “classical” one and an icons-only task manager — you can drag it onto the panel. However, take note, because there may be a window list entry on the panel already, and this window list is one of the “alternative options” for the task managers. Right-clicking any widget on the panel will always allow you to choose one of the alternatives, and there’s a chance you did that earlier.

Once you’re done, right-click your desktop again and choose “Exit Edit Mode”.