KDE Night Color seems to follow UTC instead of my timezone

Like the title says.

I am on CEST (UTC+2)

Nightcolors work, but are now (in winter time witch is why I noticed it) 2 hours behind.
The times on the settings tab shows correct time, but the colors clearly are 2 hours behind.
I have dualboot window, but Idc if it breaks windows time at this point, I want to go back to “default” settings if that is what is doing this.
Is there a way make nightcolors follow CEST instead or how do I revert to linux only time, so to say?

timedatectl
               Local time: Tue 2023-10-10 19:52:19 CEST
           Universal time: Tue 2023-10-10 17:52:19 UTC
                 RTC time: Tue 2023-10-10 17:50:32
                Time zone: Europe/Stockholm (CEST, +0200)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode cannot be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.
$ inxi -Fazy                                                                                                                                                                                           ✔ 
System:
  Kernel: 6.5.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.5-x86_64
    root=UUID=700d034d-b99a-482b-880b-9060acf3a6b3 rw rootflags=subvol=@
    nvidia_drm.modeset=1 resume=UUID=5ae8fbf5-a704-41ea-be6d-bf26b38325ed
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: X670 AORUS ELITE AX v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F11a
    date: 07/21/2023
CPU:
  Info: model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 400 min/max: 400/5733 scaling: driver: amd-pstate-epp
    governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400
    8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400 15: 400 16: 400
    17: 400 18: 400 19: 400 20: 400 21: 400 22: 400 23: 400 24: 400
    bogomips: 225241
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow mitigation: safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com. driver: nvidia
    v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-23 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none empty: DP-1,
    DP-2, DP-3, HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
  Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: HDMI-A-2 empty: DP-4,DP-5,DP-6
    bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 51.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: Asus VX279 serial: <filter>
    built: 2015 res: 1920x1080 hz: 60 dpi: 79 gamma: 1.2
    size: 621x341mm (24.45x13.43") diag: 690mm (27.2") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: radeonsi inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics
    (raphael_mendocino LLVM 16.0.6 DRM 3.54 6.5.6-1-MANJARO)
    device-ID: 1002:164e memory: 500 MiB unified: no
  API: Vulkan v: 1.3.264 layers: 9 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 3090 driver: nvidia v: 535.113.01
    device-ID: 10de:2204 surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 23.1.9-manjaro1.1 device-ID: 1002:164e surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA GA102 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 15:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 15:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.6-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0f:00.0
    chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp15s0 state: down mac: <filter>
Bluetooth:
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:5 chip-ID: 0e8d:0616
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 4.09 TiB used: 1.67 TiB (40.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 46.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 4B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD30EFRX-68EUZN0 size: 2.73 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
Partition:
  ID-1: / raw-size: 122 GiB size: 122 GiB (100.00%) used: 56.07 GiB (46.0%)
    fs: btrfs dev: /dev/sda7 maj-min: 8:7
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5
  ID-3: /home raw-size: 104.53 GiB size: 104.53 GiB (100.00%)
    used: 48.97 GiB (46.9%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
  ID-4: /var/log raw-size: 122 GiB size: 122 GiB (100.00%)
    used: 56.07 GiB (46.0%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 38 GiB used: 768 KiB (0.0%) priority: -2
    dev: /dev/sda6 maj-min: 8:6
Sensors:
  System Temperatures: cpu: 76.4 C mobo: 35.0 C gpu: amdgpu temp: 52.0 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 525 Uptime: 6h 34m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 30.5 GiB used: 11.09 GiB (36.3%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1551 pm: pacman pkgs: 1544 libs: 430 tools: pamac,yay pm: flatpak
  pkgs: 7 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.30

Edit
I wasn’t sure where to put this question, if its fixable through nighcolors I guess it’s correct. If I have to configure time, I guess it should be in a completely different category. Sorry mods.

To change the hardware clock time standard to localtime, use:

# timedatectl set-local-rtc 1

To revert to the hardware clock being in UTC, type:

# timedatectl set-local-rtc 0

https://wiki.archlinux.org/title/System_time

I tried that, but it does not want to change. :frowning:

Still throwing the warning and saying it is set to 0.

I even rebooted to see if that would change anything.

$ timedatectl
               Local time: Tue 2023-10-10 20:18:08 CEST
           Universal time: Tue 2023-10-10 18:18:08 UTC
                 RTC time: Tue 2023-10-10 20:18:08
                Time zone: Europe/Stockholm (CEST, +0200)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode cannot be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.

$ timedatectl set-local-rtc 1
$ sudo systemctl daemon-reload
$ sudo systemctl restart systemd-timesyncd.service

$ timedatectl
               Local time: Tue 2023-10-10 20:18:32 CEST
           Universal time: Tue 2023-10-10 18:18:32 UTC
                 RTC time: Tue 2023-10-10 20:18:32
                Time zone: Europe/Stockholm (CEST, +0200)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode cannot be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.

Is NOT following the standard, ie set to 0 the “default”?

It’s saying set it to 0, ie run the cmd.

Considering the warning, I have to wonder if night color may work correctly if you switch to UTC.

Therefore you need to change to UTC in Windows, how-to, is covered in the link provided by @Olli

UTC in Microsoft Windows

To dual boot with Windows, it is recommended to configure Windows to use UTC, rather than Linux to use localtime. (Windows by default uses localtime [2].)

1 Like

Ait, I’ll set it to 0, but I thought that was the “non standard”.
I set it to 0, tried it with custom times and that seems to work, I have to wait until morning if the location service works.

About Windows, that is about to get removed, when I need the hd space, I don’t care about it any more.
The second it causes problems for me, it goes out the “window”… xD

I suspect that it won’t. There was a bug report about it at the PCLinuxOS forum a while ago, whereby the night color clock is always off by one hour and doesn’t seem to honor daylight savings settings.

The post was from a US American member of the PCLOS forum, and the US switches daylight savings time at different dates compared to Europe. They’ve already gone back to “winter time” — or standard time, if you will — at the start of October, while for us it’s on the last weekend of October.

Still, you can keep an eye on it and see whether you experience the same thing. :man_shrugging:

In Windows, apply the following in a registry file:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
 "RealTimeIsUniversal"=dword:00000001
 

You may need to adjust the time once or twice, after a reboot, but after a subsequent reboot all should be woking as expected. Cheers.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.